Jump to content
About Just Joined group Read more... ×
Andres ZeroCross

macOS High Sierra 10.13.4 Build 17E199 at Asus A455LF-WX159D

5 posts in this topic

Recommended Posts

A. Notebook Specifications

Name : Asus A455LF-WX159D

Processor : Intel Core i3 5005U

IGPU : Intel HD Graphics 5500

Discrette GPU : Nvidia GT930M

RAM : 8GB PC12800/1600Mhz

Wifi Card : Atheros AR9565

Bios Version : 300

Audio Codec : Conexant

Storage : Samsung SSD 850 Evo 500GB

Boot Mode : UEFI with CSM Disabled

 

B. How To Install 
 

  1. I am not good for make a tutorial, so i upload my CLOVER folder (zipped), just use it :D (overwrite your USB Installer's Clover Folder)
  2. Set SATA Controller to AHCI at BIOS
  3. Make sure your BIOS version is "300"
  4. Set DVMT to 64MB
  5. XHC set to "Smart AUTO"

C. Make a USB Installer with CreateInstallMedia method, install Clover Bootloader R4423 or above, then delete Clover Folder inside it and replace with mine

=======

SPECIAL NOTE

D. Normally for broadwell IGPU (IHD 5500), you only need to Inject Intel and set ig-platform-id=0x16160002 or 0x16260006. But some notebook will face RANDOM KERNEL PANIC or STUCK at IGPU log (hang) when you inject ig-platform-id. This is not DVMT Pre-Allocation Problem. I found the solution :D Just set FakeIGFX to 0x16268086, Tick Inject Intel and set ig-platform-id as 0x16260006 or 0x16160002. Now you will get QE/CI :D For me, i set those values at SSDT-1.aml (check my attachment file)

======


Whats Working??
- QE/Ci

- Audio OUT and Mic

- Wifi Card

- LAN Ethernet

- Battery Indicator

- Fn + Brightness Button

- Touchpad

- Sleep, Restart and Shutdown

- All USB Port (High Speed and Super Speed)

- Battery Indicator

- Etc

 

Thanks :)

 

My Clover Folder's Link : https://drive.google.com/open?id=1qzvT155DZ1r8cI0ceBW4OjWAEMUu491-

Screen Shot 2018-04-06 at 22.26.13.png

Screen Shot 2018-04-06 at 22.26.32.png

Screen Shot 2018-04-06 at 22.27.31.png

Screen Shot 2018-04-06 at 22.28.02.png

Screen Shot 2018-04-06 at 22.29.02.png

Screen Shot 2018-04-06 at 22.29.37.png

Screen Shot 2018-04-06 at 22.30.51.png

Edited by Andres ZeroCross
Add Clover Folder

Share this post


Link to post
Share on other sites
Advertisement
use your settings on my Asus X540L and get only black screens to the point of not having video.

 

You would help me compile my DSDT and SSDT.
Edited by Bernardo415

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By 83427
      I'm member of this community for 10 years and now I feel I can finally somehow help to other beginners like me, who has the same or similar hardware like me. 
       
      Here is my EFI partition with OpenCore 0.6.1 configured for 
      Asus Maximus VI Formula (chipset Z87)
      Intel Core i5-4670K @ 4GHz
      32GB DDR3 1600MHz
      Sapphire Radeon RX480 4GB
       
      I removed SN, UUID and others unique values from config.plist so don't forget to fill yours own or generate new. For beginners like me is very useful OpenCore Configurator
       
      Its compatible with macOS Catalina. I'm not sure, but I think that Mojave works also.
       
      I spent a lot of time by resolving problem with integrated sound card (Realtek ALC1150). If you have problems with sound, try another layout number via alcid=XX in boot-args. For Maximums VI Formula value 5 match the best I think. For more info how to fix soundcard read here: https://dortania.github.io/OpenCore-Post-Install/universal/audio.html 
       
       
       
      EFI.zip
    • By HerryYT
      I own a asus eee pc 1025c with patched bios to support x64 os, is it possible to install any version of mac os even with patched kernel? anyone interested in helping? 
    • By rvilbert
      Good evening,
       
      I apologies for the broadcast message but i have decided to reinstall my Hackintosh machine using Catalina 10.15.6 and .... I'm stuck at "PCI configuration begin".. 
       
      My configuration is:
      Asus X99 Deluxe Core i7 5960x 32 Gb memory GTX 980  
      Knowing that my graphic card would not be fully recognised in Catalina i have also tried to install High Sierra but I managed to get exactly to the same point  and i have therefore decided to give another try to Catalina and .... I'm still stuck.
       
      (FYI I had managed to install 10.8 on my machine a while ago but a few things have changed since then and I may be missing a trick).
       
      In a nutshell I believe my issue is linked to this message that i'm getting:
       
      Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourcesMatch</key><string ID="2">boot-uuid-media</string></dict> 
       
      I tried all options (with/without flags and with/without kext) but i think that my issue is between my DSDT, SSDT and config.plist files.
       
      Any help would be much appreciated!
       
      I have attached my EFI folder and the print screen with the error message.
       
      Let me know if you need any further information.
       
      Thanks a lot
       
       
       
       

      EFI.zip
    • By macinsane
      *This guide is deprecated and will not be maintained anymore*

      Update: Now running Mojave! Thanks to mojave2core! Yeah   Still using C2D in 2019!
      Inserted a nice and cheap GT710 that is not relying on nVidias Webdrivers and runs OOB under Mojave.
       
      Nice, seeing High Sierra running on this old but capable system! It rocks with a new ASUS GT1030
       
      Config:
      Gigabyte EP43-DS3L
      Core2Quad Q9300
      6 GB DDR2 RAM
      Asus GT1030 2GB
      Sandisk SSD 128GB
      TP-Link AC1200 Wifi USB
      Inateck KT4006 USB 3.0 PCIe (No boot)
       
      SMBIOS: iMac14,1
      Clover: 4297  4360
       
      A good deal of DSDT editing was necessary to get this machine to boot High Sierra but finally it works flawlessly, even sleep and wake!
      You NEED to have the DSDT put in place for installation because otherwise macOS doesn't recognize the SATA ports.
      There are a few important BIOS settings: SATA hast to be set to AHCI and "native" and HPET has to be run "64-bit", I'd recommend to disable IDE and the serial and parallel port.
      For the GT1030 nVidia Webdrivers are needed, have to boot with nv_disable=1 until you have them installed.
      You have to install Clover in legacy mode because this old fella does not support UEFI.
       
      Only downside: The so often recommended Inateck USB-card isn't recognized by BIOS, so you cannot boot from it. It works perfectly within macOS though, have the ac-Wifi connected to it.
      config.plist.zip
      DSDT.aml.zip
    • By VortexisTV
      I'm trying to enable UHD 620 graphics on my laptop since it's almost impossible to use Catalina with it disabled (freezing), so after I followed this guide, every time I try to boot into Catalina it does get stuck at the apple logo and progress bar. Heres also the EFI if anyone wants to look at. I'm using this UHD 620 plist to try to get my graphics to work.
       
      ASUS Zenbook UX331FN
      i5-8265U
      Intel UHD Graphics 620
      8GB of SDDR4 Ram

       
×