Jump to content

Bluetooth Hackintosh


70 posts in this topic

Recommended Posts

3 minutes ago, MARZILLO said:

non è un buon metodo quello che usi...per provare ok ma se vuoi un sistema stabile io consiglio una nuova installazione seguendo la guida di gengik...ne approfitti pure per dare una ripassata...hai un secondo disco?

Purtroppo no, questa è la brutta notizia,

la buona notizia è che ho appena trovato il video che riguarda il mio problema :

Questa pennetta ha finalmente un nome ed è la Cambridge Silicon Radio (tra l'altro negli screen che ho fatto con Windows c'è questa marca), ho fatto come dice nel video scaricando il pacchetto che indica qui :

https://www.tonymacx86.com/threads/bluetooth-not-showing-working-cambridge-silicon-radio-0x0a12.239985/

Anche se con non buoni risultati visto che non ho risolto, ma probabilemente come sempre non ho fatto bene io.

Se prima avevo solo speranze, ora sono sicuro che posso combinare qualcosa con questa pennetta qui su Mac :D

Ah, ho appena scoperto che Hackintosh la rileva tra gli USB

screenshot_86.png.0f99b2bef4c7f5d5ac530117a4003779.png

quindi c'è tutto, ora manca solo una buona configurazione !

1 minute ago, MARZILLO said:

dovresti togliere tutti quei kext di cui hai fatto un'ammucchiata come tu hai scritto sopra...ripara i permessi

Riparati sia da utility e sia da kext wizard, va bene ora ci provo! Comunque un'altra cosa che mi sono scordato di scrivere è che nel video il tizio ha 10.10.5 esattamente come il mio 10.10.5 e ad inizio video ho notato che la pennetta che inserisce nel PC è identica alla mia, ho grosse speranze, ora faccio tutto. I kext da dove li installo ? Va bene Kext wizard ? Nel pacchetto di questo tizio c'è Kext Utility e consiglia di usare o questo, o come fa lui nel video EasyKext.

1 hour ago, MARZILLO said:

va bene anche kext wizard...installa in s\l\e....kext wizard ha anche l'opzione di riparare i permessi...seconda schermata

Niente, ho fatto tutto installando anche ad uno ad uno i 4 kext riparando i permessi ad ogni installazione.

Ho notato però che dopo aver installato i kext quando vado a vedere le port USB ora la riconosce col nome della marca "Cambridge Silicon Radio Ltd."

screenshot_89.png.8f9eabdffac5212d62b72cf4fc6a5477.png

 

Mentre nella foto che ho postato prima di installare questi kext lo trovava come "Apple Inc." e basta.

 

Ora ho pensato, ma non è che ora ho bisogno dei kext per la cassa ? E' una JBL GO e non avendo il mac originale non capisco se l'icona Bluetooth sul mac spunta solo quando ci sono dei Bluetooth nei dintorni  o se è sempre fissa.

Cosa posso fare ?

Non ci posso credere ce l'ho fatta !

Ho fatto grandi passi girando un bel po' sul webbo. Questo tizio mi ha risolto gran parte del mio problema :


https://www.tonymacx86.com/threads/ebay-usb-bluetooth-adapter-csr-not-working-help.63758/

Quindi ho fatto come ha detto lui e ho cancellato i due kext che erano nei contenuti di uno dei quattro kext del video che ho visto prima, poi ho creato la cartella extra/extensions (che non esisteva prima) e ci ho buttato l'altro kext che dice sempre lui. Risultato ? Riavvio il pc e :

screenshot_91.thumb.png.e5c3297ad830ae5f0dad75c56f442fd9.png

Direi che ci sono quasi, eccetto che non riesco a sentire la cassa, nonostante ora l'abbia persino rilevata (dopo taantissimi tentativi) e sono in questa situazione :

 

screenshot_92.png.92d8460c2c301817240bb9c04fba8693.png

 

Ma non riesco proprio a far sentire la musica, e in preferenze sistema/audio non me lo trova proprio, mancherà un kext appunto audio per questo ?

Il risultato che ho è già impressionante, pensavo fosse solo un pezzo di ferro ma mi sta dando grandi risultati :D

Chiunque ha avuto il mio stesso problema con questa chiavetta può risolvere seguendo qua :D 

complimenti...devo dire che la tenacia paga....visto il poco costo di una bt400 io l'avrei cambiato immediatamente....però vuoi mettere la soddisfazione....

se funzionasse appieno l'audio ti apparirebbe in preferenze di sistema\suono 

6 hours ago, MARZILLO said:

complimenti...devo dire che la tenacia paga....visto il poco costo di una bt400 io l'avrei cambiato immediatamente....però vuoi mettere la soddisfazione....

se funzionasse appieno l'audio ti apparirebbe in preferenze di sistema\suono 

Esatto appunto su sistema/suono non riesco a trovarla ! "Sei già fortunato che ti funzioni su windows" Sicuramente il fatto che su windows funzionava mi ha caricato a mille sperando di trovare una soluzione anche per mac, e infatti avevo ragione :D ;)

 Comunque quando mi hai detto di eliminare tutti i kext che aggiunto a casaccio, per sbaglio ho eliminato proprio tutto che riguardava i bluetooth nella cartella extension, tra cui questo file : AppleMIDIBluetoothDriver.plugin che risaliva all'installazione di Hackintosh fatta nel 2014, sarà questo il problema ? Ho eliminato un componente software Audio/Bluetooth ? Se si è un .plugin e non .kext , posso reinstallarlo con kext wizard ?

Non sono comunque sicuro sia questo il problema, quale può essere una soluzione ? Mi sa che ora il bluetooth è configurato bene, ora è una questione di audio dell'hackintosh, nemmeno in Utility/Configurazione Midi Audio lo trova ? Cosa posso fare ? :( 

nella cartella extension puoi anche copiarcelo e mi sembra anche che non è necessario sistemare i permessi...però fallo uguale...

il problema non è audio,se funzionasse ti ritroveresti nelle preferenze il nome della cassa collegata quindi è il bluetooth non va...potrebbe anche dipendere dalla tua installazione magari confusionata...vai a saperlo..

cerca di rimediare un secondo disco cosi non tocchi la tua e provi una seconda installazione

3 hours ago, MARZILLO said:

nella cartella extension puoi anche copiarcelo e mi sembra anche che non è necessario sistemare i permessi...però fallo uguale...

il problema non è audio,se funzionasse ti ritroveresti nelle preferenze il nome della cassa collegata quindi è il bluetooth non va...potrebbe anche dipendere dalla tua installazione magari confusionata...vai a saperlo..

cerca di rimediare un secondo disco cosi non tocchi la tua e provi una seconda installazione

Beh dai qualche risultato l'ho avuto, eccome :D

Sono sicuro che se ci giro ancora un po' intorno la risolvo una volta per tutte.

screenshot_93.png.452a9ea2282d888c3df95d2df7b9df45.png

Ho notato che da quando ho installato il bluetooth è apparsa da sola questa configurazione nel Network che però non riesco a farla connessa, mentre se vedi la prima che è del Wifi me la da in Verde, può essere anche questo ? Se metto configura dispositivo Bluetooth mi rimanda al alla pagina Bluetooth e non risolvo niente, nelle avanzate è un po' più complesso, sarà quello ?

Per il secondo disco ci ho già pensato, ma non ho problemi con questo, e dopo che ho avuto questa buona notizia ormai tanto vale chiudere qua, no ?

17 minutes ago, MARZILLO said:

ma l'audio ti funziona?intendo le casse interne...se si,con cosa?

Certamente! Ho una scheda audio esterna Microbook della MOTU e anche questa ho i kext appositi, e funziona tutto alla perfezione, ci collego casse e roba varia.

Non so davvero come risolvere sono disperato arrivato al punto di collegarla anche tramite Bluetooth ma non me la trova in "Uscita" in Suono. Cosa sarà ? Io non ci capisco niente

36 minutes ago, MARZILLO said:

difficile dire perche non funziona...non essendo nativo ne hai ottenuto il pseudo funzionamento con qualche trucco,ma non basta a quanto pare...hai fatto quella prova che dicevi...cioe ripristinare il plugin?

Sisi, rimesso subito ma niente. Vorrei capire quando si installa dall'inizio l'hackintosh e quindi si arriva alla configurazione Bluetooth e Audio quali sono i kext necessari ? E' possibile che io ho proprio mancato questi passaggi non avendo mai avuto il Bluetooth come problema e avendo inserito una scheda audio esterna e quindi non essendo mai andato a cercarmi kext vari per sistemare. Diciamo che sono un po' un po' alla configurazione iniziale, qual'è il pacchetto base che mi serve per far funzionare il tutto ? Posso fare gli screen di ciò che ho nelle varie cartelle o vedere cosa manca da quello che dovrei avere appunto.

una volta finita la prima installazione se la periferica è nativa è subito funzionante...altrimenti con un aiutino(kext) lo diventa..quindi se il tuo bluetooth fosse stato riconosciuto sarebbe stato funzionante da subito..se l'installazione attuale ha qualcosa che interferisce con il funzionamento della tua chiavetta puoi starci anni senza capire perche non funziona...da qui il consiglio di provare una nuova installazione su un secondo disco senza intaccare quello esistente seguendo la guida di gengik e usando clover come bootloader...una volta installato vedi se il bluetooth è riconosciuto o no

16 hours ago, MARZILLO said:

una volta finita la prima installazione se la periferica è nativa è subito funzionante...altrimenti con un aiutino(kext) lo diventa..quindi se il tuo bluetooth fosse stato riconosciuto sarebbe stato funzionante da subito..se l'installazione attuale ha qualcosa che interferisce con il funzionamento della tua chiavetta puoi starci anni senza capire perche non funziona...da qui il consiglio di provare una nuova installazione su un secondo disco senza intaccare quello esistente seguendo la guida di gengik e usando clover come bootloader...una volta installato vedi se il bluetooth è riconosciuto o no

Grazie per la risposta, sicuramente la nuova installazione può solo fare bene ma ti ripeto, non mi và di fare una nuova installazione appunto solo per sentire un po' di musica wireless oggi.

Praticamente sono arrivato al punto di rilevare la cassa bluetooth perfettamente, quindi a questo punto non è nemmeno un problema e non ho bisogno come dici tu di un "aiutino" (kext) perché qua sembra proprio che la zona Preferenze di sistema/Suono non sia connessa con la zona Preferenze di sistema/Bluetooth.

In alto dice perfettamente che il bluetooth è attivo e che la cassa (JBL GO) è connessa.

Ma nelle Preferenze di Sistema/Suono/Uscita non c'è, nonostante nelle preferenze Bluetooth la trova come accessorio Audio, dovrò abilitarla io da qualche parte ?

screenshot_94.thumb.png.5aae8702cf67286d86e8f3d73887d430.png

Addirittura mi trova anche "EZCast-33......" che è una pennetta (una cinesata di Google chrome) quindi mi rileva anche l'audio della zona Wifi dell'hackintosh, ma non del bluetooth.

Devo abilitare forse la cassa da qualche parte per farla rientrare nel sistema Suono ?

Seconda cosa che ho pensato : Sarà che magari ho bisogno di un Utility del bluetooth apposita per l'hackintosh ? Io per il wifi uso un programmino che in effetti mi ha risolto il problema che avevo con la pennetta Wifi che non mi riusciva a connettere l'hackintosh nemmeno con i kexts, ma poi ho risolto appunto con questa girando moolto sul web :

screenshot_95.png.042fcadf4c001ecb6a4d88ad59f8b8a5.png

C'è una utility simile per Bluetooth ? Ho cercato su internet ma niente.

Forse potrebbe essermi utile a sincronizzare meglio nelle Preferenze Suono ;)

Sono sicuro che una delle due cose mi risolve tutto. Perché è quasi fatta ce l'ho davanti e mi dice "Connesso"  qualcuno che mi aiuta ?

 

Per la prima cosa in resoconto sistema mi dà nella voce bluetooth non solo le caratteristiche della pennetta (finalmente) rilevata, ma anche le info del mio telefono, e della cassa, dandola come tipo "Audio"

screenshot_97.thumb.png.e00d46647eb715ce1c031d73b9909a78.png

 

Ma sempre in resoconto sistema Audio non la dà, che diavoleria è mai questa? Sarà che davvero dovrò abilitarla ed è più facile di quanto io possa pensare ?

screenshot_96.thumb.png.6cb334039c561b33aedc8ce6bd47a68f.png

 

Arrivato a questo punto mi chiedo perché fermarmi ? E' tutto sincronizzato, magari sono io impedito che devo solo premere un tasto per collegare il tutto ?

On 23/3/2018 at 9:18 AM, MARZILLO said:

senti,a questo punto sai che ti dico?...prova un'altra cassa o una diversa periferica per vedere se funziona...puo anche darsi che ci sia un'incompatibilità hardware tra le due periferiche

Grazie per la risposta, non so se è questo il problema anche perché mi rileva anche l'iPhone e la cassa è nuova di zecca appena regalatami per il compleanno, sicronizzata con iPhone và una meraviglia quindi penso che il problema sia altro e forse ho capito dopo varie ricerche

Ho appena pensato, ragioniamo su come ho fatto funzionare il bluetooth dal nulla, cartella IOBluetoothFamily.kext e nei contenuti vado ad eliminare questi due, tra cui uno si chiama “CSRBluetoothHostControllerUSBTransport” (CSR è Cambridge Silicon Radio la marca della pennetta)

screenshot_102.thumb.png.90b16e7344032cf98cc1dc8badbb0bc1.png

Quindi l'eliminazione di questi due file mi ha permesso magicamente di vedere il bluetooth nel mio pc (in seguito anche a quell'installazione di un altro kext in extra)

Ora se vado a vedere nell'info.plist di questo kext in extra nella foto giù c'è scritto proprio il file che ho eliminato (in rosso) e ho lasciato invece quello che è dell'altra marca (in blu, Broadcom e CSR ho letto sono le marche più diffuse per chip dei bluetooth dicono), quindi (in verde) nelle info sistema e nella sezione USB leggo che la periferica ha il nome uguale al kext eliminato ma con le parole un po' invertite "Controller host USB Bluetooth"

screenshot_100.thumb.png.70bc9817c1609eb7cb6faa4baa3c09ca.png

 

ora mi fa pensare, sarà che è questo il problema che non mi sincronizza l'audio in bluetooth ? Leggo anche sempre nell'infoplist di una roba tipo di Fake Apple CSR Bluetooth Controller come una specie di controller che mi si dovrebbe visualizzare appunto appena inserita la pennetta ? Se si io non ho visto di niente.

Leggo anche che qui nel forum c'è un tizio che ha creato il kext per CSR e poi una volta scaricato và modificato l'info.plist con i dati del mio venditore e modello :

https://www.insanelymac.com/forum/forums/topic/307181-csrapplebluetoothkext-usb-csr-injection-driver/

Chiedo un aiuto qui al forum italiano qualcuno può darmi una mano a moddare magari il plist per farlo funzionare ? Forse potrei tentare con questo ? Ho letto che molti modificando appunto questo file sono riusciti a far funzionare il tutto Io sono incapace:D

O comunque con tutti questi dati potrei girare su qualcosa che mi porta a farlo funzionare ? Sono sicuro che sta tutto in questa cartella, se rimetto questi file non funziona il bluetooth mentre se li caccio funziona ormai ci ho fatto pure la prova :D

 

 

Edited by Natty
  • 1 month later...

Sono arrivato alla conclusione che non c'è molto da fare con questa pennetta, quindi ho pensato di comprare qualcosa di nuovo, mi è stata consigliata un'altra pennetta ancora, ma avrei intenzione di potenziare il tutto invece comprando uno di quegli Airport per Hackintosh, visto che anche la mia pennetta Wifi è diventata vecchiotta, e che quindi comprenda Bluetooth + Wifi, qualcuno mi consiglia qualcosa? Servono a qualcosa sti Airport ? Quale mi conviene per prezzo/qualità ?

Edited by Natty
×
×
  • Create New...