Jump to content
Sign in to follow this  
Followers 0
battista

VMware Mac Sierra Darvin 2.1.1: Unwanted video resolution 960x600

2 posts in this topic

Recommended Posts

I am using a WIN 10 VMware 14 Workstation solution with Unlocker 2.1.1 and Mac OS Sierra as host image.

 

I have a single 1820 x 1200 monitor.  Graphics ist Standard Intel that comes with the mainboard HDMI and VDI

 

Since the last windows and darvin update I face an unwanted situation that my Sierra image comes up with an unwanted resolution

 

(scaled) 960 x 600 (HiDPI)

 

which is activated by default and cannot be deactivated by switching to the standard monitor screen. The standard monitor screen still exists on 1920x1200 and it is possible to select it out of sierra setup.

 

If you do that what happens then is that the screen swiches to 1920x1200 for one or two seconds, then switches back to 960x600 automatically.

 

This situation is new and wasn't present on windows 10 without update and vmware 12 using the same image and the older darvin that was designed for the 12 version.

 

I see from searches here that I am not the only one who faces this problem of a non deactivateable unwanted lower video resolution.

 

Can you help me please?

post-294465-0-86006600-1512388897_thumb.png

post-294465-0-98781600-1512388910_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

This is the answer I posted in the thread just below this one ("Wrong resolution on VMware")... AFAIK this should work for your resolution too.

 

I was having the same issue with my 10.12 VM in ESXi 6.0.  I would go to display resolution and try to select 1600x900 and it would auto-switch it to 800x450 HiDPI no matter what I did.  I was able to fix it by doing the following:

 

1) Open terminal in the OSX VM

2) Enter the following command (no quotes) "sudo defaults delete /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled"

3) Enter your admin password

4) Restart the VM

 

When the VM restarts it will now go to 1600x900 and the 800x450 HiDPI setting is gone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×