Jump to content

Guide: Start Your Native Hackintosh in Windows via VMWare For Beginners


5 posts in this topic

Recommended Posts

Hi, 

 

this tutorial is about running your physical hackintosh installation in Windows. It's not about setting up a new OS X VM. As always it's very simple once you know, but it however took me a while to figure out the settings, especially using IDE in the VM and using the Clover/EFI partition or not. Luckily, it turned out we have to skip it, so we can leave Clover (or any other bootmanager) untouched.

  

 

What's the point?

If you have to do tasks in Windows, be it mining bitcoins, 3D-rendering, gaming or simply work with a windows-only software, you probably at the same time miss your OS X. 

 

The advantages over a simple new virtual machine running with your personal setup are many: Imagine you can use all your data, listen to your iTunes library, use your installed and configured programs and work with your settings. It also comes in handy when you messed up your installation for some reason and want to conveniently fix it. And last but not least don't forget you save the 25GB minimum space for a virtual disk what is probably not sooo insignificant since (I assume) most of us already switched to SSDs and only a few may have picked the models above 500GB because they are still pricy.

 

tl;dr

Gain advantages by hooking up your existing Hackintosh installation in a VM and work in your personal OS X environment whenever you like, even under Windows.

 

If you have High Sierra with APFS installed it will most likely not work (yet), because Paragon and probably VMWare don't support the filesystem (yet). That being said, let's get started: 

 

 

1. Preparing Instructions

- do all possible reboots as required while installing

- install Paragon HFS+ 11 or above (buy or know where)

- install VMWare Player (free for private use)

- install Unlocker from Insanelymac (free)

 

 

2. in VMWare, set up a new virtual machine 

 

- choose "I will install the operation system later" next >

- choose "Apple Mac OS X" and "macOS 10.12" next >

- choose "Store virtual Disk as a single file" next > and next>

- choose 5GB Maximum disk size (we delete it later) and pick "Store in a single file" next >

- Finish

 

3. in VMWare, configure your new machine

 

- click on "Edit the virtual machine settings"

- delete your new 5GB virtual Hard Disk (SATA)

- click Add... on the bottom, select Hard Disk 

- select SATA (IDE works, too but I'd prefer SATA in 2017) (UPDATED)

- pick "Use a physical disk"

- select your harddisk with your OS X installation on it and pick "use individual partitions"

- now do not select your UEFI partition, select the partition with your OS X: 

 

Example: My Sierra is on my PhysicalDrive 3 which I selected before. As we all know, the EFI partition is always the first partition (0), so my OS X (and probably yours, too) is on the second partition (1). So I check partition 1 and click next and finish.

 

- if all is set and done, close VMWare.

 

4. check your VMWare .vmx file

 

- replace the green parts with your data and move to "C:\Users\YourWindowsUsername\Documents\Virtual Machines\YourVM-Name\"

- open yourVM-name.vmx with the Windows Editor and add the folowing lines only if they are missing:

 



smc.version = "0"
firmware = "efi"


 

Click save.

 

5. VMWare optimization

I choose half of my physical RAM, maxed out the graphics RAM and choose half of my physical CPU-Cores in the VM settings.

 

6. Finalize (UPDATED)

Go to your VMWare program folder, right-click on vmplayer.exe and under Preferences > Compatibility > check the "Run as administrator" checkbox on the bottom. 

 

 

And that's it! :) Screenshots for reference. Now you have your OS X install available in Windows, too.  :sorcerer:

 

If it asks you for updating the VMWare Tools, click yes or install them with one of the tools in the download section here on insanelymac. You can also add other Harddrives to your VM. What will not work: VMWares unity-mode in Windows - it's not supported for OS X yet. Gaming, the graphic is slow-ish but enough for coding, office, music and all basic tasks.

post-5400-0-69263700-1501670292_thumb.jpg

post-5400-0-26357900-1501670313_thumb.jpg

 

 the graphic is slow-ish but enough for coding, office, music and all basic tasks.

 

 

As long as you can't passthrough your GPU, I don't see the point. The macOS needs a fully enabled GPU even for the basic tasks, even if you don't see the juicy grapchics (i.e. OpenCL can't be used)...

As long as you can't passthrough your GPU, I don't see the point. The macOS needs a fully enabled GPU even for the basic tasks, even if you don't see the juicy grapchics (i.e. OpenCL can't be used)...

 

For me it's very different. I need to work in x-code and Windows at the same time, like to access my iTunes library from there because of the playlists and most of my personal bookmarks etc are under OS X.  But as I already mentioned above, it's not for gaming or other metal/opengl/opencl relevant programs but I think this is true for any VM. 

 

It works fairly good with anything else tho.

  • 1 year later...

Hope this post is still look at. I have been working for days trying to get VM Workstation 14 on windows 10 to run my hackintosh ssd drive... No matter what I try I get a VMWare error when trying to run the VM.... "Error while powering on: Insufficient permissions." I have tried adjusting permissions, mounting/unmounting, tweaking settings, and running as administrator.... all without any luck.

 

Any ideas?

 

I am using macOS 14.0 Mojave, Windows 10, unlocker 2.1.1, VMWare workstation 14, APFS for windows, and Paragon HFS+ for windows. The macOS partition is on a separate NVME ssd than the windows one. 

  • 1 month later...
On 10/1/2018 at 3:18 AM, jdl6884 said:

Any ideas?

 

Hi, 

 

sorry for the late answer. I ran across the same problem when I first tried VirtualBox as a VM. AFAIK it had something to do with the UUID of the disk or that it was used by Windows. VMWare however never had that problem here.

 

But I found a possible workaround that seems to work although I would be careful if your OS X and Windows share the same SSD/HDD:

 

"A simple fix for vm ware fusion if it is saying insufficiant permissions is to open file on MAC, go to where the virtual machene is located, right click on the icon, click show package contents, and delete all the folders with the extension '.lck'. These are lock files that are stopping you from opening the virtual machene."

×
×
  • Create New...