Jump to content
Gymnae

Final Cut Pro X crashes machine

2 posts in this topic

Recommended Posts

Hey everyone,

I'm running Sierra on a very well supported Notebook, the Dell XPS 15 9550. There are great guides out there on how to get it to behave like a MBP. One by me, which is a bit dated, and one by @wmchris, which is the basis of my current setup

 

The Notebooks sports a Nvidia 960M, which guides usually deactivate in MacOS since it cannot be used for displaying purposes, so all graphical and OpenCL work is done by the iGPU, an Intel 530. Which is sad, because that tiny piece of silicon cannot really deal with 4k.

 

My problem lies with Final Cut Pro - 10.3.3 and 10.3.4 both have the same problem, I haven't tried earlier versions. I read that FCP uses the GPU for rendering Effects, all the other rendering is done by the CPU.

 

My system crashes to the POST/BIOS Boot logo (the DELL logo) when running a GPU depending task. With 2k, 4k or even VGA content - it doesn't matter.

 

Things I checked:

  1. Temps: The temperature of the CPU is fine, at least from the measurements I can see via HWMonitor or iStat Menu
  2. Re-activate the dGPU via Clover and drivers: Even though NVIDIA Optimus is unavailable for Hackintoshes, somwhere I read that a dGPU can still be useful for compute tasks such as OpenCL or Metal. But FCP does not seem to utilize the dGPU
  3. Re-install FCP
  4. Trash Preferences of FCP
  5. Benchmarking the {censored} out of the system / burn-in: I ran geekbench, metal & opengl benchmarks. The system remained working and stable
  6. Check the RAM - it passed the hardware diagnosis of the Notebook and "seems" fine
  7. Check the SSD / USB for errors - the disk(s) is (are) fine
  8. Editing the same content with Adobe Premiere and rendering via Adobe Media Encoder - no crash, temps and load are higher, but system is stable

What I assume:

  1. The system freezes for a second before rebooting to the Logo screen. This might be a hint at faulty CPU/iGPU or overheating. But why does it only affect Final Cut Pro?

 

Is anyone experiencing problems with Final Cut on their hack? Freezes and lock-ups might be normal when heavy loads are handled, but a complete and utter reset to boot logo without ANY log? Sweet holy jesus, that is serious.

Share this post


Link to post
Share on other sites
Advertisement

Hi Gymnae,

 

i'm having the same problem.

Furthermore, i realize heavy problems when using different internet streams with safari, e.g. sky go (even with the mac os app), system (mouse and video) stucks every 4-5 sec. Can you apply to this? Could be related to the other problem..

 

Did you find any solution?

 

Best regards

Edited by shane87

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×