Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Fermi Quadro 1000m, HP Z1, no signal on internal screen

10 posts in this topic

Recommended Posts

I've got Sierra installed w/ Clover on my HP Z1 AIO workstation. Without video acceleration the internal screen is recognized just fine. With Inject NVidia set to true I get video acceleration, but only the external monitor works.


I got a a rom dump for this card from techpowerup.com and also dumped the rom myself, both produce the same NVCAP in NVCAP Maker:




Using this NVCAP doesn't change the results, still no internal display signal. actually blacks out both displays.


For completeness, here is the original NVCAP from IOJones: 0400000000000100fe0000000000000700000000


Any tips on how to tweak this to get the internal display to work? I'm not sure if it's LVDS or eDP, does this make a difference?


I have a source for a cheap Kepler based k2000m that would work in this machine. Any idea if that should be more likely to work?


System Specs:

HP Z1 AIO Workstation (gen 1)

Intel Xeon E3-1245 V2


Quadro 1000m (mxm card)

Share this post

Link to post
Share on other sites

Thanks, Hervé. I gave this a try and I'm still seeing the same issue. To be clear, the internal screen isn't even showing up in System Preferences, it's like it's not even connected. I looked at the ioreg output and there is a Display-A and a Display-B, so it does seem that the OS can tell at some level that there are two ports (btw, the internal screen is eDP, just figured that out in Linux).


Since EDID Inject didn't work, I also tried injecting a CustomEDID (which I dumped in Linux), this also didn't help.

Share this post

Link to post
Share on other sites

Post zipped copies of your:

* ACPI tables

* Clover config

* IOReg output (from say IORegistryExplorer)


I don't think it makes a difference whether LCD is eDP or LVDS. It's definitely an EDID issue. I had a similar problem with a Radeon HD5430 GPU, albeit with a laptop: built-in LCD would not be recognised until I switched to Clover and:

  1. injected ATI graphics
  2. selected correct ATI framebuffer
  3. injected EDID
  4. selected Load VBIOS

Try "Load VBIOS" too and set "DualLink" to 1 too.

Share this post

Link to post
Share on other sites

You may also want to try this unusual SMBIOS setup: your current Ivy Bridge iMac (I presume) with MacBookPro10,1 board-id Mac-C3EC7CD22292981F. If it does not work, try MBP10,1 SMBIOS.


That what I was once recommended to use at OSXL to avoid black screen on Sandy Bridge laptops with Quadro 1000M graphics: MBP6,2 SMBIOS with MacBookPro10,1 board-id Mac-C3EC7CD22292981F.



Could be an Apple whitelist in the nVidia drivers (for specific Mac models) like there exists for Broadcom wireless drivers.

Share this post

Link to post
Share on other sites

I've attached the requested files.


In my current config.plist I'm using all the settings you recommended. Tried each suggested SMBIOS iteration and still no change. I've commented out my custom EDID since it wasn't helping.


I picked up that Kepler card, I'm going to install that now and see what happens.

Share this post

Link to post
Share on other sites

IOReg file (named IOReg.plist) cannot be opened with IORegistryExplorer. What did you obtain it with?


There isn't much in your Clover config. In the Graphics section, try to remove the NVCAP, retaining all the other parameters. You don't appear to have set the SMBIOS as recommended. Use latest Clover Configurator app.

Share this post

Link to post
Share on other sites
Sorry, that dump was from IOJones, I didn't realize it doesn't have equivalent output to IORegistryExplorer. IORegistryExplorer output attached.


I tried each iMac13,1, MacBookPro10,1, and (for good measure) MacBookPro6,2 both with and without with Board-ID of Mac-C3EC7CD22292981F. Just went through again and tried each of these permutations without the NVCAP. Every attempt had the same result of only getting video on the external display (except MBP6,2 which actually blacked out both screens). The current plist version (edited w/ Clover Configurator 4.43.0, no NVCAP, Ivy Bridge iMac, custom board ID from above) attached.


Thanks again for all your help.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kami11o
      I've got W520 with running High Sierra on it with configuration based on the great guide by @tluck (http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only). I works great with integrated video card, the only thing that I'm unable to get working is Nvidia card (Nvidia Quadro 1000m). 
      By far I tired the following configuration:
      SMBIOS set to MBP 10.1 / 9.1 / 8.1 Nvidia Web Driver 378. Nvidia enabled in the Clover Video card set to discrete in BIOS   
      As a result, after boot, I've got flickering screen with disappearing windows and some artifacts, unfortunately not usable at all.
      Does anyone has managed to get this discrete card working on this notebook?
    • By nano21
      Hi all,
      I see there are many knowledgeable people around here so you guys might help.
      I`ve got imac 27"(BTO model) and ofc 4850 died. I ordered radeon 5870(from alienware laptop), I hear start chime and I know it boots into system as I press enter and hear that "bong" sound when nothing is selected but no display at all (just black, checked if its backlight issue its not).
      So I ordered GTX280M, as I saw someone wrote its easier to get it working... Well not in my case. I installed it and same thing happens, boots - no display.
      I know its the graphic card because I can boot into OSX with 4850 in safe mode, still has the lines but works. Can it be that imac is using external mini display port as a primary "display" (for 5870&GTX)?
      I also tried smc, pram reset, harware test, safe mode... Nothing helped.
      Any suggestions?
    • By sakoula
      I would like to request some help and guidance on how to troubleshoot the performance issue I am facing with my GPU on a hackintosh. 
      My card used to perform ok on 10.8 and 10.9. When I upgraded to 10.10 I had a big performance loss. I am not sure if this is normal or not. 
      I am trying to understand if something is missing on my configuration.
      My use is NOT gaming but everyday work , coding, browsing etc.
      - My GPU is "NVIDIA Quadro NVS 300 with 512MB" with two monitors hooked: 1920x1200 and 1280x1024.
      - I use MacPro3,1 and GraphicsEnabler=Yes on Chameleon and the stock apple drivers and my card is recognized in 'About' as (which seems right):

      Chipset Model:  NVIDIA Quadro NVS 300
        Type: GPU
        Bus:  PCIe
        Slot: Slot-1
        PCIe Lane Width:  x16
        VRAM (Total): 512 MB
        Vendor: NVIDIA (0x10de)
        Device ID:  0x10d8
        Revision ID:  0x00a2
        ROM Revision: 70.18.9F.00.0C

      - LuxMark gave me 117
      - Cinebench gave me 4.60
      - kextstat shows the following modules:

         95    2 0xffffff7f8102c000 0x274000   0x274000   com.apple.nvidia.classic.NVDAResmanTesla (10.0.0) <78 77 12 5 4 3 1>
         96    0 0xffffff7f81cab000 0xce000    0xce000    com.apple.GeForceTesla (10.0.0) <95 78 77 12 7 6 5 4 3 1>
         97    0 0xffffff7f812a0000 0x2cf000   0x2cf000   com.apple.nvidia.classic.NVDANV50HalTesla (10.0.0) <95 12 4 3>

      I am looking on some direction. Any help really appreciated!
    • By Alec J
      Alright.  I have a PNY GeForce GT 630 as stated in title.  I got the card a few weeks ago and switched from a Radeon 4450 (or 4550.. doesn't matter).  Naturally, I had to remove the GraphicsEnabler=Yes flag and the computer ran great.  Eventually I installed the CUDA driver and it seemed to do its thing correctly.  All was good.
      One day, I booted to a black screen in the morning.  I wasn't sure why, so I tried again and manually added GraphicsEnabler=No.  It booted fine.  ...ok!
      For almost a week the machine would boot just perfect if I did a "restart" (as opposed to power-off shut down) and sometimes would boot fine if I shut it down and turned it back on promptly.  Otherwise, I would have to manually enter the GraphicsEnabler=No at my Chameleon prompt.  When I checked Chameleon Wizard's bdmesg, it showed that I was booting with GraphicsEnabler=No TWICE at this point (I had added it manually to the .plist and then, as stated, would have to manually type it in a boot in the mornings, etc).
      Eventually this stopped working and I was magically able to limp along with the same methods except adding PCIRootUID=1 every boot.  Adding this to the .plist, just like GraphicsEnabler, would show that the machine booted with the flag but it would only work if I manually inputted it into Chameleon when selecting the drive upon booting.
      A few days after that, I was absolutely unable to boot no matter what.  Black screen.  I could VNC into the machine and see the desktop.  According to Kext Wizard, the nVidia kexts are in fact being loaded.  In System Information > Graphics/Displays, my card shows up as "Nvidia Chip Model", device ID 0x0f00, 128mb.  I don't know if I have any hardware acceleration at this point since I'm only VNC'ing into the machine and it's a little slow and crappy anyway.  I don't seem to get any glitching that would be apparent when I booted with nv_disable.

      Oh yeah, nv_disable will boot fine, as you might expect, with the subsequent crappy graphics performance and glitching and all of that.  Of course this makes sense as the nVidia drivers are not loading.

      I currently run the machine on my old ATi 4870 which works just great with GraphicsEnabler=Yes.  A little old for my needs and also gets hot and sucks a lot of power (I think it's around a 200w card or something silly!)
      I have tried nearly every combination of the following boot flags
      GraphicsEnabler=No (and Yes)
      PCIRootUID=1 and 0
      PciRoot=1 and 0
      npci 2000 and 3000 (whatever those were)

      I made a flash drive with Clover on it and was able to boot to the same black screen.
      I kept my Yosemite USB stick and never touched it after I first successfully installed, back when I was using the Radeon 4450.  I cannot boot from this USB stick using any combination of the above flags either.  I plan on making a Mavericks stick with MyHack soon and seeing if I can get that to boot. 

      There is a thread on Hackintosh.Zone (I hope it is ok that I link to there) where a person has the EXACT same problem with the same comptuer (well, Precision T3400 at least) except the thread was never resolved (heck, nobody but him/her replied) and they stopped posting at the point where the boot flags seemed to be completely random as to which one would work any given day.
      They, however, were using an old Nvidia Quadro 1700 which was based on the 8600GT - very old card, completely different drivers as far as I am concerned.  I assume they were running Mavericks (april 2014). 

      Any ideas!?  This seems to be an undocumented problem, I've been searching around for over a week now while banging my head against the desk or giving up and using my old Radeon. 

      My computer:

      Dell Precision T3400
      Intel X38 chipset
      Xeon x3363 (with 771->775 conversion)
      6gb DDR2
      Yosemite 10.10.2
      Everything ran totally perfect, as I mentioned, for a while.  I have looked through my BIOS and found no settings that would seem to hint toward solving the problem.  There are no onboard graphics and the only video settings in BIOS are to make it prefer PCIe or PCI (both options of which I have tried).  I reset the BIOS many times.  The BIOS clock does set itself to GMT time (I think, 6 hours ahead from my USA Central time which is -6GMT I beleive) whenever I shut the computer off.

      The ONLY thing that I can remember changing during the genera time period when it first stopped booting was that I added a second hard drive (main is 500GB and additional was another 500GB) so that I could run a 100% Time Machine backup. 

      I am so lost.
    • By tigerking9
      I'm about to build my second Hackintosh.
      This one needs to be fast for my 3D & Video workflow.
      I need a card with a lot of cuda cores and one that is fast for rendering on aplications like Maya and Adobe products.
      I found out the K4200 would be perfect for this.
      My questions are:
      - Does the K4200 work with hackintosh?
      - Do I need 2 of K4200 in order to render fast on GPU?
      - Can I buy a different Nvidia GPU that's already been tested on hacktinsh with the same kind of specs?