Jump to content

Solved! need help with DSDT


Go to solution Solved by MaLd0n,
13 posts in this topic

Recommended Posts

hello,

 

running fresh Sierra with the old Clover config from old El Capitan.

 

using two kexts FakeSMC and NullCPU - and somehow the case Fans running full speed.

 

tried without NullCPU but no luck - I think I need better DSDT.

 

also can't activate Nvidia Web Drivers on Sierra, tried with NvidiaWebDriverUpdater.

 

is someone please so kind and can help me out.

 

thanks.

coosee_EFI.zip

Send me coosees iMac.zip

coosees_iMac_14.2.ioreg.zip

  • Like 1
  • Solution

Check

Replace full folder, just replace dont changed nothing

CLOVER.zip

generate ur SSDT for PM with pike script

ssdtPRGen.command.zip

save and compile, put SSDT.aml in Clover/Acpi/Patched

run it

Olarila.command.zip

Reboot

 

if u have a black screen, just boot with nv_disable=1 and run it

http://www.insanelymac.com/forum/files/file/424-agdpfix/

 

Use iMac17,1 ;)

 

send me new ioreg after reboot

IORegistryExplorer 3.app.zip

  • Like 1

Check

Replace full folder, just replace dont changed nothing

attachicon.gifCLOVER.zip

generate ur SSDT for PM with pike script

attachicon.gifssdtPRGen.command.zip

save and compile, put SSDT.aml in Clover/Acpi/Patched

run it

attachicon.gifOlarila.command.zip

Reboot

 

if u have a black screen, just boot with nv_disable=1 and run it

http://www.insanelymac.com/forum/files/file/424-agdpfix/

 

Use iMac17,1 ;)

 

send me new ioreg after reboot

attachicon.gifIORegistryExplorer 3.app.zip

 

I can't believe it - Boot ok - no black screen - Nvidia Web Drivers works again  :thumbsup_anim:

 

No Sensors with iStat, will try HW-Sensors - which one I should choose these  http://www.hwsensors.com/releases or Kozleks?

 

here's a new ioreg.

 

thank you so much.

coosees_iMac_17_1.ioreg.zip

  • Like 1

for sensors, use it, only it

attachicon.gifFakeSMC.kext.zip

 

ok, good to know.

 

TRIM doesn't work but I can see my NVME Drive now  :D

 

maybe I'll replace my FunToo Linux at later time, which is on the M.2 atm.

 

Now, it feels like a perfect System  :rolleyes:

 

thanks MaLd0n !

Just enable patch in ur config.plist

MaLd0n 2017-04-05 às 21.29.45.png

 

U dont use audio onboard?

 

if ur Nvme appears external, need _DSM patch into device

"built-in", 
Buffer ()
{
"NVMe SSD"
}
  • 2 years later...
×
×
  • Create New...