Jump to content

PAE error installing OSX86 on VMware installed on Parallels

2 posts in this topic

Recommended Posts

Hi there!


Ultra Mac Nerd here.....


Have a problem I just can't figure out.


I have a MacBook Pro 17 inch, use Parallels with a legit copy of Windows XP. Use XP for work related stuff and have no problems.


Have a distribution of x86 Mac OS and wanted to install it in Parallels. No luck, tried everything I know. Read all the stuff about how VMware does better PAE support, so installed VMWare on Parallels/XP. No problems there.


Tried again to install x86 Mac OS on the VMware (installed on Parallels) side, did the PAE = "TRUE" in the *.vmk file edit. MacOS does get to the gray Apple screen and then gives me the PAE error thing you are familiar with. Followed the instructions about instlalling on VMware at that site with the tutorial video, still same error.


So, instead of wasting more time on this, since I am really just seeing if I can do it (and some other reasons), I am posting this to see if anyone else is crazy like me and would like to see this work. Yeah, I know it is a VM in a VM thing, but that is what I want to do. Don't care about the performance hit, there is a reason for the madness!


Anyway, any help in this regard is appreciated. I'm not a beginner, so please only reply if you have an answer (would do the same for you). 



Link to comment
Share on other sites

  • 1 month later...

It's a really bad idea to run a VM in a VM. This does not work.

Virtualization software needs to access the CPU directly in order to work.

Running VMWare Workstation in a VMWare workstation session doesn

t work because VMWare workstation checks to see if it is running in a VM and halts if it does. Because you are using Paralells, VMWare Workstation is unable to detect the presence of a VM (it's only programmed to detect VMWare's own memory signature) it still runs but obviously fails.


Actually you are more likely to succeed with Microsoft Virtual PC running in a VM. I booted WIndows Server 2003 in a VM and installed Virtual Server 2006 R2 on it. I managed to get a virtual server running fine, but the performance hit was too great (it took 5 minutes for the virtual BIOS in Virtual Server to POST).


You better install VMWare on Mac (there is a BETA version available, but I will not help you getting it).

Link to comment
Share on other sites


  • Create New...