Jump to content

intel HDA no sound

12 posts in this topic

Recommended Posts

Hello friends,


I have a sound card of soundmax integrated Digital HD (High Definitaion Audio).


My vendor ID = 11D4

My Device ID = 1986

(These are soundmax codes).



My vendor ID = 8086

My Device ID = 27D8

(These are Microsoft UAA High Definitaion Audio codes).


I did the following:


sudo su -

rm -rf /System/Library/Extensions/AppleHDA.kext

vi /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/Info.plist


and wrote




save and exit.




vi /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist


and wrote




save and exit.

Then I did

rm -f /System/Library/Extensions.kextcache

rm -f /System/Library/Extensions.mkext

kextload -t /System/Library/Extensions/AppleAzaliaAudio.kext

kextcache -k /System/Library/Extensions/


Then a reboot.


After that I went to

Finder > Applications > Utilities > Audio Midi Setup.


There I saw Output device as Intel HD Audio. Ok I made the volume maximum closed it and played a mp3 in iTunes. It played but no sound came out of my laptop speakers. I tried with earphones too in line jack and headphone jack (I only have these 2) but no sound came.


I am able to play mpeg, dat, avi, mov, mp3 all but no sound is coming out.

I have SoundMax Integrated HD Audio (Lenovo 3000 N100 Laptop).


And have ICH7.

Also installed version of OSX is JaS 10.4.7 (SSE3 Patched).


Any more information regarding my hardware details ?


Please help




Link to comment
Share on other sites

  • 2 weeks later...

I have the same system and did the same. Nothing worked for me neither :D


I have tried appleazalia, ac97audio and few other tweaks. No luck.. but only for appleazalia i can see the volume control icon.



Link to comment
Share on other sites

Go into Terminal and type:


sudo -s

"your password"

chmod -R 755 /System/Library/Extensions/AppleAzaliaAudio.kext

chown -R root:wheel /System/Library/Extensions/AppleAzaliaAudio.kext

chmod -R 755 /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext

chown -R root:wheel /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext

Link to comment
Share on other sites


  • Create New...