Jump to content

Run latest version of Google Chrome on old Mac


3 posts in this topic

Recommended Posts

I managed to update Google Chrome to the latest version (51) by changing 10.7.5 to 10.9.1 in /System/Library/CoreServices/SystemVersion.plist

 

npVLHfG.png

 

Chrome was required a restart to complete the update and run fine.

 

Zhn77Ny.png

 

The yellow warning bar about not receiving the updates showed up and quickly disappeared.

 

But...

 

When I restarted the system, it didn't boot. 

 

I had to boot into recovery and change OS version back to 10.7.5. Obviously Google Chrome did not run anymore and was complaining about version 10.9 being required.

 

I tried update again and it worked again. I even changed the system version back while Chrome was open and it still worked.

 

cJHycE1.png

 

After trying to restart Chrome, alas, it failed with a message

 

UGKdQ3A.png

And a greyed out Chrome circle in Dock

 

SO MY BIG QUESTION IS:

 

I wonder is there a way to script Google Chrome launch the way it patches the systemversion.plist, runs Chrome and then quickly patches the plist back to it's original state?

 

Or...

 

to make Chrome to look somewhere else for system version?

 

Or...

 

to make systemversion.plist to have original system during boot and have patched version when booted?

 

Anybody savvy enough to collaborate?

 

P.S.

 

Please do not ask off topic questions like, why do I not update to El Capitan or why do I not throw away my Xenon quad core hackintosh and buy a new mac or why would I not use Firefox.

Browse the contents of Chrome and open the Info.plist. Change the minimum system version from 10.9 to 10.7 and see if that fixes things. The fact that you say it ran OK sounds promising.

Thanks, that does kind of help. After the patch the version 51 runs after restart under 10.7.5. 

 

xb5Ah1o.png

 

By the way there are 3 versions of plist files which have this 10.9.0 string.

 

I have found that the best plist editor is XP and Word 95. Windows File Explorer searches and browses mac app packages just like normal folders.

 

Tp3Lr04.png

 

But there is another problem. The Google does not remember any passwords and the profile has to be signed in every time you launch Google. This is similar to Google run from ML post factor. That's why I am running Lion even though I can run Mountain Lion post factor. The version tricking flags some security alarms in Chrome and it does not run correctly.

 

JIavEvD.png

×
×
  • Create New...