Jump to content
Sign in to follow this  
Followers 0
hashish.k

speed step not working after sleep

4 posts in this topic

Recommended Posts

My speed step is not working after sleep. When I first start the computer the CPU frequency varies from 1.5 to 3.6 Ghz. After it wakes from Sleep the frequency gets stuck at 3.6 Ghz. I have noticed on the windows the minimum frequency achieved is 800 Mhz. I amusing intel power gadget to monitor the power management.

I am using F4 bios. Using kernelpm=true and have a SSDT.aml generated by ssdtPRGen.

Any ideas on what I might be missing. Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement

Thanks for the reply. my CPU is Intel core i5-6600 and MB is gigabyte z170x UD5.

Since the last time I posted I have done some digging around, and I have more stuff to report. When I type XCPM on console, it shows my power managment is loaded upon start, but after sleep it shows power management is not loaded. 

I have made an IOreg dump as well. I have screen shots of intelpowergadget before and after sleep. I even tried changing the SMBIOS to macpro 6,1 but it did not work. 

output of appleintelinfo kext is also attached. also attaching config.plist

Do you think I should do  a fresh install or this will be solved with a later version of OSX. So far I have not been able to confirm if other skylake users have the same problem or not.

after waking up from the sleep I get an error saying "USB devices disabled, unplug the device using too much power to re-enable USB devices". Not sure if this has something to do with the problem at hand.

post-1589215-0-23547600-1452549439_thumb.png

post-1589215-0-81204300-1452549437_thumb.png

post-1589215-0-59668100-1452549438_thumb.png

post-1589215-0-55999700-1452549436_thumb.png

Archive.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×