Jump to content
About Just Joined group Read more... ×
HenryXP

Multi Boot El capitan - Windows 10 - Linux

14 posts in this topic

Recommended Posts

Son riuscito ad aggiungere Windows 10 al menù del bootloader Clover, ma non riesco a far partire Linux che risiede su una partizione dello stesso disco dove è OS X.

La partizione viene vista però linux non si avvia, rimane tutto con una schermata nera.

 

Grub2 è stato installato sulla stessa partizione dove risiede l'installazione Linux, come posso risolvere? E soprattutto, come faccio ad avviare linnux Mint?

 

ecco la lista dei dischi:

 

 

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *500.1 GB   disk0
   1:               Windows_NTFS Dati                    500.1 GB   disk0s1
/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *120.0 GB   disk1
   1:                        EFI                         367.0 MB   disk1s1
   2:       Microsoft Basic Data Windows 10              119.7 GB   disk1s2
/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS OS X El Capitan         99.8 GB    disk2s2
   3:                  Apple_HFS Recovery HD             650.0 MB   disk2s3
   4:                  Apple_HFS Home                    109.6 GB   disk2s4
   5:       Microsoft Basic Data                         98.1 GB    disk2s5
   6:       Microsoft Basic Data                         11.6 GB    disk2s6
iMac-di-Henry:~ henry$
 

Linux e grub sono su disk2s5

disk2s6 è la partizione di swap.

 

saluti.

 

 

 

 

Share this post


Link to post
Share on other sites
Advertisement

Mi pareva che in quinta partizione non mi partiva Linux, se il bootloader lo vede sembrerebbe tutto corretto con grub in partizione...


Così mi ricordo, io in terza partizione non ho problemi.


Premetto che uso Clover Legacy, ammesso conti qualcosa.

Share this post


Link to post
Share on other sites

Son riuscito ad aggiungere Windows 10 al menù del bootloader Clover, ma non riesco a far partire Linux che risiede su una partizione dello stesso disco dove è OS X.

La partizione viene vista però linux non si avvia, rimane tutto con una schermata nera.

 

Grub2 è stato installato sulla stessa partizione dove risiede l'installazione Linux, come posso risolvere? E soprattutto, come faccio ad avviare linnux Mint?

 

ecco la lista dei dischi:

 

 

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:     FDisk_partition_scheme                        *500.1 GB   disk0

   1:               Windows_NTFS Dati                    500.1 GB   disk0s1

/dev/disk1 (internal, physical):

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *120.0 GB   disk1

   1:                        EFI                         367.0 MB   disk1s1

   2:       Microsoft Basic Data Windows 10              119.7 GB   disk1s2

/dev/disk2 (internal, physical):

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *320.1 GB   disk2

   1:                        EFI EFI                     209.7 MB   disk2s1

   2:                  Apple_HFS OS X El Capitan         99.8 GB    disk2s2

   3:                  Apple_HFS Recovery HD             650.0 MB   disk2s3

   4:                  Apple_HFS Home                    109.6 GB   disk2s4

   5:       Microsoft Basic Data                         98.1 GB    disk2s5

   6:       Microsoft Basic Data                         11.6 GB    disk2s6

iMac-di-Henry:~ henry$

 

Linux e grub sono su disk2s5

disk2s6 è la partizione di swap.

 

saluti.

 

Scusate ma, tutto questo cosa c'entra con El Capitan?

Share this post


Link to post
Share on other sites

Invece su partizionamento GTP se mettevo tutti e tre i sistemi dovevo correggere con GPTSync, un MBR ibrido.

 

l'ho installato ma non ho idea di come funzioni ...Quindi dite che linux non parte se è nella 5a partizione?

Share this post


Link to post
Share on other sites

NO, io ti ho detto una cosa che in passato mi è successa, quando usavo il partizionamenti GPT e cercavo di mettere molti sistemi in un solo disco.


Il GTPSync in ogni caso serve per far convivere Linux con Windows e MAC sullo stesso disco con partizionamento GPT

Share this post


Link to post
Share on other sites

Se metto grub all'inizio del disco dove c'è EFI de El Capitan dici che poi fa casino?

 

Potrei rifare l'installazione di linux e metterei il boot loader su 

0:      GUID_partition_scheme                        *320.1 GB   disk2

 

oppure lo potrei mettere su un altro disco all'inizio dell'MBR per esempio qui: 

0:     FDisk_partition_scheme                        *500.1 GB   disk0

Share this post


Link to post
Share on other sites

Ho risolto mettendo il bootloader sul disco

FDisk_partition_scheme                        *500.1 GB   disk1

Ovviamente ho dovuto reinstallare Linux

Adesso ho questa configurazione dei dischi:

 

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *120.0 GB   disk0
   1:                        EFI                         367.0 MB   disk0s1
   2:       Microsoft Basic Data Windows 10              119.7 GB   disk0s2
/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *500.1 GB   disk1
   1:               Windows_NTFS Dati                    500.1 GB   disk1s1
/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS OS X El Capitan         99.8 GB    disk2s2
   3:                  Apple_HFS Recovery HD             650.0 MB   disk2s3
   4:                  Apple_HFS Home                    109.6 GB   disk2s4
   5:           Linux Filesystem                         90.0 GB    disk2s5
   6:                 Linux Swap                         19.8 GB    disk2s6

 

CMQ non capisco come mai Linux Mint è un ISO da meno di 1GB mentre El Capitan è quasi 7GB, i programmi che installano sono +o- gli stessi. Cosa c'è che pesa così tanto?!

Linux lo si installo in 10 minuti, OSX ci vole quasi un ora :D

 

 

Share this post


Link to post
Share on other sites

Grub va in partizione. Linux si installa veloce ma anche Mac se fai un dmg ripristinatile con un installazione che poi usi come campione fatta su vmware.

 

DMG per MAC

 

REMASTERSYS per LINUX.

 

10 minuti e sei a posto con entrambi.

 

Ma su questa sezione con questi argomenti sei OT...

Share this post


Link to post
Share on other sites

Adesso però c'è un problema, devo far partire linux dal menu clover di OSX,  esso punta sulla partizione (disk1s1) "dati", invece che su (disk1) dove risiede grub di linux.

Per adesso parte dal menù di boot della MB selezioando il Disco disk1

 

  0:     FDisk_partition_scheme                        *500.1 GB   disk1
  1:               Windows_NTFS Dati                    500.1 GB   disk1s1

 

Sul menù grafico clover ho la partizione "Dati" ovviamenti da li non parte linux.

 

Se la discussione vi sembra OT spostatela dove dovrebbe stare, cmq trattasi sempre di un problema riguardante la post l'installazione de el capitan..

post-1594260-0-75943300-1444053969_thumb.jpg

Share this post


Link to post
Share on other sites

La partizione DATI ce l'hai a prescindere se non la nascondi, se non hai Linux nel boot vuol dire che grub non è in partizione...

<key>GUI</key>
	<dict>
		<key>Custom</key>
		<dict>
			<key>Legacy</key>
			<array>
				<dict>
					<key>Disabled</key>
					<false/>
					<key>FullTitle</key>
					<string>Windows 10</string>
					<key>Hidden</key>
					<false/>
					<key>Ignore</key>
					<false/>
					<key>Type</key>
					<string>Windows</string>
					<key>Volume</key>
					<string>Legacy HD1</string>
				</dict>
			</array>
		</dict>
		<key>Hide</key>
		<array>
			<string>bootmgr.efi</string>
			<string>HD(2,GPT,xxxxxxxx-3C25-4E8B-xxxx-6A3D25681DD0,0xxxxx,0x1D1BCB000)</string>
			<string>BOOTX64.efi</string>
			<string>Windows</string>

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×