Jump to content

Can't use more than two CPU cores...

2 posts in this topic

Recommended Posts

Hello. I've finally got Niresh's Yosemite 10.10.1 installed, and so far is pretty stable on my computer. Got all of my devices fully working. The only problem i have is that i can't make it use more than two CPU cores.

I have to boot with cpus=2 to be able to get into the system. If I remove cpus=2 flag, i get kernel panic and reboot instantly. Also, if i put any other numbers, (not 1 or 2), at cpus option, i also get kernel panic and reboot...so i can't make the system use more than two CPU cores.


I've tried DSDT patch for cpus=1, but nothing changed. Also i've tried VoodooTSCSync.kext...nothing changed. Tried a lot of different AMD kernels...same...nothing. I don't know what else can I do about this. I really like Yosemite and i'm wanna use it as a primary operating system, but i really need to be able to use all my CPU cores.


I need some help, please...


My system specs:

Processor: AMD FX-6100 3.3GHz 6x core

Motherboard: ASRock 960GM-VGS3 FX

Ram: 4GB DDR3

Video: Nvidia GT630 2GB

Link to comment
Share on other sites


  • Create New...