Jump to content

Lost Battery Display Functionality with 10.10.3


1 post in this topic

Recommended Posts

I use RehabMan's OS X ACPI Battery Driver, version 2015-0123.  I didn't notice any problem with it when I installed 10.10.3, nor did I ever have any problem with it when testing the beta versions of 10.10.3.  However, now, I cannot get the battery to display.  There is a battery tab in the energy savings system preferences but the settings cannot be saved.  There is a box to check to display the battery info in the menu bar but as soon as I check the box, it unchecks by itself.  Using iStat menu battery display, it shows an empty battery and says there is no battery present.  In energy savings preferences, it says that battery charge is 0%.  I haven't changed my DSDT and it has previously worked fine.  I also have a partition on my same laptop running 10.10.2 and it works fine.  Anyone else having issues with this kext?  Just need to wait for an updated kext?  Your thoughts are appreciated.

OK, I fixed this by moving the kext from the kexts folder in Clover to S/L/E.  That suggests that the problem is related to my kernel cache, not RehabMan's battery kext.  I tried to delete the topic but couldn't.  Moderator-please feel free to delete the topic.  Thanks.


OK, better fix:  I dropped my Clover 10.10 kext folder into Kext Utility to repair permissions.  That did it and I could remove the battery kext from S/L/E and keep it Clover where I want it.

Link to comment
Share on other sites


  • Create New...