Jump to content

[Solved] VM Player 6 with OSX Yosemite unable to detect USB flash drives

1 post in this topic

Recommended Posts

Hi guys,


The OSX Yosemite .vmx file was not booting up in VM Player 7, was always getting stuck on the apple logo. Using VM Player 6 fixed it.


So now using VM Player 6, I've successfully run a virtual system with OSX Yosemite 10.10. I now need to create a bootable usb.

Unfortunately no usb devices are being detected (whether it is USB 2.0 or USB 3.0). 


Any idea how I can get osx yosemite to detect the flash drives under vmplayer 6?


PS: USB detection of mouse and keyboard works fine. Only USB memory devices are a problem like external sata drives or flash drives.


Edit: After some serious and tricky googling, I have now found the solution to my pains.



  1. Type services.msc in the windows run command.
  2. Locate "VMware USB Arbitration Service"
  3. Open it and start it. (This will now run the service.)
  4. Close your virtual machine and restart VMPlayer.


Solution where it was found: usb not working in vmplayer 6 or 7

Link to comment
Share on other sites


  • Create New...