Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
luki1979

GA-EP45T-UD3LR Xeon X5472 weird problem - SOLVED

5 posts in this topic

Recommended Posts

Before I ask you guys for help I googled for hours and found nothing. 

 I got myself new/old board: GA-EP45T-UD3LR and Xeon X5472. I modified 775 socket for 771 and Xeon cpu with sticker.

Under Windows everything works perfectly, I tested CPU with Intel utility and run various stress tests for GPU/CPU and memory. Not a single glitch. System running stable at stock 3Ghz, 1600FSB and DDR3 1600.

 

 I plugged my OSX HDD and it booted but system was behaving weirdly, windows were half opening and sometimes it wasn't displaying anything in finder, some icons froze on desktop, proper screen artifacts. I have an GTX-760 and HD5770 to swap, both used to work natively on my old motherboard.

Right I thought new hardware needs new system. I Installed Niresh Mavericks distro as only thing working was a  PC. I had the same problems with displaying when installing, it sometimes become unresponsive on the welcome screen, sometimes freeze on grey screen. I managed to install but glitches are still there. I tested with 2 different graphics card, same thing.

 System works but display freeze sometimes or showing stuff with delay. I tried all the boot flags and no difference.

 

Many thanks for any input. I will post pictures tomorrow.  

Share this post


Link to post
Share on other sites

Hi,try to use smbios to MacPro 3.1 first

i use boot flag for Xeon  tscsync npci=0x2000

good hack

Share this post


Link to post
Share on other sites

Thank you so much for your answer.  It working ok-ish with cpus=1 flag, at least I can do something. 

 

I see you've got similar setup. I will try tscsync thing now.  Are you using Chameleon or Clover?

 

I found this ironic that I got problem with CPU used on real MacPro 3.1 :)


 

Edit:

 

I'm pleased to inform that after installing tscsync package all 4 cores are working and there is no more screen artefacts.

 

Many thanks Husaber. I owe you a beer or two :)

Share this post


Link to post
Share on other sites

i need five beeer :hysterical:

and it's very good info from you,hackintosh work like champ with this modded processor :drool:

But not everyone can do it use.. :hysterical:

Cheers and GOOD HACK

 

PS-you check speedstep?work or no?

in terminal command-

ioreg -lw0 | grep PerformanceStateArray
ioreg -lw0 | grep CSTInfo
kextstat | grep LPC

Share this post


Link to post
Share on other sites

I got this after typing first command:

    | | |       "PerformanceStateArray" = (<b80b0000c05d00000a0000000a0000002147000021470000>,<f00a0000805700000a0000000a0000002107000021070000>,<280a0000405100000a0000000a0000002146000021460000>,<60090000004b00000a0000000a0000002106000021060000>)

 

nothing after second command and this after third:

49    0 0xffffff7f81193000 0x12000    0x12000    org.hwsensors.driver.LPCSensors (1018) <14 11 10 7 5 4 3>

 

Is that ok?

 

It sleeps ok and frequencies are changing in HW monitor, it's showing 4 cores at 2.4 or 3 GHz depends on load.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Thank you Baio77. Here is my CLOVER folder and the Hack info. 
            For Some Reason I can't upload my CLOVER folder. But here you can download...
      https://www.dropbox.com/s/vjprxs1idtj9pt7/CLOVER.zip?dl=0     Thank you again!!!   HackInfo_Report.zip
    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  


×