Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

TP-Link WDN4800 & Mavericks 10.9.4 - Lose internet connection while still connected to WiFi

1 post in this topic

Recommended Posts

My TP-Link WDN4800 wireless adapter (PCI-E) has been suffering constant disconnectivity starting yesterday. It doesn't seem to let me load webpages however it still states that a connection is active in the AirPort menu on the menu bar. When I boot into OS X, it says that there's no internet connection. At these times I have to turn off the WiFi and turn it back on again, and it's getting tedious.


I don't know what has caused it to even do this. I don't tamper with network settings once they've been configured. It was working for some time on 10.9.4, so I don't think that would be the issue. This isn't an issue with the adapter, either; I use Windows 8.1 on the same machine and it maintains a connection. When testing my Yosemite install, it doesn't appear to want to make a connection to the Internet. It shows a connection but doesn't actually let me visit websites.



Wireless adapter: TP-Link WDN4800 (Connectivity via PCI-E)

Motherboard: Gigabyte Z77X-UD3H

OS Affected: OS X Mavericks 10.9.4


I don't know what else there is to add, but if need be I'll add more specs.


EDIT: The connection appears to have stabilised after a check of the PCI-E slot, the device and the antennae, however at every boot-up it shows "Alert: No Internet Connection" and I have to disable the WiFi and re-enable it to bring the connection back. I have tried removing relevant plists to rewrite them however this doesn't fix the issue. I have also tried updating my bootloader (Clover EFI). I've even renewed my DHCP lease.


EDIT 2: Nope! Still the same thing. I'm getting angry now. I very, very, very highly doubt it's a hardware failure as if it was, I'm sure Windows would also have trouble with it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.