Jump to content
Sign in to follow this  
Followers 0
pitou97125

Installation OS X Mavericks sur Asus K551LBl

47 posts in this topic

Recommended Posts

Bonjour, 

 

Je cherche actuellement à installer l'OS X Mavericks dans sa version 10.9.3 sur mon Asus K551LB-XX269H. J'ai déjà essayé plusieurs tentatives avec différents tutoriels mais je bute toujours à un problème différent qui m'empêche de poursuivre mon installation. Je voudrais faire tourner OS X Mavericks en Dual-Boot avec mon Windows 8.1 sans pour autant supprimer mes données ainsi que mes applications installées. Mon disque SSD est bien en GPT avec une partition Mac OS journalisée pour accueillir le système OS X.

 

J'aimerais bien avoir un tutoriel ou des explications sur les marches a suivre pour effectuer cette installation. 

Cordialement.

 

 

Share this post


Link to post
Share on other sites
Advertisement

Salut , 

 

il te faut un patch MBR ou alors une astuce plus longue mais efficace qui consiste à installer OS X sur un support ext que tu restaureras sur ta partition GPT MBR/win8 (CCC) ;) 

Share this post


Link to post
Share on other sites

Pourquoi un patch MBR alors que mon disque est en GPT ?

 

Tous les moyens sont bon pour reussir cette installation donc je veux bien essayé l'installation sur un support extérieur  :)

Share this post


Link to post
Share on other sites

bha dans ce cas si ton disque est bien en gpt et que win est installé pour démarrer en mode efi...

y'a rien de bien compliqué, tu installes osx sur sa partition dédiée, et tu installes clover en mode uefi. (si tu voulais le chameleon, c'est pas possible en efi)

et ça doit rouler :)

 

edit : mais faudrait peut être en dire un peu plus sur les problemes que tu rencontres... parceque on est pas encore devin, j'y travaille, mais c'est dur :D

Share this post


Link to post
Share on other sites

Alors en faite, après avoir essayé plusieurs tutoriels pour installer OS X Mavericks (clé usb d'installation avec OS X en machine virtuelle etc) sans succès, mon problème aujourd'hui est l'installation avec clover que j'ai suivie à partir de ce topic. Je suis bloqué à la partie "1. Démarrez sur la clé USB, choisissez Install OSX, tapez espace, selectionnez With Injected kexts et validez" de l'installation d'OS. Lors du démarrage en utilisant " With injected kexts " le chargement en  mode verbose se stoppe à  " [iOBluetoothHCIController][searchForTransportEventTimeOutHandler] -- Missing Bluetooth Controller Transport ( j'ai pris une photo mais je ne sais pas comment l'insérer dans mon post).

Share this post


Link to post
Share on other sites

ça ressemble à un soucis avec la carte graphique. (oui je sais ça parle de bluetooth pourtant :D) mais c'est le moment ou l'interface graphique devrait être lancé

c'est donc un portable, avec gpu intel et nvidia si j'en crois ta signature donc je suppose, avec optimus ?

 

à tout hasard, est ce que tu peux désactiver la nvidia ?

 

mais je te dirais qu'il faudrait que t'ailles verifier les options de boot de clover.

dans la partie graphique, voir si l'option pour injecter l'intel est bien active (normalment, par défaut ça l'est)

Share this post


Link to post
Share on other sites

Oui tout a fais.

 

Alors la par contre aucune idée de comment désactiver la carte graphique Nvidia ..

J'ai vérifié les options de boot de clover et effectivement dans la partie graphique je vois écrit intel HD 4400. 

Share this post


Link to post
Share on other sites

pour la nvidia, en croisant les doigts et avec un peu de chance, c'est peut être possible dans le bios (enfin, efi dans ton cas :D)

sinon, faudra le faire apres l'installation via une modif dsdt, ça te fera economiser de la batterie.

 

pour l'intel, tu as remarqué si l'option d'injection était bien selectionée ? "inject intel" si je dis pas de blague.

faudra sûrement jouer avec des options, peut être indiquer le bon id ou quelquechose du genre...

mais je pense que la clé est là. arriver à bien faire reconnaitre l'intel.

 

essaye voir de booter en safe mode, voir si tu arrive bien à l'écran d'installation. et tu me dis si ça passe comme ça ou pas.

Share this post


Link to post
Share on other sites
Alors malheureusement je n'ai pas eu la chance de pouvoir la désactiver à partir du bios. Pour la modification DSDT je ne m'y connais vraiment pas et sachant que ce sera après l'installation je ne pourrais donc pas utiliser ma carte graphique Nvidia sur l'OS X Mavericks ?

 

Je ne sais pas vraiment si l'option d'injection est bien sélectionnée, je trouve quand même bizarre que sa me donne un modèle intel HD 4400 alors que mon contrôleur graphique est un intel HD 4600.

 

Concernant le safe mode, j'ai droit a un problème de reboot instantané  :mad:

Share this post


Link to post
Share on other sites

nope, tu pourras pas utiliser la nvidia avec osx, à cause d'optimus, la bascule ne peut pas se faire.

 

pour le reboot en boucle... alors là, perso je seche un peu.

ça pourrait ressembler au probleme de mavericks avec les cartes meres haswell verouillées sur un truc pour la gestion de l'energie, faut un kernel patché pour éviter ça.

il me semble que clover et capable de corriger ce probleme à la volée, mais peut être pas en safe mode...

 

parcontre, si j'en crois intel, tu as bien une 4400 : http://ark.intel.com/fr/products/75460/Intel-Core-i7-4500U-Processor-4M-Cache-up-to-3_00-GHz

Share this post


Link to post
Share on other sites

Je ne sais pas ce que c'est optimus car je n'ai jamais encore vu cela nulle part sur mon pc. Sa m'embêterais de ne pas pouvoir avoir la Nvidia car j'ai l'intention d'utiliser fréquemment Final Cut Pro X et autres logiciels de graphisme. 

Pour le reboot je vais essayer de patcher mon kernel pour qu'il soit compatible Haswell.

Comment puis je insérer des photos dans mon post pour montrer les problèmes que je rencontre  ? 

Share this post


Link to post
Share on other sites

-> Tu cliques sur "More Reply Options" en bas à droite de la fenêtre de post.
 
Optimus n'est pas supporté sur Hackintosh; tu es obligé de désactiver ou l'Intel HD ou le nVidia. Soit pas BIOS, soit par patch DSDT.
 
Pour le patch Haswell, regarde ici.

Share this post


Link to post
Share on other sites

Merci Hervé pour votre réponse.

Donc si je comprend bien je dois choisir d'utilisé soit le GPU intel ou le GPU Nvidia pour mon Hackintosh ?

Sachant que mon utilisation reposera plus sur du graphisme je préfère utiliser uniquement ma Nvidia, mais je ne sais pas comment patcher mon DSDT car je ne peut pas le faire via mon BIOS.

Share this post


Link to post
Share on other sites

Merci Hervé pour votre réponse.

Donc si je comprend bien je dois choisir d'utilisé soit le GPU intel ou le GPU Nvidia pour mon Hackintosh ?

Sachant que mon utilisation reposera plus sur du graphisme je préfère utiliser uniquement ma Nvidia, mais je ne sais pas comment patcher mon DSDT car je ne peut pas le faire via mon BIOS.

il est équipé d'optimus, donc c'est définitivement cuit pour la nvidia.

donc faudra soit te contenter de la HD4400, ou rester sous windows.

 

de toute façon, si tu voulais vraiment utiliser FCP, à la limite, la HD4400 devrait pas trop mal s'en sortir avec opencl. (FCP n'utilise pas cuda)

les nvidia kepler sont pas terrible en opencl. donc finalment, tu perds peut être pas grand chose :)

Share this post


Link to post
Share on other sites

non, à cause d'optimus.

et a cause de ça, la sortie video de la nvidia passe par l'intel.

 

c'est mort, il n'existe toujours pas de solution pour le support d'optimus sous osx :(

Share this post


Link to post
Share on other sites

Bon alors si ce n'est pas si mal d'utiliser FCPX avec la carte Intel je veux bien essayé avec :) Mais mon problème avec clover n'est néanmoins non résolu  :(

Share this post


Link to post
Share on other sites

Pour cela il va falloir que je patch mon DSDT pour désactiver ma nVidia ? 

J'ai patché mon kernel pour qu'il soit compatible Haswell mais l'étape de la DSDT j'y suis un peu perdu car je ne sais ni ou trouver le fichier ni comment le créer ni comment le modifier  :(

Share this post


Link to post
Share on other sites

je dirais, chaque chose en son temps :D

pour le moment, si t'as pas encore reussi l'install, c'est pas tres gênant que la nvidia soit encore active.

elle devrait pas poser de probleme (à part pomper de la batterie pour que dalle). avant ça en posait... dans mon cas, avec 10.7/8 il avait fallu que je la désactive (mais coup de bol, je peux le faire dans le bios) pour pouvoir faire l'install, mais depuis 10.9 ça ne gêne plus.

 

là pour le moment, je pense que tu devrais chercher des infos pour configurer la intel avec clover, parceque je pense que ton soucis vient de là pour l'instant.

on verra apres pour le dsdt. y'a des topics tres complet qui concernent optimus, dans la partie anglophone du forum :)

Share this post


Link to post
Share on other sites

salut

 

pour passer cette erreur [iOBluetoothHCIController][searchForTransportEventTimeOutHandler] -- Missing Bluetooth Controller Transport

 

il suffit simplement de supprimer tous les kexts intel (surtout AppleIntelCapriFramebuffer et AppleIntelAzulFramebuffer) et nvidia (tout ce qui commence par NVDA) sur ton support, qui doit être ta clé usb.

 

c'est tout  ;)

 

Par contre, si tu peux les sauvegarder, ce serait (peut-être ?) une bonne chose; il se pourrait que certains de ces kexts précédemment supprimés se retrouvent sans Info.plist, une fois ton install fini.

 

C'est pour cette raison que bcp n'arrivent pas à faire fonctionner leur IntelHD4000 ou + alors que l'astuce (que ce soit avec Chameleon ou Clover) fonctionne très bien.

Share this post


Link to post
Share on other sites

Bonjour,

Merci de votre réponse mais ou se trouve les kexts intel et nvidia ? Car avec clover je ne sais pas ou se trouvent les kexts en question.

Share this post


Link to post
Share on other sites

Ce répertoire n'existe pas avec la méthode d'installation par clover.

Ma clé possède une partition EFI (créée par clover) et la partition Install OS X Mavericks (qui inclut que Install OS X Mavericks.app)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×