Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


IATKOS ML2: Can't Create Boot USB (Win & or OSX 10.5.2)

4 posts in this topic

Recommended Posts

I don't have a Blueray DVD-R/RW, so I'd have to install this from a USB stick.


I have tried the following options, and miserably failed with each of them.


A) Windows 7


1) Using TransMac


a) I used Transmac to copy the .dmg file to the USB, but it won't make it bootable.


b ) I used Bootdisk utility to install clover and chameleon. The USB boots,  but the boot menu won't install the package. It just hangs.


2) Using 2 USB drives  in Windows 7


a) I used  DMG2IMG to convert the  .dmg to .img file.


B) I, then, used  Win32img to write the .img file to the USB.


c) Finally, I used Bootdiskutility to install clover and chameleon.


This boots the USB, but the boot menu  doesn't install the package. It just get stuck there.


B) Kalyway 10.5.2


1) Carbon Copy Cloner to write the .dmg file to the USB.


Kalyway 10.5.2 with the Vanilla_93 kernel won't install many Mac programs, including Carbon Copy Cloner, Unarchiver, or even the Mac drivers for a USB WiFi modem.


2) Inbuilt Mac Disk Utility.


a) I used the restore function with the source and destination options. It did write the .dmg file to the USB.


B) I then used Chameloen multibooter ML2_Bootloader_Installer.pkg.zip to make it bootable. It goes a few seconds into the boot process and then reboots the computer.


3) ##### fails to execute the script.


4) Mutibeast installs the loader. It boots with the loaders, but the bootloader 'options menu' doesn't load from the USB when I choose it. It just hangs.


E) I have a Dell Inspiron 9400 with Windows 7 Enterprise and Kalway 10.5.2 OSX (Kalyway 10.5.2 installation was very simple. I just burned the ISO to a DVD, and booted from it)


a) I have both disabled and enabled the multi-core, speedstep, hyperthreading and AHCI options.


1) OSX won't boot from a GUID partition, so I used EASYBCD and then renamed chain0 for the multiboot menu. This works fine for the Kalyway 10.5.2


2) I've formatted the USB drive with an MBR partition (Mac Extended Journaled), but it still won't boot from it.


F) Is the problem with the extracted image? It shows an IATKOS icon, and you find the two primary folders inside it when you double click on it . Do  I need to take these folders out, and place them in the root directory? Or Do i need to try a different boot loader?


Suggestions, please.


( Could you provide me with some information on GUID partitions. I'm only familiar with the MBR.


I've been taking computers apart since 1987, but am not familiar with the OSX. I stuck to DOS, UNIX, and Windows 3.1. I finally chose Windows 95 over the OSX in 1995, and never looked back.


I've realized that the PC BIOS doesn't recognize Active GUID Partitions. I managed to boot the Kalyway only after I made the entry in EASYBCD and then renamed chain0 to fool EasyBCD because its  menu isn't as neat as that of Chain0. I hear you need tboot for logical partitions. You do realize that the files on primary partitions are invisible from other primary partitions, but those from extended ones are accessible.)

Share this post

Link to post
Share on other sites

A) In short; I don't have a Blueray DVD-R/RW, so I'd have to install IATKOS ML2 from a USB stick.


1) I have successfully transferred the IATKOS ML2 .dmg file to the USB using numerous programs.


(I have used Carbon Copy Cloner, Transmac, and the 'Restore Option' on OS X's  Disk Utility .All work flawlessly)


2) I have also transferred OS X boot files to the USB.


(I have done so using the Chameleon (Multiboot loader), Clover (BootDisk Utility, and Chimera (Mult-beast). All of these work without a glitch.  Uni)Beast won't work for me).


3) I'm having the same IATKOS problem with every bootloader. It loads, but then reboots the computer, a few seconds into the IATKOS ML-2 Menu Option.


B- I Installed  OS X 10.5.2 from the (Kalyway 10.5.2) .iso file, which I simply burnt to a DVD drive and booted from it. It took me 10 minutes to install that. 


C- I have enabled/disabled multiple cores, virtualization, and speedstepping. I have tried both MBR and GUID Partition Tables. 


Can anyone help? This is an inspiron 9400 with the ATI Radeon X1400 video chip, but I have chosen generic drivers in each instance of the install process. I











( I don't plan to buy a Blueray DVD-R/RW.


 I've had eternal problems with CD/DVD and floppy drives, and am very averse to them. 


The laser/magnetic sensor/reader and the media have been a chronic problem with both since my first computer, from 1985.


Nothing beats the NAND Drive/USB)



One final question! Can the PC BIOS read the GUID partition? Mine couldn't, but strangely it does read the partition through all Multiple boot utilities.


It does so through EASYBCD which just adds a Mac line to the Windows boot sequence.


It also does so through the chain0 and tboot utilities.


My PC wouldn't booth  boot from OSX regardless of whether I used Hiren's  to make the partition active or if OS X made the ( HFS+, Mac Extended Journaled) GUID partition active. 


It also is rather odd for my OS X Snow Leopard (Kalyway 10.5.2) to not be into run Wifi drivers from OEMs for Wifi USB dongles. It also wouldn't install Carbon Copy Cloner or the Unarchiver for Mac/OS X. It doesn't run most Mac/OS X software. It strangely does run some, and I'm sure it has nothing to do with 16, 32 and 64 bit variants.

Share this post

Link to post
Share on other sites

Bro, install the iatkos image using VMware Virtual machine so that you have a working OSX.

After restoring the iAtkos ML2 image (.DMG file) to the USB stick (using Apple's disk utility on the osX), you should install a PKG of chameleon bootloader to the same USB so that it becomes bootable.


Here, download this one:


Unzip the file, then install the .PKG to the USB stick. Be careful not to install it to your own mac.


After you follow those steps, it will boot right away from the USB.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.