Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

(Success) GA-X79-UP4 + 4820k

3 posts in this topic

Recommended Posts

The build:

-Motherboard: GA-X79-UP4

-CPU: Intel Core i7 4820K 3,7Ghz Stock core (4,2 OC, it can go to 4,6 arriving 5,2 turbo frequency without temps problems using air cooling)

-Memory: G-Skill 1600Mhz CL7 (OC 2400Mhz) 8Gb --> 32Gb (soon)

-GPU: GTX 560 (Non-ti)


    SSD Kingston 3K 256Gb (MAC OS)

    SSD Kingston v500 128Gb (Windows)

    HDD Seagate 2Tb (Data)

-Wifi: Ebay airport extreme PCI-e x1 card (native working)


-How to install:

    -Create an usb MAC OS installer (nothing special)  10.9.2

    -Boot into the installer using these flags; -x -v -f npci=0x2000 PCIRootUID=0 GraphicsEnabler=yes cpus=1 (Booting into the 

     installer   it´s slow, wait some minutes)

    -Install as ever we have made.

    -Then reboot and boot using usb installer, but this time boot into drive you have installed mac os, using the same flags; -x -v -f 

     npci=0x2000 PCIRootUID=0 GraphicsEnabler=yes cpus=1

    -Finish configuration, create user....



  -What we need:

    -Go to Rampage Dev Blog and download X79.dmg http://rampagedev.wordpress.com/dsdt-downloads/gigabyte-x79/

    -Download last chameleon release

  -How to:

    -Now install chameleon

    -This is my chameleon boot config:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">




<key>Graphics Mode</key>






<key>Kernel Flags</key>

<string>npci=0x2000 darkwake=0</string>












    -Well, now open x79.dmg and copy to your extra folder SSDT, SSDT-1 and DSDT, also put into modules folder FileNVRAM.dilyb, and

     you will need too in extra/extensions put VodooTSCsync.kext NullCPUPowerManagement.kext FakeSMC.kext


    -Now, use the forum search feature to find and install; 

      -Audio: ALC892 with dsdt

      -Network: RTL81XX

      -Misc: TRIM enabler, VodooTSCSyc (4 Core) and FakeSMC



That´s all.



Stepping is working properly but non turbo-boost, also sleep works but fans keep running (NullCPUPM i think), and ALC892 crackles using chrome, garageband and logic pro (i wanted it for audio mastering, i hope this will be solved soon in next releases).

I can´t pass 4,2Ghz in mac os, so i get around 16000 geekbench, and turbo does no work, but using windows 4.6Ghz -->5,2Ghz(turbo) i hit 19000 geekbench points.



PD: Sorry for my bad english, i am spanish, and good luck with your builds.

Edited by fantomas1
Post edited! We don't support tonymacx86 tools!

Share this post

Link to post
Share on other sites

Hallo! It's REALLY worked?

I have the same MB, but CPU Intel Core i7-4930K, 3.40ГГц  

I have long been using the loader Clover, and had forgotten Chameleon....

When the system boots, you used DSDT? Where can I get the corrected DSDT? Or you only have SSDT from rampagedev?

Thank you!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.