Jump to content
InsanelyMac Forum
Sign in to follow this  
Lotustar

8400 GS..simple right? Nope

Recommended Posts

Could REALLY use some help from the gurus out there. I have a PNY 8400GS 512 PCI card I cannot get working properly. I've used this card before without problems but now...who knows. The problem is I can't get any resolution choices besides the 1024x768 and obviously no qe/ci. But! In safe mode I get the many resolution choices except when I choose my monitor resolution the screen goes blue and stays that way. Makes me think a kext problem. Also I am using VGA connection. My monitor has no DVI. Here's what I've tried:

Nvenabler

Nvinject

Nvkush

Efi strings

Added Id to nvdan50hal. Nvdan40hal, nvdoresman

Misc boot flags

 

Specs:

Asus p5n-e sli mobo

PNY 8400gs 512 PCI 0x06e4 VGA/DVI

3G ram

Aiktos s3 v2

 

This would be a perfect install if I could just get this card working properly. Have a sneaking suspicion it's nvdan50hal. PLEASE anybody that can help. Spent all weekend on this. Thanks!

Share this post


Link to post
Share on other sites
Advertisement

Thanks for replying fantomas. I will give it a read! :-). Have A feeling if it's not kext related then it's VGA problem. I bet the dvi output is working just fine. But I need a dvi to VGA adapter to tell. Sigh.

Share this post


Link to post
Share on other sites

Ok I've gone through a ton of posts and guides, got a dvi to vga adapter, and spent hours on this. Surely someone has an idea how to get this card working. It supposed to work out of box. GraphicsEnabler=Yes does not work. As do all the other boot flags I've tried. My card is listed in efi studio but I get black screen after trying that unless I use -x for safe boot. Then my mouse goes crazy and backwards. I've tried soooo many kexts but still no joy. This is a PNY 8400 gs 512 PCI with VGA and dvi. 0x064e. Iatkos s3 v2 using chameleon rc4 (but have tried them all), and I never choose any kexts on install besides nforce sata for my mobo (no ahci in my bios). Booting in 32 bit. PLEASE someone help. I've been member here for years and done MANY hackintoshes. This card situation is ridiculous.

Share this post


Link to post
Share on other sites

Yep. Got a dvi to vga adapter. Same old bs. I updated to 10.6.7 also. Still a no go. If I boot in safe mode it's better and I actually have resolution choices all the way to 1400x900 and that's what my monitor will do. This has gone way past ridiculous. And I've used this card in a hp pavilion a6030n with amd 64. Full resolution and qe/ci! I will give those links you posted a read but chances are I've read them. Thanks so much for your reply.

Share this post


Link to post
Share on other sites

Ok I will try that. Now I have done that before with nvdanv50 and nvdrasman(I didn't spell that right) and got black screen and had to reinstall because I couldn't boot back to safe mode. Ok so now I have no efi strings or injectors and I'm gonna add id to the two kexts you just mention. Will post back in a bit. Fingers crossed. Btw, I have no com.apple.boot.plist in my extra folder. Always did before. Now it's in L/S/P/S. Stock place I'm assuming. Make a difference?

Share this post


Link to post
Share on other sites

Made no difference adding id to nvdanv50 and GeForce.kext. Tried booting with GraphicsEnabler=Yes as well. No change. At least I didn't get stuck on a black screen this time though. Ugh. Two weekends now I have spent on this. There has to be a solution.

Unfortunately my internet is down right now so I can't send you those. I don't use dsdt either. Posting this on my phone.

Share this post


Link to post
Share on other sites

What really frakkin sucks is that efi studio lists my card and I write to boot.plist and boot back up I do get back to desktop but it doesn't all load and I can't click a single thing. Also my mouse pointer moves backward and jumps all over the place. So it's a real pain to remove efi string with a mouse doing that even in safe boot.

I know. A vanilla install is always better. But I don't choose anything but nforce under sata for my mobo. Have no ahci option. And I've used distros many times without a problem. So who knows. May have to just give this up. I hate being defeated by this card. Grrrr.

Share this post


Link to post
Share on other sites

@ Lotustar

 

No explicit AHCI option in BIOS is not an issue...........invariably on nForce MOBOs with a BIOS that does not have an explicit SATA Controller Mode with an AHCI mode setting, enabling RAID but disabling each SATA RAID channel in BIOS (assuming that you are not using a RAID setup) implicitly enables AHCI mode........

 

Pre_Series7_nForce_Chipset_BIOS_SettingsV2.pdf

 

See http://www.insanelymac.com/forum/topic/263931-nforce-os-x-lion-107-app-store-download-install-guide-on-a-series-6-or-7-nforce-chipset-intel-cpu-mobo/?p=1725686 re graphics card operation.....

Share this post


Link to post
Share on other sites

Oh wow thanks verdant! I didn't know that. I was trying to install iatkos L2 and ran into the dreaded still waiting for root device issue. So I bet setting raid up that way would work. Then maybe lion would handle my 8400gs a bit better. Gonna check those links. Thanks man! ;-)

Share this post


Link to post
Share on other sites

Ok I'm totally lost on this raid thing. I'm not sure I can disable "channels". I can disable sata ports and there is a place on my mobo to enable raid. Under enable raid it shows my 4 sata ports and has enable or disable under them. Also there is a place that says sata 1,2 and then sata 3,4 channels. And under those something about dma. I'm confused here.

Share this post


Link to post
Share on other sites

@ Lotustar

 

Your Asus p5n-e sli MOBO has a 650i chipset, so match all your BIOS parameter settings that match the corresponding BIOS parameters for the 650i BIOS settings for OS X, that I have listed in my nForce BIOS template attached to my previous post.....

Share this post


Link to post
Share on other sites

Ok cool. Thanks again

Share this post


Link to post
Share on other sites

Well Verdant, I followed EXACTLY the mobo settings and it made no difference. Also, I have no option for AHCI under Jmicron. So I just chose enabled. Still, iatkos S3 installs no problem with nforce sata option and boots fine. Graphics still a no go. Stuck at 1024x768 no matter what I try. Trying to install iatkos L2 to correct this and maybe have a bit more current system still no go. Install is fine when I use the nforce sata package from iatkos S3 on my usb installer but post install I get waiting for root device after a long string that mentions something about uuid and IOResource something or other. There is no option on iatkos L2 for nforce sata. Tried all the other sata options on install. Even all at once. Ugh. So I don't know. Maybe it's time to just quit. But I can't!! Have to know why this why work. Bugs me.

Share this post


Link to post
Share on other sites

UPDATE: Managed to update to 10.6.8 with combo updates. Also found a 64 bit kext for nforce sata. So no more arch=i386. Was hoping that would let me use nvenabler64 since I'm booting 64 bit now but no. Same old same old. Most things I try give me a black screen. So then I have to boot -x to remove whatever I did. And with a jumpy out of control pointer. What a pain. What could be causing this!!!? SOMEONE out there has to know. Please?

Share this post


Link to post
Share on other sites

Try DSDT GFX0 and DTGP etc. patching.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Crack download software petromod v2016.2 GeoTeric v2017 paleoscan v2016.1 Leica CloudWorx v6.2 techlog v2016.1
      ttmeps#gmail.com ----- change "#" to "@"
      Anything you need,You can also check here: ctrl + f
        midas civil 2018 v1.2
      symmetre r410
      CP-Studio
      kepware 5.20
      saia PG5 2.1
      Motocom32 dx200 plus
      procon-win 3.5
      midas soilworks 3.5
      geostudio 2012
      technet GMbH PreDesigner 2017
      framecad structure v8
      csi preform 3d v6
      geogiga seismic pro 8.3
      citect 7.2
      3dbody 7.0
      3shape convince
      plastycad
      hypermill 2018
      deswik suite 2017.1
      Scania XCom 2.30
      tebis 4.0
      3shape implant studio 2017
      Cape pack V2.15
      Prinect Signa Station 2017
      exoplan 2017.03
      MagiCAD 2018 
      ExoCad 2017.12
      MillBox 2016
      GOM ARAMIS 6.15
      Blue Sky Plan v3 x64
      Maestro 3D Dental Studio 4
      Sirona InLab 4.2.5
      Maestro Ortho Studio Build 2.8
      Zirkonzahn 2017
      Dolphin Imaging 11.9
      Digital Smile System 1.9.8
      PlastyCAD 1.7
      3Diagnosys 4.1
      ArKaos MediaMaster 5.0.3
      smile designer pro v2.6.1 
      GEO5 2017
      TRUSS4 v10
      exocad Partial Framework 2017
      OnDemand3D Application 1.0.10.5385
      Dental Master 2016 
      Dental Wings (DWOS) 2016
      Ekahau Site Survey 8.6.1
      HYPACK 2016
      Dental Shaper
      Orcaflex 10.0e
      AQWA
      MOSES
      NAPA 2017
      offpipe
      maxsurf
      DNV GL AS PHAST
      DNV safty offshore 7.2
      aveva bocad suite 2.2.0.3
      AVEVA Engineering v14.1 SP1
      Aveva everything3D (E3D) v2.1
      napa ship designer
      numeca fine
      marine 3.1
      Veristar Hull, Stability, Homer, Optimise
      Hydrostar, ariane7
      AVEVA Marine 12.1 SP4.29
      sacs 11.0
      DNV Sesam all moduels
      Leica GEOMOS v5.0
      Rocscience RS3
      3shape orthodontic 2017
      Onyx ProductionHouse v12.1
      pc-dmis 2018
      exocad DentalCAD 2.2 Valletta
      exocad 2018
      frontline genflex 3.2c1
      frontline genesis 10.02
      ez-fixture 9.6.4
      ezgrid 9.5
      ucam 10.2
      em-test expert v8
      3shape design system 2017 2.17.3.0
      PC-DMIS 2018R1 x64
      Motor-CAD/Motorcad 11.1.5
      Synopsys Synplify FPGA 2017.09 Win&Linux FPGA
      Golden Software Strater 5.4.948
      Golden Software MapViewer 8.6.651
      Waterloo Visual MODFLOW Flex 2018.v5.1
      Cype 2017m
      Intergraph SmartPlant Spoolgen Isometrics 2014.v08
      Intergraph SmartSketch 2014.v08.00.00 R1
      Intergraph CAESAR II 2018 v10.00.00 x64
      Intergraph SmartPlant P&ID 2014 R1
      IHS QUE$TOR 2017 Q1
      Intergraph SmartPlant Review 2017 v12.00.00.0501
      ANSYS Apache Totem 14.1 Linux64
      Crosslight Csuprem 2018 x64
      Ensoft LPile 2018.10.02
      AnyBody Modeling System 7.1
      Antenna Magus 2018.0.v8.0 x64
      CGERisk BowTieXP 9.0.1
      PDI GRLWEAP Offshore Wave 2010-7
      NI AWR Design Environment with Analyst 13.03 x64
      Rock Flow Dynamics RFD tNavigator 2017.v17.3 x64
      CMG (Computer Modelling Group) Suite 2017.10
      PHDwin2.10.3
      meyer 12 2017.12
      Schlumberger petrel 2017
      HampsonRussell Suite 10.3 
      geoview 10.3 HRS 10.3
      Midland Valley move 2018.1
      jason 9.7
      Schlumberger CoilCADE 6.0
      Schlumberger StimCADE 4.0
      crystal 2018.1
      gohfer 9.0.1.6
      omni 2017.1
      tesseral pro 5.0.3b
      ERDAS IMAGINE 2018
      Waypoint Inertial Explorer 8.7
      Deswik suite 2017
      FAROBox PointSense plant 18.5
      EyeRadar 2.0
      Leica Xpro 6.4
      Trimble EdgeWise_v5.0.2SP1
      Trimble Business Center 4.0
      3DReshaper 2017 x64
      Amberg Tunnel 2
      virtual surveyor 3.6
      cloudworx for revit
      socet set 5.6
      socet GXP 4.1
      OrbitGT
      Riscan PRO 2.0 x64
      JAR reconstrucer 3.3.0 x64
      Materialise E-stage v6.6
      Virtual Surveyor 3.5
      CARIS HIPS and SIPS 10.2
      DP-moderler
      APS 7.6
      Imagestation SSK 2015
      Deswik 2017.2.1234
      EnterVol 2017.4 for ArcGis
      Geochemist Workbench 11.0.8
      Maptek Vulcan 10.1.4
      Tesseral Pro 5.0.3
      Tesseral 2D 7.2.8
      Global Mapper 19.0.2
      GEOVIA Surpac 6.8
      Ventsim 4.8
      MineSched 9.1.0 x64
      Paradigm 17
      VUMA3D-NETWORK 2018
      MineSight 12.0
      Maptek Eureka 4.1
      whittle 4.7.0.1
      Leapfrog Geo 4.0
      Leapfrog Geothermal 3.2
      Leapfrog Hydro 2.6
      OptiSPICE 5.2
      VPI transmission maker 9.8 x64
      VPI photonics Analyzer 9.8 x64
      VPI componentMaker 9.8 x64
      socet gxp 4.3
      GEOVIA GEMS 6.8.1
      GamaPrintPro
      PosterShop
      RipCente
      ProductionHouse 12
      neoStampa 8.1.5
      Fiery XF v6.5
      ORIS COLOR TUNER WEB 3.1
      ORIS PRESS MATCHER WEB 1.4
      FlexiSIGN & PRINT 12
      PhotoPrint 12 Cloud
      ColorGate V10
      neo Textil
      ACRORIP 9.03
      ErgoSoft RIP 15
      3shape trios 1.4.7.4
      OptiSystem 15
      plaxis 2D 2017
      plaxis 3D 2017
      Rocscience SLIDE3 V2017.010
      Rocscience SLIDE V7.029
      Rocscience RocData v5.008
      Rocscience RS3 v2.005
      Rocscience RS2 phase2 v9.023
      ITASCA 3DEC v5.20.250
      ITASCA Griddle v1.0.1
      ITASCA UDEC v6.0.323
      ITASCA PFC v5.0.32
      ITASCA Flac3D V6.0.48
      ITASCA Flac v8.0.443
    • Hahahaha.. right. Man this card is going to make me loose my mind. Funny thing is I had tried a XFX version before this one and a GTX 780 TI that both couldn't get to work correctly. . Hope I can get this to work. I was reading on another forum about flashing it with a 7970 ROM. DO you know anything about that?    I'm going to give that frame buffer a try . 
    • I think the SMSC chip is analogous to NSC chip supported by plugin  https://sourceforge.net/p/hwsensors/hwsensors3/code3/HEAD/tree/trunk/plugins/SuperIOSensors/NSCPC8739x/ No direct access to monitoring but we can find registers shadow to show them. Anyway, continue the research!
    • Good thanks, i guess you no with that card hhh  ! AMD graphic cards are known with that problem, so you should use the Hamachi or Futomaki as framebuffer, this is going to be the first step, if you still have that issue add RadeonDeInit in config with the help of Clover Configurator


×