Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Dell 17R Laptop network error on Mav 10.9.2

4 posts in this topic

Recommended Posts

My Dell Laptop is mostly running with 10.9.2.  


My main problem is that I can't get the internal wifi Atheros AR9565 802.11 to work or the internal LAN which is a Realtek RTL 8139/810x fast Ethernet adapter to work.  


Does anyone have a kext that would work?  I have tried updating the IO80211Family.kext to include my device as well as some DSDT edits.  


DPCi Manager reports: 


168C, 0036, 1028, 020C, Qualcomm Atheros, QCA9565 / AR9565 Wireless Network Adapter


10EC, 8136, 1028, 05EC, Realtek Semiconductor Co., Ltd., RTL8101E/RTL8102E PCI Express Fast Ethernet controller


My system uses the Haswell i7-4500 ULT cpu and has HD4400 GPU. That all is working fine.  


I had to use the hack on the mach_kernel to get past the initial panic error but since then I have made slow but sure progress getting things going.  Editing the DSDT is not my forte and a lot has changed since my first hack several years ago.  


My question is which path should bear fruit?  I can try to hack kexts that are close or try find DSDT patches that will get it going.  I have no idea what is best to do.



Share this post

Link to post
Share on other sites

I see a few folks have looked at my problem but no help.  I have made a little progress on my own but still no go.


On the Athernos wifi, I was able to modify the Atheros40.kext but the IONetworkFamily is looking for a plugin to match.  Any suggestions as to where to look or try to find a plugin?


On the Realtek 8139 I am close but no cigar.  I used IONetfamily and added a AppleRTL8139.kext to the plugin folder.  I left the info.list unmodified to my device address so it doesn't load.  Next installed the PCGenRTL8139.kext in my s/l/e folder and bingo!  I have an ethernet card.  It sees all the pertinent info like mac address and so on.  So what is the problem?


It says my cable is unplugged.  I have tried manual settings but no luck.  My cable is not unplugged as it works fine when I reboot in windows 8.1.  


My sense is that the PCGen kext is just too far out of date.


Any suggestions?  

Share this post

Link to post
Share on other sites

Okay, I am getting really close.  I am using Laura Millers latest Realtek RTL8111.kext

I can now see the cable plugging in and out.  says ethernet is connected but

can't auto sense my internet connection.  Putting the values in manually doesn't get me there.


log shows: 


2014-03-25 23:47:49 -0700 kernel[0]: Ethernet [RealtekRTL8111]: EEE support enabled.

2014-03-25 23:47:49 -0700 kernel[0]: Ethernet [RealtekRTL8111]: TCP/IPv4 segmentation offload enabled.

2014-03-25 23:47:49 -0700 WindowServer[128]: Server is starting up

2014-03-25 23:47:49 -0700 kernel[0]: Ethernet [RealtekRTL8111]: TCP/IPv6 checksum offload enabled.

2014-03-25 23:47:49 -0700 kernel[0]: Ethernet [RealtekRTL8111]: Using interrupt mitigate value 0xcf68.

2014-03-25 23:47:49 -0700 kernel[0]: unknown chip version (44800000)


my system info shows:

Realtek RTL8168B/8111B PCI Express Gigabit Ethernet:


  Name: ethernet

  Type: Ethernet Controller

  Bus: PCI

  Vendor ID: 0x10ec

  Device ID: 0x8136

  Subsystem Vendor ID: 0x1028

  Subsystem ID: 0x05ec

  Revision ID: 0x0007

  Link Width: x1

  BSD name: en0

  Kext name: RealtekRTL8111.kext

  Location: /System/Library/Extensions/RealtekRTL8111.kext

  Version: 1.1.3

annoying but close, any suggestions out there?

Share this post

Link to post
Share on other sites

I am on with the help of the Hackintosh Vietnam tool.  


it was the rtl8100 kext that solved the problem.  


for wifi I am using a usb pivot that works fine so I will close this thread.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.