Jump to content
About Just Joined group Read more... ×
Jeanp3rez

Triple Monitors on 7970 causes OS X 10.9 to Crash.

5 posts in this topic

Recommended Posts

So Currently I've had an issue that whenever I have more than 2 monitors connected Maverick will hang and crash immediately. Here some some details about my Computer's Spec.

•Motherboard: ASUS Maximus Hero VI Z87
•CPU: Intel Core i7 4770k @ 4.5Ghz
•GPU: AMD Gigabyte HD Radeon 7970
•Ram: 16GB 1600Mhz G.Skill DDR3
•HDD: Western Digital Black 650GB 7200 RPM
•PSU: 850 Watt 

After some troubleshooting I noticed that I can have 2 monitors if connect in these port on my GPU:
•DVI
•HDMI

However If I try to use my Active mini-DP adapter the OS will crash. In order to use three monitors with this GPU you need to use an Active Adapter for example:
•DVI
•HDMI
•Mini-DP (Active)

or 

•DVI
•Mini-DP
•Mini-DP (Active)

etc etc. 

I'm not sure how to troubleshoot and fix this any further, If anyone has any ideas or similiar issue please let me know. 

On as side note if it matters, While i'm on Windows HDD i can use the Three Monitors Perfectly while Gaming, Multitasking, and even using Eyefinity.

 
 
 
Here are some troubleshooting steps I've tried and still not progress: 
 
I've used ioreg | grep ATY to find out my Framebuffer but I do not understand it that well. 
Jeans-Mac-Pro:~ jean$ ioreg | grep ATY
    | |   |   | +-o ATY,AMD,RadeonFramebuffer@0  <class AtiFbStub, id 0x100000376, registered, matched, active, busy 0 (4 ms), retain 8>
    | |   |   | +-o ATY,AMD,RadeonFramebuffer@1  <class AtiFbStub, id 0x100000377, registered, matched, active, busy 0 (2 ms), retain 8>
    | |   |   | +-o ATY,AMD,RadeonFramebuffer@2  <class AtiFbStub, id 0x100000378, registered, matched, active, busy 0 (0 ms), retain 8>
    | |   |   | +-o ATY,AMD,RadeonFramebuffer@3  <class AtiFbStub, id 0x100000379, registered, matched, active, busy 0 (0 ms), retain 8>

After which I tried booting up using the following commands

GraphicsEnabler=No AtiConfig=Aji

I've also tried using the follow AtiConfigs: 

AtiConfig=Aji,Dashimaki,DashimakiS,Futomaki,Hamachi

Each at one at a time when booting of course. None of which have gotten me pass the Apple Loading screen it just hangs and freezes. 

 

 

Side Note, If I try to boot using GraphicsEnabler=Yes I receive the following Error. (This error happens even when I boot using only two monitors).

Memory allocation error! Addr: 0xdeadbeef, Size: 0x0, File: ati.c, Line 1725

This is a non recoverable error! System HALTED!!!

So Quick Recap of my issue. my Active Mini-DP Adapter does NOT work with Mac OS X 10.9 it will freeze my computer. Hence, being unable to use my Active Mini-DP means I can not use three monitors with my AMD HD Radeon Gigabyte 7970 3GB Graphics Card. However, I can use any Port in a Combination of 2, i.e: Mini-DP & HDMI, or DVI & HDMI, etc. 

 

 

Any Ideas on what else i can troubleshoot or find a fix? 

 

Share this post


Link to post
Share on other sites
Advertisement

Hello and welcome!

 

It would be just a workaround, but have you already played with the HDMI output of your motherboard? You will have to enable the iGPU (HD4600) with GraphicsEnabler=Yes and to prevent the deadbeef-kp with SkipAtiGfx=Yes. Assign the correct framebuffer to the HD4600 with IntelAzulFB=X (X stands for a value between 0 and 15, you will have to try them - start with 9 or 10).

 

Afaik you can't assign a specific FB with Chameleon to AMD series 7xxx and newer. Maybe a fix analog to http://www.insanelymac.com/forum/topic/294315-radeon-r9-270x-framebuffer-issue/ will do the trick for your triple setup...

 

Good luck!

Share this post


Link to post
Share on other sites

I tired these fixes so far now I can go pass the Apple Logo with one Monitor connected to my Integrated Graphics and HDMI & DVI from my Dedicated GPU (7970) to my Monitors. However after doing this I get nothing btu a Blank White Screen and I cant go into sleep mode or use the "Rotation" Trick. Any ideas? 

Share this post


Link to post
Share on other sites

I have a Sapphire R9 280x Toxic which has the same GPU as the 7970 and I'm having the same issue with my active DP - DVI adapter. It boots perfectly into windows when it is connected but Mac OS does not seem to be happy at all. I have also tried a number of the different FB personalities but without any success.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By kokozaurs
      Hi all,
       
      I'm using ESXI 7.0b (did use 6.7 to try but with no difference).
       
      Right now on Catalina but I can't seem to try to get GPU (RX580) working properly.
       
      I pass it through to the VM(tried with windows before with no problems) and it appeared just as pci-device with no name.
       
      After that, I've applied whatevergreen + lilu kexts and it does properly recognize it under system report however that's all there is. It's listed at GFX0. See attached images.
       
      No hardware acceleration. Monitor also not turning on using either DP/HDMI. 
       
      Since it is being passed through to the VM, it seems that the problem is not on ESXi side but on macOS side. 
       
      Has anyone has been able to pass through an AMD GPU to ESXI VM? Can anyone suggest some pointers as to where I could find some solutions to this problem?
       
      Thanks! 
       
       



    • By b2550
      Currently my install is 100% working except that so far I have only been able to get one of my 1080p monitors working with a MiniDP to HDMI cable. I currently am getting a second MiniDP to HDMI cable but for now I am stuck with a DVI to HDMI cable.

      The monitor that is working is plugged in via the MiniDP to HDMI. The monitor that isn't working is using the DVI cable. However I also tried switching it to HDMI to HDMI which had the same result. The monitor wakes up but it's black. However for whatever reason, both monitors are still recognized in system preferences and hackintool.

      I know all my cables are good and work because I updated from an install of El Capitan (which I still have on it's original SSD just in case this install fails) as well as a Windows install. Both monitors worked fine on El Capitan for literally years. El Capitan is just too old now and I need to update to keep up with software updates.

      Problem reporting files should provide needed info about how I've configured this install. Build is in my signature.
      debug_22725.zip
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
    • By Johnnycale
      Hi everybody. I'm stuck here and after a few days I'm really not able to boot.
      My setup is the following:
       
      CPU AMD Ryzen 9 3900x
      GPU Aorus RX 5700 XT
      MOTHERBOARD AsRock x570m Pro4
      SSD 1 Corsair MP600 1TB
      SSD 2 Gigabyte Aorus NVMe 1TB
      RAM Crucial Ballistix 2x32GB
      WIFI BCM94360CD

      Error message from Bios attached to this thread.

      Thanks to anyone willing to help me. I've tried different open core versions, adding and removing a lot of kexts, keeping essentials ACPIs, setting as true or false different .plist settings that I saw resolving similar issues as mine but nothing seems to work.
      opencore-2020-09-07-214007.txt
×