Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

PlistBuddy base64 data in Clover config.plist

4 posts in this topic

Recommended Posts



I am making an automation script for installing Clover onto a drive's EFI partition.

For editing the stock config.plist i use PlistBuddy (located in /usr/libexec/PlistBuddy), and the following command causes issues:

/usr/libexec/PlistBuddy -c "Add :KernelAndKextPatches:KextsToPatch:0:Find data ixnUEQ==" $config

I tried replacing


with other bases, e.g. 



10001011 00011001 11010100 00010001

but none yields the desired result, which is:



Do you have any suggestion as to what I could do instead?


Any help would be appreciated.

Thank you!


EDIT: Solved it. See post 3.

Share this post

Link to post
Share on other sites

Bump? i tried messing around with the "defaults" command, but it seems that it can only modify keys at the "root" of the .plist.

Should it be possible to do with perl/grep/sed?

Thank you!

Share this post

Link to post
Share on other sites

It is not pretty, but it works. I solved it by combining these commands (the gibberish data is the faulty data that ended up in the $config file):

/usr/libexec/PlistBuddy -c "Add :KernelAndKextPatches:KextsToPatch:0:Find data ixnUEQ==" $config
/usr/libexec/PlistBuddy -c "Add :KernelAndKextPatches:KextsToPatch:0:Replace data kgjsEA==" $config

/usr/libexec/PlistBuddy -c "Add :KernelAndKextPatches:KextsToPatch:1:Find data QVBQTEUgU1NE" $config
/usr/libexec/PlistBuddy -c "Add :KernelAndKextPatches:KextsToPatch:1:Replace data AAAAAAAAAAAA" $config

perl -pi -e 's/aXhuVUVRPT0=/ixnUEQ==/g' $config
perl -pi -e 's/a2dqc0VBPT0=/kgjsEA==/g' $config

perl -pi -e 's/UVZCUVRFVWdVMU5F/QVBQTEUgU1NE/g' $config

Share this post

Link to post
Share on other sites

Save the binary data to a file and use the Import command. 

/usr/libexec/PlistBuddy -c \"Import :IOKitPersonalities:HDA\ Hardware\ Config\ Resource:HDAConfigDefault:0:AFGLowPowerState tmp.bin\" plist"

where tmp.bin is the binary file.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.