Jump to content

ASUS X79-Deluxe, i7 4930K, EVGA GTX 680 FTW Edition


6 posts in this topic

Recommended Posts



I just got 10.9.2 up and running using this guide:



Firstly, thank you for that!  I have 3 systems running 10.9.2 and they all had the best install experience using this method.  Sure, I had to customize it with some post-installation techniques and procedures unique for my systems, but the tutorial was awesome - even got the MBR install to work on my Dell XPS M1330 with Win7 HP dual boot off the same HD.


I'm loving the speed and power as I do a lot of pro video work. Blows Win 8.1 Pro out of the water in comparing NLE video timeline scrubbing and overall responsiveness. I was getting sick of Adobe CC apps stuttering during video editing/playback, or the Scratch Disk HD's having to catch up to the playhead resulting in "buffer time" during playback. After Effects CUDA also not as responsive as it should be. Maybe It's Win8.1, Maybe it's Adobe, or a combination of both, but the performance was just unacceptable for this build.

My Build Specs are in my sig. I would've actually purchased the new MacPro but my old system for which is used for work (Now my build #2 after some part replacements) was out of commission, and I needed a new build fast (Oct 2013) and couldn't wait for the MacPro's to come out as I would have lost a lot of clients and therefore money. 

I just wanted to report to others with a similar configuration (X79-Deluxe), what issues I had and how I resolved them. (Black screen being the biggest one, as a lot of people were having this issue as well)

1. Follow the guide.  It's very easy to follow and if done right, works perfectly!

2. Booting up. This is where I had all of my issues pre-install. I was one of the people that had the infamous black screen right at Starting Darwin X86_64. For the life of me, I couldn't get the kernel to boot no matter how hard I tried. I tried every boot flag. cpus=1 npci=0x3000 PCIRootUID=1/0 GraphicsEnabler=No/Yes dart=0 -v -f -x a combination of all of these, different values for npci and PCIRootUID and still nothing. I thought I was done, was about to give up. I had previously successfully installed it on my other rigs (where I used "the infamous post-install tool" and a lot of kexts for the Dell to work) and I was at a loss.

So just out of a hunch, I decided to re-build my Install USB using a different USB Stick. They are both Kingston Data Traveler 2.0, the first was a 16GB (Metallic Silver) the one I rebuilt the installer to was a 64GB Green.  The first USB was created through the MBR Hack part of the guide, which allows you to install OSX on a MBR partition in order to dual boot windows and OSX from the same drive.  I guess because of that, the Kernel wasn't loading resulting in a blank screen.  So if you are getting a black screen, make sure your USB disk prep was executed correctly.


Well, that seemed to do the trick. Now, the only boot flag I required was npci=0x3000. I booted with additional -v -f flags as well as I think the installer wouldn't have loaded since I "added/modified" kexts just by simply copying and pasting on the installer USB, so Ignoring cache would let me get past any permission issues.


The installer now loaded fine, partitioned my 128GB SSD for the OSX install, installed quickly, re-started. Booted back from the USB into the installer. Opened terminal, copied -R FakeSMC.kext from the USB S/L/E to the newly installed "Macintosh HD" S/L/E location.


On my i72600K build I also had to copy -R the NullCPUPowerManagement.kext as well as it gave me a kernel panic, but by reading that 10.9.2 added native speedstep/sleep/power support for the Ivy Bridge-E processors, I decided to try my luck and not copy it - I would've booted from the installer again and copied it via terminal if needed.

Well, everything booted beautifully even without NullCPUPowerManagement.kext. Was running at 1920x1080 natively on both of my 24" displays. boot time was ridiculously fast, even comparing it to my Win 8.1 Pro install on the other SSD. Shut Down, Restart, Sleep all worked OOB.


The only thing obviously that didn't is audio, LAN and USB 3.0. I tried following guides or forum posts of other users who successfully installed ALC1150. Didn't work, had to log in as -s (or even boot from the installer again and via terminal remove the installed ALC1150 kext/repair permissions).  Didn't run "the infamous post-install tool" as for some reason it did't let me de-select certain things (such as it wanted to add NullCPUPowerManagement and other things which I knew were going to screw things up) . I used VoodoHDA and AppleHDADisabler kexts instead of the ALC1150 and audio was fine after restart. Also installed the Realtek 8111GR LAN kext using kext utility and LAN now worked fine oob as well. Finally I installed the chameleon boot loader via chameleon wizard to the Macintosh HD, using option 2 (boot0md) so it recognizes my win 8.1 install.  I haven't tried initializing the other Intel 82579V LAN port yet.

The only issue now is that USB 3.0 doesn't work. I followed other guides, tried installing the CalDigit / ASMEDIA ASM 1042 from various sources on the web. Well that ended up freezing my system (funny I didn't get a KP) about 20 seconds into the login, every time. I presumed perhaps that it is probably because of the USB freq incompatibility and maybe I should've tried it with NullCPUPowerManagement, but decided against it as all of my USB 3.0 needs are satisfied in my Win 8.1 Pro Partition and this OSX workspace was only for my work - maybe someone has had some luck getting USB 3.0 that doesn't require disabling now natively supported CPU power management for the LGA2011 chip and they can advise. I didn't use any DSDT or anything and the only issue is that About This Mac sees my i7 4930K processor as an Intel Xeon E5 - don't know if that is an issue, but EVERYTHING has been VERY stable. Even more stable in fact than my MacBook Pro. (guess it's the same/similar architecture) 

I am very happy with the performance now. I have to say, that NOW things are running as they should be with my build. Premiere Pro, AfterEffects and all Adobe CC apps run very smooth. Video playback (Using CUDA, even Open CL is OK but why use it when I have NVIDIA) is seamless, AfterEffects handles 3D (Element and Native/C4D) very nicely. C4D is flying through, even in my Logic Pro X I can now use multiple channel strips/auxes on one track which used to sometimes choke my i7 2600k out. Pro tools 9.0.6 is also running very stable using the Mbox2 interface. All my USB 2.0 peripherals (Axiom 49 MIDI Controller, Pace iLok for Pro Tools, Behringer BCF200 Control Surface, Logitech webcam) work perfectly on USB 2.0 ports. I had an additional USB 2.0 PCI-2 Card which I added in for additional connectivity.

If this information helped anyone out with a similar build, then this thread served its purpose, as I almost gave up. Just have patience.


PS. Forgot to add, that I purchased Paragon NTFS in order to utilize (write) all of my production drives I used in windows which hold a lot of my projects. And still the playback is smooth even though they are all WD Caviar Black SATAIII.


Link to comment
Share on other sites



Apologies, very tired.  Been doing this install all day today, and finally got it to work.  The black screen prior to the install killed me, literally tried every boot flag for hours until I re-built the USB Installer.  


You didn't provide a DSDT for the X79-Deluxe (I guess it doesn't require one) however you SSDT is working very well and has my wifi enabled.  Also got USB 3.0  and native audio work with the "Infamous Nameless Tool"  The ALC1150 provided in the DMG with the scripts kept telling me "path not found" ran it from desktop where it extracted itself from the master folder (which included the kexts).  Tried Both folders actually on separate restarts.


The addition to smbios.plist you stated in your guide for correct CPU Identification "SMcputype 1281 (for 6 core) still shows my CPU as Xeon E5, but oh well.time to make a drive image backup.


Thank you for replying and providing guidance, much appreciated, expect a small donation soon.

Link to comment
Share on other sites

Again your not reading what the SSDT does... it injects code into the DSDT thus allowing it to be BIOS version free. Every board needs a edited DSDT or use a SSDT table to do so... so I do provide a edited SSDT... Stop skimming...


You must run the audio patch from the Downloads folder as per documentation for the audio patch... so again please read all documentation... Stop skimming...


The CPU key is only for proper CPU detection when no name is there...


Last use the kexts provided on the DMG as some are Keyed for LGA 2011 boards... 


In short you keep skimming when you read.  :P

Link to comment
Share on other sites


  • Create New...