Jump to content
ltooz_audis

Dual Boot Windows 8.1 and Mavericks On Envy 4-1117nr

5 posts in this topic

Recommended Posts

Hello all,

I've just finished installed Dual Boot Windows 8.1 and Mavericks using chameleon bootloader on my newly (used) HP Envy 4-1117nr. I got this one instead of the Envy 4-1030us because it's cheaper. It's almost the same except the 4-1030us doesn't have ATI 7600G option which is good. Since Chameleon Bootloader only works on MBR, I have to reformat the hard drive to MBR partition, install windows 8.1 with non-UEFI option. By doing this, all the software my HP may not be usable since it's loaded in UEFI partition. 

- To prepare windows 8.1, make sure to get the product id that came with the laptop by using windows keys finder software. Download all the Windows 8.1 drivers for the laptop.For HP_tools, you can install it to a usb drive and use it later since it doesn't have UEFI partition to load and if you triple boot, 4 partitions are used (max). If you only dual boot, then you can let the HP_UEFI program to install it on the hard drive.

- Other than that, everything works solidly with chameleon boot loader with this installation.

- Please add comments if you see something better. 

- I'm going to replace the hard drive with 1TB 7200rpm 32MB cache from Hitachi when I have time.

 

i5-3317u

NO ATI 7600G just HD4000 graphics.

4GB Ram  8GB Ram Added 4GB.

32GB SSD Cache

500GB hard drive

Wifi - Ralink RT3290 - doesn't work - using D-link dwa-131 and tenda W311U wireless USB adapter work great.

Replaced the module with AR9285 module from Ebay for $10 and wifi works perfectly 27Mbps - even windows 8 - no white list enforce. 2/18/2014

Bluetooth Ralink - doesn't work. Bluetooth AR3011 works with REHABMAN-ATHEROS-KEXT.

Ethernet Realtek 8168 works

Camera HP Truevision HD- works - USBBusFix must be NO for it to work.

Full QE/CI acceleration

Sleep works.

Trackpad works with Rehabman's

Battery management works with Rehabman's.

 

-Turn on legacy boot in bios F.23

-Boot with Chameleon boot loader V2344 on MS-DOS partition 600Mb on 8GB flash drive - Restored MBR Mavericks OS Install disk on the rest with apple HFS.

-Use an external USB hard drive to get Mavericks working - extract DSDT.aml before installing into hard drive.

-Use disk-utilities to partition 32GB GUID PT - 500GB MBR (erase NTFS).

post-613357-0-92833100-1393620670_thumb.jpgpost-613357-0-14356800-1393620692_thumb.jpg

-Exit.

-Install Windows 8.1 on 500GB using normal DVD boot selection and NOT UEFI option.

post-613357-0-84015300-1393620880_thumb.jpg

-Shrink 100GB in windows for Mavericks.

-Install Mavericks.

-Create DSDT and SSDT.

dsdt_ssdt.zip

-use SMBios Macbook pro 8,1 or 6,2 for speed steps and turbo frequencies - all others don't work.

Enable turbo 2.6Ghz and SSDT for i5-3317u cpu

post-613357-0-78457400-1393056720_thumb.png

-Running geekbench the results are so much different between no turbo and turbo.

post-613357-0-00362400-1393389810_thumb.pngpost-613357-0-06555800-1393389787_thumb.png

-For camera to work DONOT use USBBusFix=Yes.

post-613357-0-10184100-1393624238_thumb.jpg

-To remove NullCPU need to patch AppleIntelCPUManagement.kext.

-Install Chameleon with patched kernel option for lapic kernel KP.

-Boot GPT error.

post-613357-0-28020700-1393974303_thumb.jpg

-Use USB boot disk to boot and configure Mavericks to boot fully.

-Fix GPT Boot:0 error.

-After boot0: error fixed you may have windows /Boot/BCD missing or corrupted error - need to fix this too and re-install chameleon again.

-Mavericks On Envy 4-111nr

Kext needed : AHCI_3rdParty_SATA.kext, AHCIPortInjector.kext, FakeSMC.kext (dated jan13,2014),GenericUSBXHCI.kext, NullCPUPowerManagement.kext, VoodooPS2Controller.kext (Rehabman), AppleACPIPlatform.kext from Mavericks 10.9.1

HDMI audio doesn't work for now, but analog speakers and microphones work perfectly with voodooHDA 2.8.4.

IDT sound card 111d:76e0.

HDMI audio 8086:2806.

 

Dual boot using chameleon.

 

I decided to load Ubuntu 13.1 for Triple booting - perfect laptop

 

Sync Time With Windows 8.1 and Mavericks & Ubuntu.

 

Cheers,

 

Louis

post-613357-0-17727600-1393624607_thumb.jpg

post-613357-0-17870100-1393624607_thumb.jpg

Edited by ltooz_audis

Share this post


Link to post
Share on other sites
Advertisement

I replaced the wifi Ralink 3290 with AR9285 and AR3011 bluetooth combo and Windows 8.1 and Mavericks work. Mavericks works intermittently, when the country code is loaded with "US", it will scan all ssid around the area, if country code is blank, it doesn't see any SSID around. I need to figure this out. When it's connected it's great. Does anyone know how to force the Country code and locale for wifi?

Plug in the ethernet, reboot Mavericks, ethernet will set the "US" onto all network devices and updated the caches. Now the Wifi is set to "US" automatically.When Ethernet is set to EN0 Built-in and Wifi EN1 Built-in also, it will be up right away.

 

This is how to replace the wifi module on Envy 4

 

Cheers,

 

Louis

Share this post


Link to post
Share on other sites

Boot with ethernet cable connected - the system will set "US" to all devices - Wifi is set also - When cache is updated automatically - Wifi is working with boot up. If EN0 & EN1 are built-in everything works.

I found out by accident that if I close the lid to put it to sleep, open the lid up, the wifi reactivated and everything works with the Country Code loaded with "US". Tried it many times and it worked every time. This is weird.

 

Cheers,

 

Louis

Share this post


Link to post
Share on other sites

My Ethernet built-in Realtek 8168 10ec is NOT defined as built-in when update to 10.9.2, therefore, Apps store doesn't work. I need to figure this one out before I updated mine to 10.9.2. The Ethernet function stills works, the OSX just change the built-in to false and primary device = false also.

I haven't seem be able to patch the dsdt for this problem.

 

Use EFI_Studio to generate Ethernet XML and Graphics card - Modify graphic card to capri version 03.

create xml with both capri version 03 and Ethernet together. Make sure capri is first and ethernet second.

post-613357-0-53162900-1395089739_thumb.jpg

Use OSX86Tools to get efi string combo and add to "device-properties" in chameleon boot.plist.

post-613357-0-35971900-1395089827_thumb.jpg

No longer need "PciRoot=1"

post-613357-0-84760600-1395089973_thumb.jpg

 

Fixed en0 Ethernet built-in "FALSE"

 

Update Mavericks 10.9.2 successfully with en0 Ethernet built-in "TRUE".

 

 

Cheers,

 

Louis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tragediana150
      Hi everyone!
      Long time no see guys!
      As you can see I am not new user of Insanely and do not want to post in incorrect section, but I can not find any similiar topic at all. I,ve searched the forum and the web and I can't find a solution.
      My question is that is there any possibility to install Mavericks 10.9.5 on external drive on the newest Macbook Pro 13 from 2018? I know that the Intel Coffee Lake is new generation of CPU's and there is no drivers in Mavericks system to run this CPU, but I was thinking about it alot and I decided to write here. Because if we can install all the newest OSX, macOS on older machines then maybe we can install older systems on newer builds?
       
      P.S. If I wrote in incorrect topic then please move this thread to the right section, I will be grateful
    • By dannymozzer_
      Hi,
       
      I've been trying to install Mavericks 10.9, I know it's older now, but It's honestly the version I want to use, the specs of the PC are:
      Asus P8H61-MX USB3
      i3-3220
      8GB DDR3 Memory
      GTX 750 ti
      500GB HDD
       
      I've been following this guide: https://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-yosemite/
      But, after booting, this is the error screen I get, any guidance on what Kexts, SMBios settings, etc. I need? I can tell I'm probably missing something here.

      Thanks,
      Dan
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Install Clover in USB stick UEFI mode https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace Folder CLOVER INSTALLATION.zip   --Install System and boot with USB STICK! --Install Clover in UEFI mode and replace with my folder  Mavericks / Yosemite CLOVER Mavericks-Yosemite.zip El Capitan / Sierra CLOVER El Capitan-Sierra.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches! If you need DSDT edit... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generate in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609    --DSDT My DSDT DSDT.Asus Z97M-PLUS.zip   Patches  -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -EHCx -DARWIN -LPC -XHCI -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -HDMI -ALS0 -SHUTDOWN -LAN -PNLF --SSDT Generate your SSDT Power Management, use ssdtPRGen Piker-Alpha https://github.com/Piker-Alpha run in terminal curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh chmod +x ~/ssdtPRGen.sh sudo ~/ssdtPRGen.sh ssdtPRGen.command.zip
       
      --SSDT i74790K
      SSDT.i7 4790K.zip
       
      --IOREG
      iMac.ioreg.zip
       
      Clear NVRAM, Purge and Kextcache Olarila.command.zip   stock coolerand Rio 40º    --FakeSMC http://www.hwsensors.com/releases --Audio http://www.insanelymac.com/forum/topic/314406-voodoohda-289/ --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/304235-intelmausiethernetkext-for-intel-onboard-lan/   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
    • By zeg66
      Please help me with this 10.9.5 system. Motherboard: Gigabyte 965p-s3 rev3.3, gpu: Ati Radeon HD6450 (dvi/hdmi/vga). 
      Using any of the 3 ports on the 6450 (dvi, hdmi, vga), I see all the white letters on black background during boot but when they complete and it's time for the graphics to start I get a black screen and sometimes a restart after that. Using Clover 4411. Is there any way to get past this?
    • By zeg66
      Could you please help me enable the VGA port on the GT710 in 10.9.5 13F34 ? 
      It is currently booting fine through its HDMI port, web driver 334.0103f01 and config.plist arguments checked: Verbose (-v), npci=0x2000, dart=0, nvda_drv=1
      The nvidia GT710 works fine through its VGA port and web drivers on a friend's Mac Pro 3,1
      I must soon return this borrowed HDMI monitor, mine only has a VGA port so I'd appreciate your input.
×