Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
andrew mccormick

w520 cannot get audio to work

10 posts in this topic

Recommended Posts

Finally frustrated and ready to ask for help after about 5 days of trying to get this working.  I had audio on my headphone ports one day, but got greedy and tried a different version of voodoohda (unfortunately didn't back up settings before then) and have been back at nothing working for the last couple days.

 

System: Lenovo w520 with Conexant 20672

OS: iAtkos ML2 -- Mountain Lion 10.8.5

Bootloader: Chimera

Boot Kernel Flags: darkwake=0 -v PCIRootUID=1 dart=0

 

Error: Whenever I click on VoodooHDA prefpane I get "No VoodooHDA Devices Detected"

 

Steps:

- I have tried almost every version of VoodooHDA I can find.  The two main guides for the w520 (http://www.insanelymac.com/forum/topic/273621-guide-os-x-lion-on-thinkpad-w520/ and http://hackintosh-forum.de/wiki/index.php/Lenovo_ThinkPad_W520) both use voodooHDA 2.7.2) .  I have also used the DSDT associated with both of those post to no avail.

 

-also tried this voodooHDA (and the appleHDA associated with it) http://www.osx86.net/files/file/810-applehda-and-voodoohda-for-cx20588/

 

-also tried all the voodooHDA's in #####

 

-and this one: http://www.osx86.net/files/file/3713-voodoohda-with-working-mic-for-lenovo-u510/ (i'm almost 100% sure this is the one that worked before).

 

-and probably a few more that I don't remember where I got them

 

- I also have tried each with separate DSDTs  from here (http://www.insanelymac.com/forum/topic/273621-guide-os-x-lion-on-thinkpad-w520/ and http://hackintosh-forum.de/wiki/index.php/Lenovo_ThinkPad_W520) both use voodooHDA 2.7.2)

 

- I have added my device-vendor ID as PrimaryMatch and as the ClassMatch, just as the Classmatch (without primary match row), and leaving Classmatch as same while adding PrimaryMatch Row.  

 

-i have used various device ids (see screenshots below to see my devices) { 0x506e14f1, 0x0bea10de, 0x1c208086 <- this is the one that worked }

 

- I have added the HDEF section to my DSDT after trying it without.

 

- I have done every combination of everything above.  As I said, this has been a while of just working on the sound.  Everything else works great!  When the sound did work in my headphones that one time, it sounded great.  I just got greedy and wanted my speakers to work since a lot of others seem to have gotten it to work.  Each time I install a new version of voodoohda (either by the pkg file or KextWizard to install Kext) I rebuild the cahce, and restart.

 

-Attached are screen shots of my devices in OS X and Windows 7, also my current dsdt, my mesg.txt, current version of voodoohda.kext, current appleHdadisabler.kext, and my current info.plist from current voodoohda.kext.  

 

Any help would be great.  I can use my system fine without audio because I mainly program and write code, but it just feels weird not to hear the little dings and clicks.

thanks for any help!

dmesg.txt

post-1290175-0-14941200-1390862013_thumb.png

post-1290175-0-26274600-1390862014_thumb.jpg

dsdt.aml.zip

AppleHDADisabler.kext.zip

VoodooHDA.kext.zip

Share this post


Link to post
Share on other sites

Hi Andrew!

 

Which version of OSX are you running? (Mounain) Lion or Mavericks?

Is audio enabled via BIOS? (Or better: not disabled? ;-) )

Did you install VoodooHDA.kext in S/L/E or E/L?

 

Best regards

Share this post


Link to post
Share on other sites

Okay, imho that's causing the error/disfuncion of audio:

 

VoodooHDA 2.7.2 has only a 32bit driver for your sound card, but Mountain Lion is native 64bit without 32 kernel, so only 64bit kext will be loaded. Try latest VoodooHDA (and patch info.plist if needed (patching is descriped in the guide you linked)). And forget the arch=i386 boot flag - it won't work on ML or newer OSX.

 

Edit:

Maybe this will help: http://www.osx86.net/topic/12534-which-kext-to-use-for-1c20x8086-conexant-14f1-5069-dont-need-hdmi-sound/

Share this post


Link to post
Share on other sites

Thanks again for the quick reply. I've tried about every version of voodoohda I can find. I believe it was v 2.8.4 that worked (at least for the headphones) before specifically that I got from here:http://www.osx86.net/files/file/3713-voodoohda-with-working-mic-for-lenovo-u510/ . However I can't get it to work at all again. In fact as you can see from my current info.plist, I currently have 2.8.4 installed.

-where do you see me throwing the arch=i386 not flag? I don't see that in my chameleon.boot.plist .

Share this post


Link to post
Share on other sites

You have tried different methodes of audio enabling - did you always undo them if not working? (Interferrence of differnt methodes)

 

Nowhere - just wanted to say fallback to 32bit mode won't work ;-)

Share this post


Link to post
Share on other sites

something interfering is the only thing I can think of, I just don't know where or what is different than when I was changing before and got it to work (It took a bunch of trial and error to get it to half way work before).

 

Basically each time I would install the pkg file or if it was just a kext I would use Kext wizard to install the Kext.  I would then patch the info.plist file with my device-vendor id.  Then I would rebuild the cache using Kext Wizard.  I would go to system preferences and click on the VoodooHDA prefpane to see if it worked.  If it didn't work, I would restart.  If it still didn't work, I would try a different combination of the Classmatch and Primarymatch, each time rebuilding the cache and restarting.  If it still didn't work, then I would delete the kext by deleting it from S/L/E. I would then rebuild the cache, install the next version of VoodooHDA, and repeat the cycle over again.  Hence why it's taken my days of trial and error trying every combination I can think of.

Share this post


Link to post
Share on other sites

I don't know much about the DSDT, but I don't think so.  the only thing I've done to any of the DSDTs I've tried is add the HDEF section many of the tutorials say to add in

 Device (HDEF)
            {
                Name (_ADR, 0x001B0000)
                Method (_PRW, 0, NotSerialized)
                {
                    Return (Package (0x02)
                    {
                        0x0D, 
                        0x05
                    })
                }

                Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x06)
                        {
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }, 

                            "layout-id", 
                            Buffer (0x04)
                            {
                                0x1C, 0x00, 0x00, 0x00
                            }, 

                            "PinConfigurations", 
                            Buffer (Zero) {}
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }

Also attached is my current dsdt.aml

dsdt.aml.zip

Share this post


Link to post
Share on other sites

Well for the first time I have sound from speakers and headphones!!! 

Not sure if it matters but I noticed that some of the VoodooHDA packages install VoodooHdaSettingsLoader.app 1.2 .   So I removed that kext as well as the prefpane and voodoohda.kext.  rebuilt the cache, reset.  Installed the 2.8.4 package from here: http://www.osx86.net/files/file/1194-voodoohda-2-8-4-pkg-installer/ , added PrimaryMatch key. rebuilt cache and restarted.. and boom.

Microphone works as well.  Not sure about HDMI, but don't really care as I can always switch over to win7 if I need to output something to HDMI :)

 

The only thing I can imagine is that it was that settingsloader.app as I haven't noticed that or tried removing it in the past.  Sometimes it just takes talking it out to make you stop and think.  I just hate posting before I've exhausted everything I can think of.

 

Thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  
    • MAld0n, I can't post a new topic on post installation forum. is it on maintenance?
      Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up
      EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image
      https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have your (Mald0n) DSDT   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
       
    • somehow I can't post a topic using safari and Firefox on Mac. no box for inserting text, is this kind of maintenance?  
    • Hello Allan!   I do have ACPIBatteryManager.kext and if i use IntelBacklight then I get stuck on boot with an error along of the lines of "busy timeout, (60s), : 'PEG0'". I have tried to patch the DSDT but failed. If i understand right, ACPIBatteryManager.kext needs DSDT edits to work? same goes for IntelBacklight?   EDIT: I tried to edit my stock DSDT using MacIASL again and i applied the battery patch for Asus Q550LF from @RehabMan Repo! I also applied the AsusFNkey DSDT patch. Now the battery meter pops up when i unplug the laptop. If i plug the charger back in, then the battery meter stays but does not update to show that the charger has been plugged in. Ive attached the DSDT below.. DSDT.aml.zip


×