Jump to content

Moving SSD from PC to Notebook


7 posts in this topic

Recommended Posts



I have ssd with working macosx 10.8.4 running on my PC p67 and i7 2600k. The problem is that I sort of copy pasted files required to setup bootloader from one of the blogs on the web.


Now I moved the SSD to a notebook (temporarily) and of course mac wont boot. I was wondering whether


1) I am able to prepare bootloader on an USB stick which will boot mac on the laptop without having to change bootfiles on SSD so that when i plug it back into the PC it will boot as before


If yes then what are the minimum requirements for bootable USB stick so that mac run at least (not necessarily fully functional).


2) Is chameleon + plist + dsdt.aml enough to at least boot the OS?


My model is HP 8540w and unfortunately no one here so far had the same CPU as I do. My model runs on 740QM and Fx1800m graphics (graphics are common thou).


3) if I rip aml from 720QM, should verbose boot throw errors (panic?) or just hang or something else? Is there a chance it will boot at all?


Our laptops (8540w's) share the same mobo


4) Am I able to generate the dsdt file? Number of stuff inside it is huge and I dont know where to start if I would like to patch it to my needs



I'll be very thankful for answers on numbered questions and any additional comments that might help me get started with this

Link to comment
Share on other sites

If the DSDT from the desktop is still on there you need to boot with DSDT=none.


Besides an appropriate boot loader, the minimum requirement for booting OS X on any PC is Fakesmc.kext, but you already have that, otherwise the HDD wouldn't boot on the desktop either.


When swapping a drive like that you should boot with "ignore caches", -f ,and in safe mode -x (at least on first boot).


You didn't say what actually happens when you boot, you can see that if you boot with in verbose mode with -v


Since it's a laptop, model identifier will be wrong, you can try SMBIOSdefaults=y to ignore /Extra/smbios.plist and use Chameleon's default model identifier for your laptop.


Multiple flags can be combined: DSDT=none SMBIOSdefaults=y -f -v -x


Possibly UseKernelCache=n instead of -f, I'm not sure if it'll make any difference.


Anyway, whatever options you need to override from the boot prompt will depend on what your settings are in /Extra/org.chameleon.Boot.plist.

Link to comment
Share on other sites

Thanks. I did as you suggested.


Here's how my pen drive looks so far



This is DSDT editor (I extracted it @ windows OS and patched errors/warnings)



I ran flags DSDT=none SMBIOSdefaults=y -v UseKernelCache=n (as well as -f, not really a difference) GraphicsEnabler=No (that flag I did second time but result was the same)

and.. screen turns black.


This is last thing I was able to catch before screen went black (it happens very fast so there might have been something in between of what I caught and blackout)



Thanks :) 

Link to comment
Share on other sites

I don't get it. When I setup key/strings in plist file, they seem to be completly ignored.

In order for things like SMBIOSdefaults, DSDT, etc to be applied I have to write them every time in boot options and that's what I do.


Also the other strange thing is that if I wrote DSDT=none it boots and then turns black (but dsdt=none means - don't use DSDT?)


However if I use DSDT=/Extra/DSDT.aml or I don't specift DSDT at all, this is what I get



and from that moment it hangs, nothing happens after that.



Link to comment
Share on other sites

So I found that many people using 8540W with FX 1800M had problem with screen going black due to some issues with recognizing internal display. I found some topic on putting PEG3 before PEGP or addint NVEnabler.kext but neither of those solutions worked, screen remain black.


The thing with not reading DSDT.aml file correctly happened because chameleon was loading DSDT.aml from /Extra directory on hackintosh rather than from USB stick. I had to manually specify hd(0,2)/Extra/DSDT.aml in order to make it read the proper .aml file.

Link to comment
Share on other sites

That happens because you're using Chameleon to boot a drive that already has Chameleon installed. Configuration settings and files in /Extra on the hard drive take precence.


You should not need to use an USB stick, just pass the boot arguments to the bootloader that's already installed.


Try connecting an external display.

Link to comment
Share on other sites

True, I don't need the whole bootloader on the USB stick.


Nonetheless, the screen is still black.

Unfortunately I don't have any external display here, I'm out of home and that's also the reason why I moved SSD from PC to notebook


I tried to use those two solutions

and solution with EDID which i could not apply because I can't boot mac



Nothing works! This is so frustrating, there must be a way

Edited by iFIRE
removed TMAC links
Link to comment
Share on other sites


  • Create New...