Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
0n3

AMD Mavericks Easy install for people having issues bootinng to installer

5 posts in this topic

Recommended Posts

I have a AMD Phenom II x4 965 (black), and Asus Gforce 210 Silent, running on a Gigabyte GA-880GM-D2H (rev. 1.x), AMD880G Chipset. Running Mavericks 10.9.1

 

 

 

I tried everything to get mavericks to boot, but it would only boot to a white screen, sometimes the console spit out a bunch of "junk", but no kernel panic, that is until I came across this thread and kernel: http://www.osx86.net/files/file/3657-amd-fx-109-mavericks-kernel-nvidia-work/?st=40#comment_75955

 

 

 

I have full internet, working sound, full graphics acceleration and HD resolution, and I can run the chess app and VLC, handbrake etc. with no problems at all.

 

 

 

[Edit]

 

I have tested iMessage, works great, iCloud dose not gives communications errors. I will post my findings on Photoshop once I install it...

 

 

 

[Edit]

 

I have tested adobe Photoshop CC and it runs perfect...

 

FaceTime dose not work, gives error processing registration....

 

 

 

For anyone having issues with the installer as I did, do this:

 

 

 

 

 

You will need:

 

 

 

1) Freshly set up copy of Mavericks on VMware with AMD CPU

 

2) Carbon Copy Cloner

 

3) SATA to USB adapter or SATA Drive enclosure

 

4) Chameleon Wizard

 

5)mach_kernel : http://www.osx86.net/files/file/3657-amd-fx-109-mavericks-kernel-nvidia-work/

 

[Edit]

I have attached the kernel I used check the bottom of this Topic

 

Follow the following steps:

 

 

 

1) Mount the USB Adapter/Enclosure in VMWARE

 

 

 

2) Clone Mavericks to the USB HDD using Carbon Copy Cloner

 

 

 

3) Navigate to S/L/E remove all VMware kexts

 

 

 

4) Use Chameleon Wizard to install the bootleader to the usb drive

 

 

 

5) Navigate to /Extra on the USB drive and Right-click org.chameleon.Boot.plist select open with and choose other, navigate to were you saved chameleon wizard and click open, I have the following checked:

 

a)GUI

 

b)Timeout: 5

 

c)Legacy Logo

 

d) Kernel: mach_kernel

 

e) Use Kernel Cashe

 

f) ncpi=x3000 (if your system freezes at [PCI CONFIGURATION], disable this or use x2000)

 

g) SMBios.plist: /Extra/smbios.plist

 

h) Restart Fix

 

i) Graphics enabler=Yes

 

6) Navigate to you USB drive, and delete the current mach_kernel, replace with the attached mach_kernel (for NVidia users)

 

 

 

7) Reinstall the SATA drive back into its intended Computer.

 

 

 

8) Try to boot (this is were I had issues, I had to use google to get past them)

 

 

 

9) Once your booted to your desktop, install VoodooHDA for your sound, and try lnx2mac drivers for your Ethernet ( I found that using separate installers for voodoo and lnx2mac worked better then [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] on AMD Mavericks

 

 

 

10) Enjoy

 

 

 

This is my first MAC tutorial, please pardon my spelling

 

mach_rc7_10_9.zip

Share this post


Link to post
Share on other sites

how about usb problems .Can you edit DSDT..........

Share this post


Link to post
Share on other sites

I'm a hackintosh newbie, I know very little about DSDT, but I have no usb issues, if that helps....

Share this post


Link to post
Share on other sites

Successfully used Above Method to get Mavericks running on the following PC:

 

Mainboard: MSi 970A-G436

Chipset: AMD 970

CPU: AMD FX-6300 OC @ 4.5Ghz

16 GB GSKILL DDR3 Ripjaws ram

GPU 1:AMD Radeon HD7770 (working with full acceleration, native kexts)

GPU 2:AMD Radeon R7 250 (only works on minimal mode, no kexts found)

 

If anyone has any ideas how to get the Radeon R7 250 working it would be greatly apreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×