Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Extremely slow graphical performance (4930K / Ivy Bridge-E related?)

8 posts in this topic

Recommended Posts

Hello there!


I'm running an Ivy Bridge-E based setup that I just purchased, this is my 3rd Hackintosh build. Specs are as follows:


Motherboard: ASUS P97X9, latest BIOS 

CPU: Intel i7 4930K (not overclocked)

48GB DDR3-1333 RAM

Graphics: eVGA 770 GTX SC


I can get fully booted in several different ways. I changed out the mach_kernel to the Ivy Bridge-E patched one on an existing Hackintosh 10.9.1 installation. Boots fine. I can boot off of a 10.9.1 installation USB drive, using the flags "-v npci=0x2000 GraphicsEnabler=No cpus=1". Boots fine. I've even gone so far as to use the RampageDev DMG for my motherboard and install the recommended KEXTs, DSDT, etc. Boots fine.


However, the problem is that no matter which of those methods I use, once I'm booted, I'm greeted by incredibly sluggish UI performance. Here's a short video showing what I mean:




Basically anywhere there are animations, they run at around 1/4 FPS. Notice that the windows without opening animations open right up. I also haven't noticed any issues with processing time when I do things (e.g. I can copy files between hard drives at normal speed). It's just that the animated effects of window openings, dialog box popups, progress bars, moving windows around, etc. run incredibly slowly/jerky.


I tried removing the nVidia kexts, same thing happens. Tried booting into safe mode, same thing happens.  Tried swapping in a Radeon 6870 and had the exact same issue


I had this exact same graphics card working fine on my previous non-Ivy Bridge-E build. Really the only thing I've changed in this new build is the CPU, motherboard, and added more RAM. I'm really at a loss here. Hopefully there's just a simple thing I'm overlooking? Could this really be Ivy Bridge-E related?


Thanks in advance for any help anyone can offer, even if it's just to say "this is definitely a graphics card issue" or "this looks like something to do with the CPU" so I can concentrate my efforts in the right place.

Share this post

Link to post
Share on other sites

I also have the same problem. Everything else seems to be working fine and I have tried a number of things to get it working with no luck. Any help would be appreciated.


IOReg attached. 


Edit: apparently I can't upload an ioreg file


My hardware:

CPU: Intel Core i7-4930K 3.4GHz 6-Core Processor
CPU Cooler: Corsair H60 54.0 CFM Liquid CPU Cooler
Motherboard: Gigabyte GA-X79-UP4 ATX LGA2011 Motherboard
Memory: A-Data XPG V1.0 8GB (8 x 4GB) DDR3-1600 Memory
Storage: Samsung 840 Pro Series 512GB 2.5" Solid State Disk
Storage: Seagate Constellation ES.3 1TB 3.5" 7200RPM Internal Hard Drive
Video Card: Gigabyte GeForce GTX 760 4GB Video Card
Case: Corsair 600T Silver ATX Mid Tower Case
Power Supply: Corsair 760W 80+ Platinum Certified Fully-Modular ATX Power Supply
Optical Drive: Asus DRW-24B1ST/BLK/B/AS DVD/CD Writer

Share this post

Link to post
Share on other sites

Hi, I'm curious what mach_kernal you're using and what kexts are installed. I can't get mine to boot without using -f -v -x cpus=1. a couple of times I did get it to work with the kernalcache=yes and -v. My graphics were good, but I'm using nvidia kexts from 10.6.4,

Share this post

Link to post
Share on other sites

Here's my startup options:


<key>Kernel Flags</key>
<string>npci=0x2000 nvda_drv=1 -v</string>
<key>Legacy Logo</key>
<key>Graphics Mode</key>

kexts installed:

  • AppleIntelE1000e.kext
  • AppleACPIPlatform.kext
  • VoodooTSCSync.kext


I've installed the nVidia web driver as well. I am now able to get the system very responsive when I go into the BIOS before booting, but not saving anything, just exit and boot Mavericks normally and the system is performant. If I just let it boot normally, I get the slowness again.


I still have a problem with audio/video cutting out and stopping after a few seconds. Haven't dug into that problem yet.


Hope that helps


Share this post

Link to post
Share on other sites

Yes, it does


I've attached my kexts for my nvidia and sound. This may or may not work, but in the few times I got my first install attempt to boot regularly, the video seemed okay.


I never had any luck with the cuda drivers. I think on 10.6.4 whatever the current cuda drivers were at the time worked, but then there were other issues. In the end I found the ones I was using worked best.


These nVidia kexts I got a while back when I was doing the 10.6.4 install and they have been remarkable robust. I have used them through 10.8.4 (which is the build I'm using to post here) I added them using kexthelper to the vanilla kexts and that was it.


The Voodoo.kext I included is old as well. It works with 10.8.4 and shows all the outputs for the internal sound. However, since I never use the internal sound, I can't tell you if it actually cuts out or not.


Concerning your kexts. Could you attach them and send including the Fakesmc.kext you're using? I've been trying to get this build to work with my MSI x79ma-gd45, and I have a feeling it's the bios messing things up. Short of that, let me know where you got them.


Are you using a nullcpupowermanagement.kext as well?


Also, are you using a modded mach_kernal, or the regular one with Chameleon?


Also note I'm not using a DSDT or SSDT file for my builds which might affect how the kexts I've attached work.


Let me know if this helps.


Share this post

Link to post
Share on other sites

Do not use VoodooHDA for audio. 


Do not use the kexts he attached. 


Do not use SL drivers in any OS X version other then the version it was designed for.


Do not use a Modded kernel as there is native support for IVY B-E under 10.9.2


Do not post bad ideas. 


Read and become educated. Always the best method. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies