Jump to content
nouatzi

Mavericks on Asus G73JH

9 posts in this topic

Recommended Posts

Hi, I would like to know if someone successfully installed Mavericks on the laptop Asus G73JH, with everything working.

If it's the case, the way to.

Thanks

Share this post


Link to post
Share on other sites
Advertisement

drone4zone, your answer is as useless as t-i-t-s on a bull!

You are what is wrong with all Hackintosh communities! 

If you can't type a real answer then stfu!

 

 

nouatzi,  I used the MyHack usb installer maker( default install ) and it booted on my G73JH then installed 10.9 on an external HD.

I was working on an other Hackingtosh of mine so I don't know what the outcome will be on the laptop.   

 

You could start with MyHack.

 

I'll be installing 10.9 on the G73GH today. I'll keep you informed.

 

2014-01-14 @9:47PM - 10.9.0 is installed on my G73JH BUT - no WiFi, only 1400x1050 resolution, Keyboard works, No RJ45,  Sound with voodoo but it's not perfect. 

Share this post


Link to post
Share on other sites

NOYFB...FYI..been there  done  myHack......done [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]  as well ...tried various personalities with frame buffers "Nomasus" seemed to show 5800 series in sys profiler ,tried to use nullCpuPowerMangement kext and without, in order to get  sleep working,without any success .I get black screen at times and have to do a hard shut down via power key hold...I will ignore your comment about "stfu" since people do make mistakes.Dont be a rude Hater,it will get you nowhere,I stand corrected  for not  posting this info,It's not perfect but here it is

As far as sharing my install process it's  been a various choice using USB 8GB  stick,along with free app store Mavericks "download app file" make sure it's placed in Applications folder for [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to work ,use another mac, my hack works the easiest and smooth you have to add  Aty netkas 64 bit kext to get Ati5870m  working ,drag it into  extra folder before boot...Mutibeast was  another way to create  usb stick boot with "GraphicsEnabler=no" and -v to see if you boot has any issues

I have not really used Clover ,but heard some people have been successful,with use Ati rom and  graphics enabler no.

I read something about Asus remapped the pins in a backward way in their PCIe slot it's a MXM2.1b series I imagine,I have it working perfectly in ubuntu,and win 7,8 version  platforms display sleeps and awakes and changes resolution ...

so far this is what I have working  note that my G73JH series is the  "BestBuy" version which kinda sucks without the 1920x1080 led panel,has 1600x900 and an intel centrino clear wifi which is not compatible with any version  osX platform ,what I did was get a orig G73JH off ebay for $5 free shipping I lucked out  and added  AirPortAtheros40Kext and it  recognized airport perfectly...I don't have bluetooth   not with my version,have two Hard drives  one with  Mavericks and other windows 7,8,ubuntu Ultimate version.

audio has been interesting sofar voodoo 8.4 universal installer seemed to work but it's buggy with mic feedback you can fix it with  plist  edit 

volume fix=true and mic=true. I have  a kext that is patched with 269codec for this G73JH but haven't really tried it yet ,been focused on video issue mostly,but here is what I have

keyboard backlight working  patched dsdt

wifi airport

audio voodoo version 8.4 buggy but ok mic works

Trackpad with 3 finger gestures work awesome  with "Rehabman ps2 custom kext

Battery icon Hardware sensors GPU,Cpu thermal working  rehab man  Fakekext with built in plugins 

turbo boost works you have to boot into bios to set it  normal or turbo,maybe there is a  kext for the hot key have not really checked.

 

here you can get  kexts  and additional  tweaks to get you running  without Graphics sleep. I just set my  laptop to not sleep  screen saver works fine ,just don't let your display fade to sleep otherwise you have to hard shut down again ,thats where I'm at so far ,maybe  the Graphics is an easy fix I'm hoping .

 

here is link to kexts I used                    

 

http://www.filedropper.com/g73jh-kextpack

 

I included patch dsdt file for  backlight keys...also if it doesn't work for you, patch your own  easy just run  app MaciASL and apply,save your dsdt patch in document and  copy past txt 07Backlight. with your own,drag into  extras folder. you have to use  ctrl,Alt,+,-, key to enable ,they will adjust 3 stages low med high + -  while holding  ctrl and  Alt  along with +,- keys also patch HDAkext should work ,not sure about IO80211Family kext I used the AirPortAthrose40 kext to work just enable  in system preferences networks.If you need any info let me know .

cheers

Share this post


Link to post
Share on other sites

Here is where i'm  stuck I'm assuming this is  a "Clarksfield" type  based on  various reviews on this Laptop...

 

Clarksfield (microprocessor) - Wikipedia, the free encyclopedia

 

Intel's Sandy Bridge vs. Arrandale and Clarksfield: A Comparison | News & Opinion | PCMag.com

 

IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-F65AE981FFA204ED.plist

In all OS X systems up to and including Sandy Bridge, native power management was enabled by ACPI_SMC_PlatformPlugin.kext, a plugin in IOPlatformPluginFamily.kext. For Ivy Bridge processors, native power management is enabled with the X86PlatformPlugin.kext. HD3000 processors on a 7 Series motherboard should not use Ivy Bridge power management. 
 

I'm thinking a  DSDT from windows or Linux  may be the way  scratching  my head  here to get true value? which "ClarksField" needs to map "NONE(must use with Discrete graphics) ..to be continued I need a beer !

Share this post


Link to post
Share on other sites

It is Clarksfield.

 

Sandy Bridge came after so I guess ACPI_SMC_PlatformPlugin.kext in IOPlatformPluginFamily.kext is correct. 

But I fail to figure out what you are trying to achieve. wake from sleep? 

 

 

dron4zone, I think I will start a new thread for the Asus J73JH. I will be abel to update the main post with all the information we gather for 10.9.

I don't think nouatzi is active. I saw his post on tony#@$#@$. He said he got his up and running. 

Share this post


Link to post
Share on other sites

    yes,seems it wakes but the screen is white and distorted...maybe  ACPI_SMCPlatformPlugin.kext needs to be edited?


Sounds good ...I was about to go back to Snow Leopard LOL..I'm having issue now sounds tweaks choppy without  nullCpuPowerMangement.kext..I have a few kexts  from iAtkos ML2 I may try 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By zeg66
      Please help me with this 10.9.5 system. Motherboard: Gigabyte 965p-s3 rev3.3, gpu: Ati Radeon HD6450 (dvi/hdmi/vga). 
      Using any of the 3 ports on the 6450 (dvi, hdmi, vga), I see all the white letters on black background during boot but when they complete and it's time for the graphics to start I get a black screen and sometimes a restart after that. Using Clover 4411. Is there any way to get past this?
    • By zeg66
      Could you please help me enable the VGA port on the GT710 in 10.9.5 13F34 ? 
      It is currently booting fine through its HDMI port, web driver 334.0103f01 and config.plist arguments checked: Verbose (-v), npci=0x2000, dart=0, nvda_drv=1
      The nvidia GT710 works fine through its VGA port and web drivers on a friend's Mac Pro 3,1
      I must soon return this borrowed HDMI monitor, mine only has a VGA port so I'd appreciate your input.
    • By zeg66
      Have managed to boot into Finder without a usb but cannot see the outside world. Could you please help me to enable Marvell 80E8056 ethernet access on 10.9.5 13F34 ?
    • By Nemorosus
      Note: This computer works with every version of OS X since (virtually) Snow Leopard, to High Sierra (and newer I presume, except if Apple makes drastic changes). Depending on your hardware configuration, you may need to change some settings and experiment more.
      My configuration:
      CPU: Intel Core i5 3570 3.4GHz RAM: 8GB DDR3 GPU: NVIDIA Geforce GT210 1GB (connected via HDMI) What works, what doesn't?
      Works: Native power management with TB, USB 3.0*, Ethernet*, parallel ports (natively)... Doesn't work: Intel HD2500. If you have i7 or another CPU with HD4000, you may get it to work. The options in BIOS are there, it's just I hadn't had any luck with the HD2500 and couldn't enable it (tried various ways). Note: I don't know if native audio works, as I own an USB audio interface and I use it without any problems. I presume you'll be able to get audio with AppleHDA patches or in last resort VoodooHDA. Let me just say that this is a relatively compatible computer. The motherboard is very good, with the exception of the PSU - you are limited to set of GPUs. Before I had the GT210, I had GTX1050 which worked wonderfully with High Sierra (latest version). But for my purposes, I needed Mavericks and hence the GPU downgrade.
      BIOS settings
      SATA mode to AHCI Disable VT-d Disable integrated GPU (if you have HD2500) Enable Execute Disable Bit Installation Guide
      Create an USB with DiskMakerX Install Clover on it (no special settings needed) Insert FakeSMC.kext into kexts/Other folder When booting, select all the CPU patches (including XCPM) If you have NVIDIA GT210, you'll need to disable the integrated GPU and only select 'Inject NVIDIA' in Graphics settings in Clover Viola Additional Kexts
      Ethernet - AppleIntelE1000e.kext USB 3.0 - GenericUSBXHCI.kext Some more screenshots:




    • By zeg66
      Trying to install Mavericks on an Asus H170M-E D3 motherboard, Skylake I3-6100 cpu, Intel 530 graphics.
      Last message I see is "root device uud is" and a series of "+++" but then it just stops.
      Have prepared usb with createinstallmedia, added Clover 4413 and changed a few settings with Configurator.
      Any help is welcome.
×