Jump to content

AMD ML post-installation problems - need some help by someone with more experience.


13 posts in this topic

Recommended Posts

Hi lads. 


I am definitely new to 'making' the so called 'Hackintosh'. (Literally started yesterday, and only just finished the two tests so I could post start this topic.)



AMD Phenom II x3, Asus mobo, R6670 (currently disabled), 4Gb RAM, OSX10.8.3 Myhack, Bios on AHCI, GUID partition with proper filesystem, AMD Mountain Lion kernel files patched, installation completed, flashing underscore on boot. 




After not touching my PC for a couple of weeks, I decided to boot it back up and fiddle around with it for a bit. 

Freshly installed 7 x64, had everything up and running with a few tweaks here and there, perfect.

I bought the thing multiple years ago, and after upgrading the hardware a few times of the past years, it still manages to crank out pretty serious performance. 

But yeah, I wanted more. So I looked into Vmware/Parralels with OSX. Turned out it was possible on an AMD machine, but only with the right kernel files. So I tried, to no avail. 


Specs (from a dusty memory of last night, just got to class but I can't let this go), AMD Phenom II x3 (Triple core, was free).


Asus Mobo, no clue which model, AM3 socket I believe, 128MB onboard Nvidia {censored} graphics.


MSI AMD R6670 (Took it out, figured that the graphics were not supported by the installation, only to just read that I could have deleted a file from the installer). 


4Gb of RAM (max this mobo will take).


So, after creating a bootable OSX 10.8.3 usb stick using MyHack, and dusting off an old hard drive, I decided to start the installation proces. I downloaded the latest AMD ML Kernel file. BIOS S-ata settings have been set to AHCI mode.

I managed to figure out that I needed to boot with npci=x3000 using -v -x commands at the Chameleon bootlauncher, and managed to get into the installation after taking the graphics card (r6670) out. 

After formatting the drive to OSX Journaled with a GUID partition, the installation actually followed trough and finished.

And of course, after going trough all that, it would not boot. 

I got the pretty blinking cursor. 


So, naturally, I used our best friend on the web, and figured out that I needed to replace the 'mach_kernel' file that was installed with the base 10.8.3 by the file that I had on my usb stick. Did that. I also checked the partitions with Fdisk, and even though it only gave me 'unknown' results by using 'P' on the selected disk, after doing a ListDisk, it showed me that OSX was installed on Disk1P2. 

So I set f to 2, and rebooted. 


Still no cigar.


I would appreciate some input by someone more experienced.




Link to comment
Share on other sites

If you can boot into Chameleon, try to use these flags: "GraphicsEnabler=No -v -x -f" and see the error code (the very very last line displayed and delays the boot for a really long time).


Once you've got the error code, try to search more about it by using "our best friend on the web".

Ah yes I forgot. Mountain Lion isn't fully compatible with AMD-based Hackintoshes. The most stable one is Lion but with no distros. Install it using myHack. If you're installing Snow Leopard, use a distro.

Link to comment
Share on other sites

Alright, when I got home I decided to fiddle around with the installation some more.

I managed to boot to the drive using '-v npci=x3000, and everything was well.


But then I tried using the unified beast, to no avail. The 5.5.5 version does not go past 'preparing installation'.

I then downloaded an older version (5.0.1 to be exact), that did manage to run, but inevitably bricked the system causing kernel panics.

Currently re-installing OSX for the 5th time, and leaving it that way I guess. 


GPU, CPU and dual screen set-up work, Ethernet/Sound do not. 


Any ideas on how to fix the ethernet/sound cards? I tried using Kext-Utility, but using that with the downloaded kekx's did not work either. 

Link to comment
Share on other sites

Mountain Lion and Mavericks both work on AMD machines now. I am currently uploading a quick video on how to prepare Mavericks for install on AMD. Will link you to it and you can try that. Once you have it installed and the kerenl replaced I can help you sort out the other issues :)


Video will be up in an hour or so...

Link to comment
Share on other sites

@Shanee, Cheers man. I had it running, but I had no Multi animal ( ;) ) support, the graphics were all glitchy, I had no sound and no ethernet :/

Currently working on Lion, but it tells me that my device in slot 1 (R6670) is not functioning. Sigh.

Link to comment
Share on other sites

I know you don't mate, but just letting you know what I am working with as a "noob".

Yeah I can get Lion booted with either -x or GraphicsEnabler=No, but even with the correct file for the ati6000 series it does not register it. 

It did register on ML though. 


Shall I go ahead and grab the Mavericks DMG and formatting my Hackintosh again?

Link to comment
Share on other sites


  • Create New...