Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


MacBook Pro has intermittent random crashes after hardware upgrades...

2 posts in this topic

Recommended Posts

Any suggestions?

I have just upgraded my MacBook Pro: installed 8GB memory (4GBx2 is max RAM for this MacBook Pro) and a new 1TB internal hard drive. It took me a day to install Mac OS X on the new internal drive, restore the Time Machine backup and check things out. The 4GB RAM was adequate for my normal use, but 8GB is very nice to have, and I need it for a special QA project, which requires me to run Windows on this Mac. The new 1TB hard drive is just over half full now, and 7200 RPM with 16GB cache vs. 5400 RPM with 8GB cache seems peppier too. 

However, there may now be an intermittent problem. My Mac had not crashed in more than one year, and I often run it for a few weeks between rebooting. For now, I cannot trust the Mac, and I am saving my work every 5 or 10 minutes. 


Since installing the new hard drive and new DRAM, it has crashed twice in two days. One "crash" was just a hang. The other "crash" caused a very strange display on the external monitor. Rebooting took longer than usual, maybe 3 minutes vs. 1 minute, after each "crash."  


Here is the screen shot after crash #1 (hang):



So, I ran the stand-alone (single user mode) memory test (memtest) overnight (5 passes takes about 10 hours with 8GB) and it did not report any errors. I have 12 more days to return the memory or exchange it at Fry's Electronics locally.   If it crashes again within a few days I will take the new DRAM back and try another brand.  
My MacBook Pro (mid-2009, 15", ) is now running OS X 10.6.8 (Snow Leopard) and want to upgrade to Mavericks (10.9) as soon as the hardware is solid for at least a few days. 
Also planning to install VMWare and Windows 7 for a special project as soon as the hardware is stable. 

For now, I plan to open the case, re-seat the RAM and run MEMTEST every night in standalone (single-user) mode.

Any other suggestions?  How to troubleshoot this and find out what is causing rare, random, intermittent crashes?

Hardware Overview:


  Model Name: MacBook Pro "Mid-2009" 

  Model Identifier: MacBookPro5,4

  Processor Name: Intel Core 2 Duo

  Processor Speed: 2.53 GHz

  Number Of Processors: 1

  Total Number Of Cores: 2

  L2 Cache: 3 MB

  Memory: 8 GB

  Bus Speed: 1.07 GHz

  Boot ROM Version: MBP53.00AC.B03

  SMC Version (system): 1.49f2

  Serial Number (system): ........7XJ


New Internal Hard Drive:

HGST HTS721010A9E630:


  Capacity: 1 TB (1,000,204,886,016 bytes)

  Model: HGST HTS721010A9E630                    

  Revision: JB0OA3B0




Corsair 8GB (2 x 4GB) 1066MHz DDR3,  204-Pin SO-DIMM Laptop Memory,   Model # CM3X8GSDKIT1066,   Frys # 6391441. 


Share this post

Link to post
Share on other sites



Returned the Corsair RAM. (It was in an open box when I bought it, often not a good thing.)


I bought PNY brand 8 GB kit (4GB x 2) because it was the only UNOPENED one that was in stock locally. Ran MEMTEST overnight, in single-user mode. A-OKAY.


During the next few days, the MacBook Pro crashed or froze several times, randomly. So, I ran MEMTEST in single user mode overnight, three passes, and it failed on pass 3.


Returned the PNY brand and ordered online from Crucial. They offer a 45 day refund and lifetime exchange, which is much better than any local store offered. Arrived 2 days after ordering.


Crucial RAM = A-Okay!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ruki250
      Since I installed High Sierra, the system hangs for about 5 seconds. This problem drive me crazy! I can't understand how fix it. How to solve it?
      Thanks in advance.
    • By Lord Kamina
      Hello there everyone. I recently put together a CL hackintosh for a somebody else and it mostly works fine; however, he's been having a problem that I (so far) haven't been able to replicate. He sometimes gets odd beachballs that end up freezing the computer into needing a cold shutdown and boot; which usually in turn freeze halfway through the boot process only for a reboot to work.
      Recently he mentioned this happened after several hours of sleep (left the computer sleeping during the night), so I'll try reproducing it later.
      However, I'm trying to figure out what the actual problem might be. I've got a theory: Wake-up issues with the NVME controller. Why? I've been experiencing similar issues on my real MBP (2011) because the secondary HD ribbon cable has been coming loose. Of course, since it's just a secondary drive, it's a large inconvenience but it doesn't completely shut the computer down. It would certainly be different if this was happening with the primary drive, though.
      What do people think about this? It's the first time I've built a hackintosh with modern hardware (my own is Ivy Bridge) and I'd never tried NVME before, so there's been plenty of trial and error involved in this build.
      CPU: i7-8700
      MB: Gigabyte Z370-HD3P
      RAM: 32 GB DDR4
      Video: Asus RX580
      Drives: Samsung 940 EVO, 2x 1TB HDDs.
      Wifi/BT: BCM94331
      Other than this issue, pretty much everything seems to be working fine on 10.13.2 (with the exception of the CPU saying Unknown on "About this Mac" but I guess that's cosmetic and expected)
    • By osidovich
      My system specs:

      GA-H55M-USB3 rev. 1.0 | i5 760 | Sapphire Radeon R7 240

      Motherboard is NOT UEFI.

      Actually I've installed Yosemite 10.10.5 on a SATA HDD (NO SSD) without major issues. SATA controller is an Intel 5 series in AHCI mode.

      I'm trying to update to High Sierra 10.13.2, downloaded from AppStore.

      When I boot from USB pendrive (using Clover r4334, config.plist attached), and select macOS installation (installation files resides in Yosemite HDD), installation fails with those errors:

      HID: shim legacy 2

      USB pendrive is inserted in a USB2.0 port. I've tried to insert it in all available USB ports but error is still present.

      Kexts used (all in EFI/CLOVER/kexts/Other):

      AppleALC.kext (used in Yosemite to have working audio with ALC889)
      GenericUSBXHCI.kext (for USB3.0, NEC/Renesas chip)
      Lilu.kext (dependency of AppleALC)
      RealtekRTL8111.kext (Ethernet)
      VoodooPS2Controller.kext (mouse)

      Downloaded from Rehabman bitbucket repositories, latest version where applicable or from author's repository.

      Any clues?

    • By Sylv3on
      as the title indicates, i'm having a lot of trouble getting high sierra working on my pc
      i created a 10.13 installer usb, booted into its installer through clover installed and even problemlessly transferred my files from my 10.12 install over to 10.13, but yet i can't boot into it
      in the attached image you can see where precisely it locks up (it might be important to note that DSMOS never arrives during the boot sequence (or at least the part of the boot sequence that actually happens before it does locks up))
      one thing i find weird is the fact that my 10.12 install (which is on another partition of the same drive that 10.13 is installed to) still boots with functioning sound despite me having completely removed applealc.kext from my clover install
      my config.plist is here: https://drive.google.com/uc?id=1RjfaLZ9zqT-N12kZXbX26xvC0QzMSBSZ(putting it on google drive because this website apparently doesnt want me to upload config.plist files, god knows why)
      i'm running clover 4297
      my specs:
      intel core i7 3770
      gigabyte geforce gtx 760
      16gb ram
      256gb sandisk ssd
      2tb seagate sshd
      750gb western digital
      1tb western digital
      i'm pretty much at my wit's end here so i'd be glad if anyone knew what the hell is going on