Jump to content
3 posts in this topic

Recommended Posts

Hi, guys, I hope I did not miss already posted topic about my notebook, however this is my first time when I am facing such problem and have tried everything I can so far but with no luck. The problem is that the notebook starts loading normally with flags: -v -cpus=1 and I can see that the CPU is correctly recognized as Intel i3 2200m but after the initial kext loading instead of seeing an installation screen or kernel panic window all I can get is a black screen for a few minutes after what the notebook restarts and everything starts all over again. Firstly I have decided that the Intel video (only) built in is not sufficient to run ML, so I went down a bit trying to boot and install the iAtkos s3 v2 (Snow Leopard). As per the compatibility charts in Internet it should boot, but all I get is exactly the same issue - black screen followed by a reboot. I have tried to go to an even earlier version with iDeneb but got exactly the same. So far the notebook is perfectly working with any other OS (Windows, Linux, BSD etc.) but cannot find a way to troubleshoot the issue with Mac OS X (any versions). I could have debuged if I had it installed however I am not aware can I do so during the initial installation booting. Out of curiosity, I have even tried to download an original Mavericks app directly from the AppStore however that did not work too. Probably it is important to mention, that I have tried with original Mac OS X versions I have legally purchased in time using a usb stick with chameleon to boot on my HP but no moving forward is possible.

I tried digging into the BIOS hoping to find some options to change and make things work, however there is technically nothing to set except the boot order and loading to default BIOS. So there I hit the bottom too and I would love if anybody of you can list some thoughts or ideas. So far I am thinking that there might be an incompatibility with the HDD and/or the DVD burner (happened to me before on another machine where the problem was solved straight after replacing the hdd, however at that time I had an error about the boot...) . In order to be precise and help myself by providing the technical information of the machine, here is all the tech. specs I could get:

CPU: Intel Core i3 i3-330M / 2.13 GHz
RAM: 4.0 GB ( 2 x 2 GB ) DDR3
HDD: Serial ATA-300 500GB 7200RPM
Optical Drive: DVD±RW (±R DL) / DVD-RAM LightScribe Technology
Display: 14.1' LED backlight - 1280x800 (WXGA)
Graphics Processor: Intel HD Graphics (Total Available Graphics Memory 1696.0 MB)
Wireless: 802.11b/g/n WLAN (I think it is Atheros xxx)

Well if there is anything else that is needed to point out some directions, please let me know, I will do my best to provide all and thanks really very much to any advice or even shared thoughts about the problem. If you happen to know how to debug the initial bootup this might also be a good idea as I am pretty sure that the specs are just fine for a Snow Leopard or even ML , but it is just to bring it to a booting first and then to start digging for not working (eventually) hardware.


This is my first posted question about troubleshooting and the reason to post is that I got this nice notebook as a gift and was happy to think that i3 CPU most likely would go well with any OS X version but so far no progress. The search did not show any results to my particular problem, so please excuse me if anything have been written about this issue but was not found in my search results.



Btw, I have forgot to mention that I cannot find any information about the Graphics processor type so my guess is that it is either Intel HD2000 or Intel HD3000 but I would put my dice in 2000 version as the notebook is about 3-4 years old.

Link to comment
Share on other sites

One more detail to add are the boot parameters I have tried so far with no luck :


-v , -f , cpus=1, busratio=20, npci=0x2000/3000 (depending on OS X Version), graphixenabler=0/1 , pcirootuid=0/1


All the parameters were tested as a single option or a dozen of combinations between them. Probably I am missing something, however what would that be... I remember there was a Mountain Lion version of Mac OS X for weaker pcs (I cannot remember the exact project name) so I am going to look for it and test that too, however once again, I doubt that an Intel i3 pc would be weak for Leopard/SL as well as ML.

Link to comment
Share on other sites

Some more research lead me to the conclusion that I can run just fine SL/M/ML/Mavericks on my notebook as far as I manage to trick the installation to load and fire up the display with Intel HD Graphics (not 2000/3000/4500) that is build in i330m. The problem is that so far I have discovered poeple having problems with Intel HD Graphics but it was only with lack of resolution and/or QE/Cl but not during the initial boot, so I guess I will have to use the Ubuntu method of getting my video card information, compiling a patched Video version and start from there. Now this is something that I have never done, so any ideas or shared thoughts would help a bit...

Link to comment
Share on other sites


  • Create New...