Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
data14

Mavericks on Lenovo B570

4 posts in this topic

Recommended Posts

I just installed Mavericks on Lenovo B570 over Mountain Lion. I will mention a few quick steps:

  1. I used this link: http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks to make a bootable USB. I formated the USB as master boot record instead of GUID.
  2. Used FakeSMC from here: https://code.google.com/p/os-x-fake-smc-kozlek/downloads/list.
  3. After booting to Mavericks. patched AppleICPM using this link: http://olarila.com/forum/viewtopic.php?f=9&t=1003 and removed Nullcpm.
  4. Installed Voodoops2 from this link : https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller. You have to use this for the keyboard and trackpad to work
  5. Installed AppleHDA and DSDT from this link: http://www.insanelymac.com/forum/topic/269586-lenovo-b570/
  6. My CPU is i3 2350, so I used SSDT for this CPU in extra folder.

Everything seems to work and none of my personal folders were touched.

 

I am triple booting, windows 7, windows 8 and Mavericks on a MBR partitioned hard drive.

 

Credit goes to rockinron_1, Rehabman, macinsane, Cassio and everyone else in the community. 

Share this post


Link to post
Share on other sites

Do you have WLAN-support?

I've got a AtherosWifiInjector.kext but if I install it, the computer doesnt boot until I remove the dsdt or the atheroskext.

But if I remove the dsdt, I have no audio but WLAN (if the atheros kext is installed).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×