Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Asus P5Q Pro-Intel Q9550 - Apple Bluetooth module preventing sleep

4 posts in this topic

Recommended Posts

Hi all, got another problem that i can't seem to resolve myself. About a week ago i bought an actual Apple Bluetooth card from a MacBook Pro. I hooked it up to my hackintosh and it worked but my Apple wireless keyboard was barely working (only basic functions, no FN functions) which i solved by using the IOBluetoothFamily.kext from 10.8.5 (kextversion 4.17) and i suddenly had a fully working BT keyboard. Even in the BIOS and bootloader. So far so good.


Eventually i wanted to go do something else and put the hackintosh to sleep, but it didn't want to. Apparently the BT module is keeping the hackintosh awake "by being disconnected"...

06/11/13 02:36:18,000 kernel[0]: Wake reason: GBEC USB3 USB6 USBE
06/11/13 02:36:18,000 kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
06/11/13 02:36:18,000 kernel[0]: SMC::setPowerState ERROR: smcPublishSleepCause failed (kSMCKeyNotFound)
06/11/13 02:36:18,000 kernel[0]: USB (EHCI):Port 5 on bus 0xfa connected or disconnected: portSC(0x101803)
06/11/13 02:36:18,000 kernel[0]: The USB device BRCM2046 Hub (Port 1 of Hub at 0x5a000000) may have caused a wake by being disconnected
06/11/13 02:36:18,000 kernel[0]: **** [IOBluetoothHostControllerUSBTransport][SuspendDevice] -- Resume -- Error -- GetDeviceInformation() returned 0xE00002C0 (kIOReturnNoDevice) ****

Note: this is without a dsdt.aml, with my dsdt.aml in place it looks slightly different as the GBEC en USBE aren't listed as wake-reasons and the USB (EHCI) line is missing as well.


From what i can gather the BT controller (BRCM2046) is somehow waking up my hackintosh from its sleep. I've tried a number of things so far:

  • Booted into Mountain Lion - same thing
  • Removed dsdt.aml - no change
  • Replaced the Mountain Lion IOBluetoothFamily.kext with the original Mavericks version (4.20) - no change, but extended keyboard and trackpad functions are disabled and Mavericks says "Bluetooth not available"
  • Used 3.3v line from PCI-E card initially, switched to 3.3v generated from same USB port that i connect the datalines to - no change
  • Fixed permissions - nothing to fix / no change
  • Fixed disk - nothing to fix / no change

Is there anything i can try to fix this problem? I really want this thing to sleep!


Thanks in advance.



Asus P5Q Pro w/ Intel Q9550

NVidia 9800GTX


Chameleon R2266


Attached are my current dsdt.aml, org.chameleon.Boot.plist and SMBios.plist




Share this post

Link to post
Share on other sites

Solved it. For anyone coming across this in need of an actual answer:


The Asus P5Q boards allow you to choose between 5V and 5VSB as powersupply on your USB ports. There are two jumpers near the bottom of the board immediately to the left of the IEEE and USB headers. By default those are set on 5V. That means that the power will ALWAYS drop from the USB as soon as it enters S3 sleep. And exactly that is why the BT module panics and sends a wake signal. After switching over to 5VSB the USB headers remained powered even in S3 sleepmode. It also means that you can use the keyboard, trackpad or magic mouse to wake up the system.


Btw, the USB ports on the left of the motherboard (rear of the case) have similar jumpers near them. IIRC those are both set to 5VSB by default. Hope this helps someone in the future.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.