Jump to content

Still waiting for root device


14 posts in this topic

Recommended Posts

I have just installed Mavericks with My Hack and generic Extra & Extensions. At the boot from the disk I got "Still waiting for root device", even with AHCIEXTENDEDINJECTOR.KEXT ( which I have added with the terminal of the mavericks installation And i have also repaired permissions). The AHCIEXTENDEDINJECTOR.kext worked perfectly with lion, (Without it I have had the same error, still waiting).

I have no AHCI mode on BIOS, only ATA And RAID, And my PC is the Dell on sign.

Why the kext worked with Lion and not with Mavericks? How can I solve this problem?

Link to comment
Share on other sites

  • 2 weeks later...

It works even without -f. Don't know why. Thanks!

Do these kext I placed to solve still waiting for root device problem create some problems like kernel panics or instability in the system?


Do you advice me try to remove some of these? I think that only 1 kext solved the problem, and so I need only 1 of them.
Link to comment
Share on other sites


  • Create New...