Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


N00b questions - Installing 10.5.6 retail CD on VirtualBox

9 posts in this topic

Recommended Posts

Hi all,


So I registered on the forums mainly (for now :P) to ask about installing an older version of OSX on a virtual machine. Here is what I have so far (running in Win7 x64 Home Premium on an Intel i3 (Laptop is the Acer Aspire 5750 if more is needed):


Mac OS X Install DVD (version 10.5.6)

Virtualbox (v4.2.18)


From what I have fathomed, I will probably need some kind of bootable GUI frontend loader to run before the installation of the CD, however I have been unable to find one for 10.5.6 in my travels (have found something on 10.5.1 but it then jumps to 10.6, which I tried and doesnt work - also, had a search on here, but is quite limiting as whenever I try to search for 10.5.6 specifically, the search strips out the "."'s which is no use whatsoever!).


Have made sure all settings are correct in VBox (watched a few youtube videos of people setting up OSX versions so know about knocking off things like EFI and one video suggested setting everything as IDE (not sure why as have no sound, but there cant be any harm in it!)


Also, many seem to recommend ripping the Retail DVD to ISO. Could do that, but is it necessary?


If you could wrap me up in cotton wool with your answers, it would be appreciated, given I have little to no knowledge of Macs or Hackintosh processes (this is my first attempt at installing anything other than Windows or Linux to a VM or PC) :D


Main reason I need it is to access some PowerPC applications that contain files that I need to access (for now just that anyway) but will be good to learn some of the processes behind it as well for future... always good to learn new things!


Cheers in advance



Share this post

Link to post
Share on other sites

As I can see here, Mac OS X 10.5 supports both PowerPC- & Intel-based hardware. These (multiarch) versions have used the "fat binaries" with apps compiled for both PPC and Intel platform.

I'm telling this to outline that PPC-only app can't be started on an Intel platform. But if you have an app with "fat binary" aren't you able to run it on a modern version of OS X?


If you really need to run Mac OS X on a virtual PPC, VirtualBox (and VMWare too) can't help you. These virtualization solutions are able to emulate only host CPU.

I know that QEMU can emulate (almost) everything (but slower), but I hope VirtualBox is actually enough for you :)

Share this post

Link to post
Share on other sites

Well whenever I try to run one of these PPC apps on OSX 10.8.5, it says "Power PC Applications are no longer supported" and does not open it.

The annoying thing is, the PPC apps I need contain Printer drivers and Pantones to install on the Mac. Nothing more, nothing less. I cant find the drivers anywhere else on the net and I even tried bodging a driver in there, but it turns out I need a special driver for this one printer as it has extra features and the regular driver cannot use them and crashes when accessed. The Pantones I cant access without paying for them again (and they cost a bomb from what I hear!).

It's the one thing I dont understand about macs. Surely there must be some logical way to spoof it within a modern OSX (a-la WINE/Linux) but from what I have seen, that isnt possible, so I came down the virtualisation route (and plus that way I thought I could try OSX out a bit more so it saves me time in the long run when working on them).

Will just have to try and bodge some other way by the sounds of things though!

Share this post

Link to post
Share on other sites

Yeah had read up a bit on this and is what I was hoping would work within my virtual machine to run the PPC apps.


I managed to get a bit further with my installation of this on VirtualBox. I got myself a copy of iPC off t'interwebs (seeing as it seems to be the almost idiot-proof installation from everything I have seen and plus it is the same OSX version as I have the retail CD for). It got as far as selecting my hard drive, at which point it couldnt find any. I created 4 different types of hard drive and added an old XP virtual drive as a 5th. Formatted them in VBox as follows:

Default .vbi from VirtualBox - no modification

Old XP Virtual Drive with XP installed on it

.vbi, opened in XP, formatted with NTFS partition

.vbi, opened in XP, formatted with FAT32 partition

.hdd - no modification

None of these were recognised by the installer. :-/ (still, its further than I got with just my retail CD and whatever loaders I could find, and given me fresh hope it may work!)

Any ideas? (if a -v installation is required for any errors, let me know and I will run it and get it up here :))

Share this post

Link to post
Share on other sites

Mac OS X installer requires HSF+ formatted drive. You should create a virtual HDD (unpartitioned, unformatted; VDI or VMDK formats are both ok, any will do) and start installation. In the installer you can start the DiskUtil (you'll find it in the menu at the top of the screen) and format the HDD with one HFS+ (Journaled) partition, set partition table type to GPT/GUID (default?). After that the installer will show the disk & you can continue!


BTW, I was able to install OS X 10.9 Mavericks in the VirtualBox without any single one modification in the OS X. It seems to be not necessary to use Hackintosh.

Share this post

Link to post
Share on other sites

Ahh. Because my laptop screen isnt very tall,ive been cutting off the top bit of the Vbox screen so missed that entirely. Thanks!

Share this post

Link to post
Share on other sites

OK, nearly there. I'm installed, but when restarting I just get the silver Apple logo screen with a spinny whirlygig on it and it goes no further. Will test some other options and see if that helps

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.