Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
peppeuz

Help for ATI 4570 QE/CI

40 posts in this topic

Recommended Posts

Hi everyone, I'm on my first experience with a Mac OSX installation (Mountain Lion 10.8.5): I've made almost everything working on my Acer Apspire 5738G but i want some more from my ATI Radeon HD 4570.
I used some kext I found on a tutorial and a modified version of Chameleon (compiled by some guy named Peregrine, I guess). Now it is kinda recognized, but I think QE/CI is not completely working. Launchpad is totally unusable, new tab in Safari slows down the entire system and VLC doesn't play video due to Quartz Extreme absence.
In this pic there are some info about my video card:
http://imgbin.org/index.php?page=image&id=15452
(as you may see, it is recognized as a 4600, although it's actually a 4570)

By the way, I finally managed to make a triple boot working, so unless it's really necessary I would prefer not to modify anything about the bootloader (I tried Clover once, but it gave me so many troubles!) 

 

Of course I checked this topic, but  I didn't understand very much. What should be my first step? 
Thanks in advance to whoever will help me with this!

 

Share this post


Link to post
Share on other sites
Advertisement

Ok. Here is your Vbios.

Last login: Wed Oct 23 18:47:09 on console
imac-admin:~ admin$ /Users/admin/Downloads/radeon_bios_decode < /Users/admin/Downloads/vgabios.dmp 
ATOM BIOS Rom: 
	SubsystemVendorID: 0x1025 SubsystemID: 0x0205
	IOBaseAddress: 0x2000
	Filename: BR33359D.bin
	BIOS Bootup Message: 
Acer_JV50_MV_M92M2_XT_DDR3 M92 DDR3 64bit 680e/800m                         

PCI ID: 1002:9553
Connector at index 0
	Type [@offset 45840]: LVDS (7)
	Encoder [@offset 45844]: INTERNAL_UNIPHY2 (0x21)
	i2cid [@offset 45902]: 0x96, OSX senseid: 0x7
Connector at index 1
	Type [@offset 45850]: VGA (1)
	Encoder [@offset 45854]: INTERNAL_KLDSCP_DAC1 (0x15)
	i2cid [@offset 45925]: 0x90, OSX senseid: 0x1
Connector at index 2
	Type [@offset 45860]: HDMI-A (11)
	Encoder [@offset 45864]: INTERNAL_UNIPHY (0x1e)
	i2cid [@offset 45948]: 0x91, OSX senseid: 0x2
imac-admin:~ admin$ 
imac-admin:~ admin$ /Users/admin/Downloads/redsock_bios_decoder < /Users/admin/Downloads/vgabios.dmp 
BR33359D.bin:

Acer_JV50_MV_M92M2_XT_DDR3 M92 DDR3 64bit 680e/800m                         

Subsystem Vendor ID: 1025
       Subsystem ID: 205
Object Header Structure Size: 217
Connector Object Table Offset: 34
Router Object Table Offset: 0
Encoder Object Table Offset: 99
Display Path Table Offset: 12
Connector Object Id [14] which is [LVDS]
	encoder obj id [0x21] which is [INTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false
Connector Object Id [5] which is [VGA]
	encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false
Connector Object Id [12] which is [HDMI_TYPE_A]
	encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
imac-admin:~ admin$ 

1) Add your dev-id as it is described here http://www.insanelymac.com/forum/topic/291276-help-ati-mobility-radeon-hd-4570-doesnt-work/?p=1939688

2) Find shrike F-buffer by hexedit

02  00  00  00  40  00  00  00  09  01  00  00  02  01  00  03
02  00  00  00  00  01  00  00  09  01  00  00  20  01  02  02
00  04  00  00  04  03  00  00  00  01  00  00  10  00  01  01

 

3) replace it by this framebuffer

02000000 40000000 0900 0000 12 04 00 07 (LVDS)
10000000 10000000 0000 0000 00 10 01 01 (VGA)
00080000 04020000 0000 0000 10 00 02 02 (HDMI)

4) lanch kext utility

5) add these keys to org.Chameleon.boot.plist in case you use Chameleon.

	<key>AtiConfig</key>
	<string>Shrike</string>
	<key>AtiPorts</key>
	<string>3</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string> 

6) reboot. PS if you get black/white screen it means we approach to a success. If you got it, just type 

GraphicsEnabler=No to boot your system. Tell me about it if it really happens and I'll give you next indications.

Share this post


Link to post
Share on other sites

I don't have any AMD4600Controller.kext, should I work on ATI4600Controller.kext or do something else?

EDIT: Ok, I find the 
shrike F-buffer in the ATI4600Controller so I guess it's it. I've already replaced with the numbers you gave me.
But now I can't find where my dev-id is...

Share this post


Link to post
Share on other sites

My IOPCIMatch is like this in Info.plist:

<key>IOPCIMatch</key>
<string>0x95531002 0x94901002</string>

Is it ok? I've modified the AMD4600Controller file and rebooted but nothing changed, I'm fixing permission with Kext Wizard right now.

Share this post


Link to post
Share on other sites

Yes, GraphicsEnabler is on. I'm going to reboot in some sec (Kext Wizard is finishing to fix), I'll let you know.

Apparently nothing changed. I updated my kext and plist.info to let you check if I made something wrong (if you can, of course!)
https://drive.google.com/folderview?id=0B8cVbXMLELqqU0M0bXlKXzE4R00&usp=sharing

If it doesn't work, might it depend on other video-related kext I installed before?


News! I updated to latest chameleon version and trying to boot now I get this. Is something like that were you talking about? What should I do now?


Booting with -v and normally:

post-1229587-13825486774881_thumb.jpg

post-1229587-13825496286731_thumb.jpg

Share this post


Link to post
Share on other sites

Well. Again, seems the problem with duallink. As it was here

http://www.insanelymac.com/forum/topic/291276-help-ati-mobility-radeon-hd-4570-doesnt-work/?p=1942157

Unfortunately, I don't know the solution with Chameleon for it. You will have to use DSDTInjection, or clover injection.

For dsdt, injections I need IOReg with working Graphics from Clover.

I recommend you to install clover to a USB stick by Disk Utility. After I can try to make DSDT injection and as a result, with any bootloader your Graphics will be working. It's up to you what to use after

You can give me smbios to make right config.plist for Clover

-----

PS The weigh of kext that you gave me is only 102bites. It's impossible to open

Share this post


Link to post
Share on other sites

Sorry about the kext, I don't know what went wrong, but now online there should be the correct version.

 

OK, late this night I'm going to make a bootable Clover USB and I'll post when I've done. Can you link me a tutorial for the operations I have to do with Clover?

Share this post


Link to post
Share on other sites

Ok, I installed Clover on USB but when I try to boot I get this interface and it can't actually boot any OS (when I try to boot Mac OS X, for example, I get what you can see in the second picture)

post-1229587-13825638070607_thumb.jpg

post-1229587-13825638324609_thumb.jpg

Share this post


Link to post
Share on other sites

1) Install SATA Clover X64, without upgrating MBR sectors(You've already done it by BDUtility

<key>Theme</key>
<string>bluemac</string>
I see you've got a blue screen it means clover wasn't be able to find a theme. Check theme parameter, install necessary theme from Instalator

2) Use Vbios. You must use your dev-id http://www.insanelymac.com/forum/topic/287995-how-to-launch-ati-card-by-dsdt/?p=1938815

3) Put your DSDT here /EFI/CLOVER/ACPI/patched

4) Try to use my config

config.plist.zip

Share this post


Link to post
Share on other sites
Nothing changed, I still get the same boot screen error like in this post.
I tell you what I've done step by step.
 
1) I create a bootable Clover USB with this configuration
2) I copied the .rom file you updated me in EFI/CLOVER/ROM on the USB
3) I copied my DSDT.aml I found on /Extra in the /EFI/CLOVER/ACPI/patched USB folder
4) I copied config.plist you gave me in the /EFI/CLOVER USB folder
I booted my PC from Clover and selected Boot Mac OSX from Mac OSX (if I select boot Mac OSX from Clover I get nothing but a Clover logo).

Is everything correct? 

post-1229587-0-56305800-1382644006_thumb.png

Share this post


Link to post
Share on other sites

I don't know. It should work. And now, Does it work with Chameleon, I mean if driver is loaded you should get  distortions as you shown on ninth message. Try to fix permissions again by kext utility.

Check it with chameleon again  to find out if it is problem with kext or with Clover.

Share this post


Link to post
Share on other sites

Ok, I installed Clover on USB but when I try to boot I get this interface and it can't actually boot any OS (when I try to boot Mac OS X, for example, I get what you can see in the second picture)

I'm following this thread trying to also get my 4570 running under Mavericks (thanks so much for your help Alex!). I had the same boot problem - it turned out Clover's default SMBIOS was setting the mac up as an older MacBookPro that didn't support Mavericks. Try adding -v to your Clover boot arguments (in config.plist, add -v to the <string> below <key>Arguments</key>, mine reads <string>npci=0x2000 -v</string>).

 

If your issue is caused my the same problem, then you'll see "this version of mac os x is not supported by this platform" next time you boot.

 

The fix is easy, add 

 

<key>SMBIOS</key>
<dict>
<key>ProductName</key>
<string>MacBookPro5,1</string>
</dict>

to the end your config.plist file, above the last </dict>

 

I hope it works!

Not to hijack the thread, I have a question about creating the card profile - I've been reading up about it and I think I understand most of it, I'm not certain:

Using DarwinDumper I get this for my VBios

ATOM BIOS Rom: 
        SubsystemVendorID: 0x1043 SubsystemID: 0x1b32
        IOBaseAddress: 0xd800
        Filename: f83s0901.m92
        BIOS Bootup Message: 
M92M2-XT Asus F83SE DDR2 500m/680e ASID:A270110.T07$                        
PCI ID: 1002:9553
Connector at index 0
        Type [@offset 45494]: VGA (1)
        Encoder [@offset 45498]: INTERNAL_KLDSCP_DAC1 (0x15)
        i2cid [@offset 45556]: 0x90, OSX senseid: 0x1
Connector at index 1
        Type [@offset 45504]: LVDS (7)
        Encoder [@offset 45508]: INTERNAL_UNIPHY2 (0x21)
        i2cid [@offset 45579]: 0x16, OSX senseid: 0x7
Connector at index 2
        Type [@offset 45514]: HDMI-A (11)
        Encoder [@offset 45518]: INTERNAL_UNIPHY (0x1e)
        i2cid [@offset 45602]: 0x91, OSX senseid: 0x2

Which is different from most because the connector at 0 is VGA and at 1 is LVDS - the reverse of peppeuz

does this mean I swap the rows in my personality?

 

10000000 10000000 0000 0000 00 10 01 01 #VGA
02000000 40000000 0900 0000 12 04 00 07 #LVDS
00080000 04020000 0000 0000 10 00 02 02 #HDMI-A

Share this post


Link to post
Share on other sites

I've managed to get full resolution and QE/CI! :D

 

Here's the important parts of my config, rather than editing AMD4600Controller.kext's plist, it's better to spoof the device id because ATIRadeonX2000.kext is required for accelerated graphics and also depends on the device id.

 

Spoofing the device id so AMD4600Controller.kext recognises it:

<key>FakeID</key>
<dict>
	<key>ATI</key>
	<string>0x94901002</string>

....  

Next, graphics settings:

<key>Graphics</key>
<dict>
	<key>Inject</key>
	<dict>
		<key>Intel</key>
		<false/>
		<key>ATI</key>
		<true/>
		<key>NVidia</key>
		<false/>
	</dict>
	<key>VideoPorts</key>
	<integer>2</integer>
	<key>FBName</key>
	<string>Shrike</string>
	<key>LoadVBios</key>
	<true/>
	<key>InjectEDID</key>
	<true/>
	<key>VRAM</key>
    <integer>512</integer>
	<key>PatchVBios</key>
	<false/>
	<key>DualLink</key>
	<string>0</string>
</dict> 

I've attached my config for reference but it won't work on your machine without some changes.

 

It's possible to also patch the framebuffer personality from the Clover config, this'll make the system more resilient to updates!

1002.9553.0301.00E0.vga.rom.txt

config.plist.zip

Share this post


Link to post
Share on other sites

I really can't make it working. I tried all the stuff suggested here and online, but I'm having no luck.
I'm now thinking that this might depend on the kext I'm using for graphics. I used a specific tutorial for my PC I found online, but  it couldn't help on QE/CI so right now I'm not sure about this. Here's all the things I've installed with Kext Wizard, do you think some of them could cause problems?
http://imgbin.org/index.php?page=image&id=15496

Please, Geo 877, can you upload me all the kext and config files you used?
(I'm going to change framebuffer by myself)

If I make it working, I owe both of you a beer :D

Share this post


Link to post
Share on other sites

I made some step forward using Geo877 config.
Now it boots from Clover and recognize my Graphic Card, it works with high resolution but QE/CI is still not working completely.
I cant use launchpad properly (still too laggy!), go to the dashboard and so on.

The fake ID I should use is the same as yours? If not, where should I get mine?

Share this post


Link to post
Share on other sites

The fakeID should be fine, It's one of the two supported by AMD4600Controller (you can see it in the info.plist)

 

If you've got full resolution you're getting close, do you have some files named ATIRadeonX2000.* in you System/Library/Extensions folder? I didn't but I think that's because I accidentally deleted it a while back, replacing them solved my issues
 

I'm attaching the AMD4600Controller, it's setup for my card but It may work for you. 

AMD4600Controller.kext.zip

Share this post


Link to post
Share on other sites

Yes, I have ATIRadeonX2000.kext.
I'm now trying with yout kext, deleting my ATI4600Controller. I'll let you know in a few minutes.

 

 

EDIT:
With your kext I get a black screen after booting.
Any suggestion? Should I change the framebuffer of the kext with the values Alex gave me?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×