Jump to content

Not booting... sometimes?


2 posts in this topic

Recommended Posts

I upgraded from 10.8.2 to 10.8.5 (app store) last night, and since my Dell e6510 would not boot.

I discovered the cause was the "npci=0x02000" flag.  Once I was able to supply boot flags I removed it, and it stopped hanging at the PCI scan.

All was well, so I thought.


I got up this morning, to a machine that won't wake from sleep (I think.. not important right now) and when I boot it, it just sits at "No interncal dound for . using 8000000", which is the last thing I see.


However, a few lines up I see it's most likely waiting for the root device. 


Waiting on ... boot-uuid-media



The crazy thing is, I can get it to boot sometimes.  I'm not sure yet HOW I've done it. I keep trying a mixture of flags, coupled with peripherals in and out (usb mouse/keyboard).  I will get it to boot, then reboot and it will revert back to this scenario.



I have tried many boot flag combination with PCIRootUID, and always boot with -v.  I don't seem to be able to make any headway into the scenario in which it does boot successfully.


Any tips?




Well, I reinstalled.  Everything was working.  I ran through software updates to which it reported "None of the selected software was able to be installed."

Upon rebooting, I am waiting for the root device again.



Another Update:
I reinstalled again.  I applied the update for 10.8.5.  This is definitely related to the upgrade to 10.8.5. Maybe I shouldn't do it, but I hate having updates that I cannot apply :P
I am still trying to figure out if I can get passed the root device issue.
I'm reading through this:
But haven't figured out what do yet.
I stumbled into this interesting tidbit:
I went ahead and pulled the kexts mentioned from 10.8.2.  That did not help.
I removed npci=0x2000 from the kernel options.  10.8.5 really doesn't like that, and hangs at PCI configuration (it doesn't like 0x3000 either)
I booted with -v -x and it's sitting at PCI configuration.  There seems to be no winning this war :)
Perhaps I need to stick with 10.8.2 for the time being.
Link to comment
Share on other sites


  • Create New...