Jump to content

Mountain Lion - Dell e6510 - couple issues


13 posts in this topic

Recommended Posts



  I've installed iAtkos Mountain Lion on a Dell e6510.  Things are going pretty well.  I have three annoying issues I would love to get some help with.


I'm pretty new at all this, so I might have missed some things.


1) No Audio. This has an IDT 92HDxxx chip in it.  I've done a ton of reading, but I can't seem to get anything to work.  


2) The system will not reboot.  When it gets to that point it just stops.  I read somewhere that this happens when you don't have a DSDT or you need to use EvOreBoot.  Neither seems to work.  I used DSDT Editor and extracted the DSDT. I applied a patch a found somewhere on the internet for an e6510.  


3) After I come back to the system for awhile it's dark and non-responsive.  I am assuming this is power saving. I have no problem disabling this.  


I would really like to get 1) and 2) resolved to make this more useful.


Thanks very much!



Link to comment
Share on other sites

is it possible to re-install mountain lion using this guide?  you can use your iAtkos build to create the usb installer.  that might solve your no.2 issue.


as for your sound, i will try to help you (but not guaranteed to work 100%) with it if you re-install osx.

Link to comment
Share on other sites

to get your audio working, you'll need a codec dump from a linux distro.   i suggest to use an ubuntu live cd.   open a terminal window and type this:


cat /proc/asound/card0/codec#0 > ~/Desktop/codec.txt


note that codec#0 could be codec#1 in your case, so change accordingly.

Link to comment
Share on other sites

from your other post:

Well, I reinstalled.  Everything was working.  I ran through software updates to which it reported "None of the selected software was able to be installed."

Upon rebooting, I am waiting for the root device again.





try to boot in safe mode -v -x


if you're able to boot in safe mode, try to rebuild kernel extensions cache.  you can use kext utility for that.

Link to comment
Share on other sites

My other post was actually completely different.  Mac OSX 10.8.5 won't work on this system. My other post was uncovering that.  It won't get beyond the "waiting on root device". This thread is still applicable.  I have re-installed and have updated to 10.8.4.


So, I'm back at it these 3 problems now.   I did try voodooHDA for sound. I had mixed results. in one scenario, my first install it would not load, and the control panel would say there were no devices.  In another install, It loaded, the control panel worked, but after rebooting I suffered from a Kernel Panic.


I have tried to remove hibernate. (pmset0-a hibernatemode 0).  every time I step away the dang thing is "off" and unwakeable. 


So, I am back at these three issues, and I have given up on 10.8.5 for now.  I would like to spend more time using this system than trying to get it to work! haha

Link to comment
Share on other sites

Audio>  So, I downloaded the voodooHDA package (2.8.4) and installed it.  I went into pfino.list and changed the Vendor and Device ID based on this reading:



I rebooted, and the control panel still tells me "No voodooHDA devices."


I also used DSDT editor to extract my DSDT and saved it into /Extra.  I haven't done any patching yet, as i'm not sure how.


Still chugging on these.

Link to comment
Share on other sites

Well, that's frustrating. I've been doing a fair amount of reading, but not really anywhere.

I stumbled into this thread:


and this one:



I grabbed the kext for the wireless and installed it with kextutility, then I reinstalled the voodoohda package.

I rebooted, and I have an audio, icon and some sounds! volume doesn't work, but eh. 


On to the restart issue!

Link to comment
Share on other sites

let's work on your audio first.

i have an IDT 92HD81B1X5 (IDT 7605) codec and i used this as a guide.  but you don't have to go through all  that process. like i said in my previous post, i'll try to help you.   i just need you to get a codec dump from your machine using an ubuntu lived cd.  

when you boot to an ubuntu desktop (assuming you used ubuntu 12.04 desktop), click on dash home and type terminal.  click on terminal to bring up a terminal window.   type the following:


cd ~/Desktop
cat /proc/asound/card0/codec#0 > codec.txt   


while you're at it, you can get the following files as well:


lspci -nn > lspci.txt


sudo cat /sys/firmware/acpi/tables/DSDT > DSDT.aml


save the three files you just created (codec.txt, lspci.txt and DSDT.aml) and upload it here.

Link to comment
Share on other sites

voodooHDA is fine but patching appleHDA is better.  but the choice is yours.


pci list of your laptop is always good to have.   i always check my pci device ids when installing os x and non stock kext.


DSDT is also good to have.  you may need it to patch your hackintosh to make some device functional.

Link to comment
Share on other sites


  • Create New...