Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
rainbowmac

Kernel panic every time I try to install OS X with Clover

5 posts in this topic

Recommended Posts

I can't figure Clover out!! I've tried so many times!

 

Heres what I've done so far:

  • I restored the InstallESD.dmg onto my USB drive formatted as OS X Extended Journaled, GPT using Disk Utility (I also have a MacBook).
  • I then downloaded Clover from here http://sourceforge.net/projects/cloverefiboot/files/Installer/Clover_v2k_r2184.zip/
  • I ran the installer, choose Customise, and ticked: Install boot0af in MBRCloverEFI 64-bits SATA & Drivers64 -> UsbMouseDxe-64
  • I installed it to another USB with a single FAT partition, MBR.
  • I put the fakesmc.kext I got from OSX86.net into the /EFI/kexts/10.8/ folder (I still got the same results without including the kext).

 

When I boot off the USB and choose to boot of the install USB I get a kernel panic:

<!-- Ususal stuff here, doesn't look as important -->
AppleACPIPlatformExpert::start failed
panic(cpu 0 caller 0xffffff80034649c1): "Unable to find driver for this platform: \"ACPI\".\n"@/SourceCache/xnu/xnu-2050.48.12/iokit/Kernel/IOPlatformExpert.cpp:1514
Debugger called: <panic>
Backtrace (CPU 0), Frame : Return Address
<!-- Insert gibberish here -->
BSD process name corresponding to current thread: Unknown
Boot args: ncpi=0x2000 -v root-dmg=file:///BaseSystem.dmg
<!-- Insert the rest of the usual KP gibberish here about the version and kernel and uptime -->

Please help!

 

 

My stuff:

ASUS B85M-G

Intel i5 4430

8GB DDR3 1600 RAM

Mac OS X 10.8.5 (Mac App Store purchase)

32GB USB 3 Flash Drive

 

I also have a MacBook to use.

Share this post


Link to post
Share on other sites

Remove ioplatformplugin.kext from System/Library/Extensions , rebuild caches and you're good to go.

Thanks for reply, I don't currently have OS X installed on the machine, I only have the USB I created with disk utility.

There is not S/L/E folder on the USB.

Share this post


Link to post
Share on other sites

Most installers are supposed to include an S/L/E, even if it's on a USB.  If you have Windows on the side, you can browse your installer using MacDrive or Transmac.

 

There is not S/L/E folder on the USB.

Share this post


Link to post
Share on other sites

If you try the fix mentioned above without success, it could be your DSDT. Use this boot option (assuming you have Chameleon)   DSDT=NONE

My system was running until I created a DSDT.aml and started having kernel panics with the same symptoms as shown above.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×