Jump to content

Install OSX on old PC


15 posts in this topic

Recommended Posts

Hi there! I have an old pc with the following specs:


- Asrock 775vm800 (Chipset- Northbridge: VIA® P4M800, Southbridge: VIA® 8237R,

Audio - CMedia CMI9761A 6 channel AC'97 audio codec LAN - VIA® 6103 10/100 Ethernet LAN PHY
- 802.3u, WOL supported
- Supports PXE


- CPU - Celeron 2,98GHZ

- 1GB ram

- Maxtor HDD 80GB IDE

- Geforce FX5200.


Does anyone manage to install osx on this motherboard? I tried Iatkos v7 (10.5.7) and Ideneb 1.6 (10.5.8) , installation went normally without using flags but after reboot, hangs at "flushing fs disk buffer returned 0x5". I used the flag-x and entered the desktop but in safe mode.

Link to comment
Share on other sites

You were lucky to get that far!


Use console.app to read system/kernel.log and look for things to fix

Use System Information and under software, click Extensions to see which drivers are loaded for the hardware.

IORegistryExplorer from OS X developer tools is also helpful.


There's a "guide for all nvidia boards" over on ProjectOSX but the forum is down for a couple of days now.

The FX5200 might be too old to be supported in 10.5.8, not sure, but the info is in that guide.

OS X on Intel has no AGP support, so if that's an AGP card it will work like a PCI card at regular PCI bus speed. This means no high resolution gaming. I used to have a 7600 GT AGP fully working on 10.5.x, except most games (Tomb Raider Anniversary for example) were completely unplayable on anything above 640x480. 640x480 was buttery smooth though :)


Look for specific drivers for the sound and LAN here, you'll be trawling through some very old posts to find those, if they exist at all. I know there are some CMedia sound drivers around here somewhere but I don't know if they'll work with your hardware. When you find useful information make sure that it is period correct, meaning that it's from the time when the OS/distro you are using was released, or from the time when your hardware was still fairly recent. Try to avoid mixing old and new until it's stable. It might be tempting to run the latest version of Chameleon with kernel patcher module and fakesmc etc but it might not work well on old iron like that. Use old OS X and old Hackintosh methods and tools.

Once you have it running more or less "period-accurate" you can start trying to update it and see how far you can get. Actually 10.5.7/8 is probably stretching it, you might have better luck with Tiger.

Also try JaS Client/Server 10.5.4 and the last 10.5.x iPC distro (I don't remember what version it was or if there was ever a full release, i remember there were some .ppf patches).

What's the exact model of that Celeron CPU?

Link to comment
Share on other sites

Also I tried Iatkos v3s2 (10.6.3), pc is restarting when "nvenabler fails" message appear.


Now I'm trying Mac OS X 10.4.8 [JaS, I hope it will work.


update: It works. (JAS 10.4.8). I choose "titan" for my video card. What do you think? I want to know if the video card is fully functional.


Only left audio channel with Voodo HDA from JAS dvd.



  • Like 1
Link to comment
Share on other sites

Just ignore that, you will not be able to use a Geforce FX 5200 on Lion or Mountain Lion...much less Mavericks. Read, people....read before posting...


If that Celeron indeed has EM64T (this is why I asked you for the full model name earlier, you must have missed it) you can probably use Chameleon's kernel patcher module with an unmodified kernel.


Note that this would require you to use a modern version of Chameleon, which is totally and utterly untested with old versions of OS X. If you want to play around with that you might want to install Chameleon to a USB flash drive so as to keep it separate from PC_EFI or the pre-historic versions of Chameleon used by the distros you are messing around with.

  • Like 1
Link to comment
Share on other sites

I don't know what cpu model is exactly, in bios says "64 bit mode", Celeron 2,93GHZ.


The "flushing fs disk buffer returned 0x5" error is from the video card in Ideneb 1.6, reinstall without any video kext in customize and now boot in desktop without problems. But I cant manage to make video full work. I tried this metod http://www.insanelymac.com/forum/topic/147066-fx5200-works-1055-and-1056/, but after first step (osc86 tools, add efi string etc) and reboot, hangs at "flushing fs disk buffer returned 0x5", and -x flag doesn't work.

Link to comment
Share on other sites


Evrika, my SL 10.5.8 - ideneb 1.6 is working with QE/CI and Quartz enabled!

Steps that I followed:

1. I installed again iDeneb 1.6 with default customize (with voodoo kernel) and without sound, lan, video.

2. After boot in desktop - installed 2587-nvenabler+tools. Reboot.

3. I have followed these steps from OSX86Tools, Universal nvidia installer, etc), without first step ( I haven't removed any geforce kext), and without log out or reboot between steps. (OSX86Tools, Universal nvidia installer, etc)

4. Finnaly reboot. Card is recognised but with scramble graphics. To fix the graphics issue I used Sanya method from the link above with Pacifist and CoreGraphics.framework from IAKTOS 5i dvd.

5. Restart and enabled quartz with OSX86Tools.

6. Installed audio and lan kext.


Still, I stuck with a little problem and I hope you can help me. When I click on About This Mac, the system seems to Logout and login back. When I installed ideneb, I checked the "about this mac fix" and yet it seems that is not working. What can I do?
Link to comment
Share on other sites

No idea. I've forgotten more than I have learned by now. But I know that was a common issue back then and I'm sure you can find a fix for it if you look hard enough.


If you had asked me the same question back in 2009 I would have had an answer or a link for you.



btw "enabling Quartz" with OS X tools is a red herring. It does not do anything except confuse noobs.


Quartz is always enabled for apps that are programmed to use it. Forcing it on for everything will cause issues.


Quartz cannot be "enabled" by OS X Tools, you need fully working video drivers to have hardware accelerated graphics.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...