Jump to content

Asus P6X58D E Succes (so far) Mavericks GM


4 posts in this topic

Recommended Posts

Hello, first post here, hughe OSx noob here, just started with this for fun about 2 months ago and have been enjoying a completely stable / fully functional ML 10.8.4 system for the last month or so.


//EDIT: I´m editing to post my complete hardware specs:



Asus P6X58D E

Core i7 930 @ 3.8ghz

EVGA Geforce 760

Dell 3007WFP + 2 x 22¨ 1080p displays in PLP arrangement (got myself one 2007FP used for cheap so the 2 x 22s are going and im going to have jsut 2 screens till i grab another 2007 for cheap or 4k 60hz screens are priced at affordable levels  :rolleyes: )

Samsung SSD840pro 256GB

$ 5 BT dongle (went throught 4 of them till I found one that worked in ML, not easy to find the targus one here in argentina)



Was hoping to give 10.9 a try as soon as I could but the only thread i found by googling with my motherboard with the DP version was from this forum and from a member not able to get sound nor network working right.


I´m going to share my (nobbest way possible, for sure) way of geting this working in just about the first hour or so of trying, not a single hiccup so far:


1) Had a spare 128gb SSD so i Superduped my ML installation to it in order to just unplug my main 256GB ssd and be able to play with the new system disk without worries of losing the ability to boot back into a working OsX as soon as I wanted/needed to.


2) Used myhack to prepare the 10.9 instalation to a USB drive


3) Booted into it and risked just installing it over my 10.8.4 installation from the setup screen, instead of going the fresh install way (I´m going to be honest here, did this since I´m nor really familiar with manual / terminal way to do things so far :( and I read about this guy not geting network up, so not being able to google for help / download stuff would be a major downer if that happened and atm this is my only system in the house, GF went out with the notebook, and while I could browse for help at the iPad or phone, they were not fast enough to do some serious forum browsing and no help if i need to download some kext or apps and get them into my mavericks installation)


4) Let myhack avoid the apple kexts it suggests avoiding (not really sure how bad this is, did this too with my 10.8.4 and I could not see a problem with this in the time i used the hack so far) 

    Rebooted, chossed the 128GB ssd from chameleon, went with GraphicsEnabler=No, got offered to sign into icloud, which i canceled just in case, and got greeted with my old familiar login screen, typed my password and boom, on the desktop and with network functionality there!!!!!


5) only thing lacking was sound, tryed a couple of kexts from some threads here, but since i dont really knew if kexthelper (don´t laugh at the newbbie  :wub: ) would work at all or not in 10.9, and (once again, lazy {censored} here, got it working the ez way, so I did not have to learn the proper way I guess) I don´t know if just copying the kexts into extras is enough (tried that, still not sound) I gave you know what a try, used it to install my DSDT (same from ML obv) added GraphicsEnabler=No to my org.chameleon.Boot.plist, restarted and here I am, typing this from my network connected, sound enabled Asus P6X58D E in Mavericks!!!!



Just felt like sharing in case some other member is wondering an upgrade to the latest OsX with this good old board, I´m now going to just give the sleep/resume process a try, then use this for the weekend and once im sure I´m going to move this instalation back to my 256GB SSD and keep this. 


I´m going to take the chance of this post to thank all of you guys for the help i got from just lurking this forums everytime I needed help at being stuck with something, and again my appologies if my method even when working, sucks to much for this community´s standards.




Would also like to use this same thread to ask those of you who might know one silly question: I´m going to buy mavericks once it´s out at the appstore, but I´m not developer and I´m running this, so, well, errrrrr, ok, you got it.


What do you guys think about loging into icloud / appstore / itunes store with these Golden Masters in these situations?



Oh, and btw, at the first time the system is loading any kext i get a warning message from OSx about it not being signed, but telling me it´s going to load it anyways, not sure if this could get locked down harder on further upgrades by apple, just wondering, not that I worry to much about those messages being there, reminds me about the very first time using windows vista´s drivers on 7.


Ok, excuse my english and the brick of wall and once again thanks all for the help!

Link to comment
Share on other sites

Hey there, fellow X58D-E user!


Logged in to iEverything with Mavericks GM - it's out to devs, surely they anticipate testing it out with different Apple accounts for app testing etc.


I use the newest FakeSMC kexts, the Yukon injector, and a patched AppleHDA, that's it. All three are loaded by Mavericks without complaint.

Mavericks works a lot better on this board than ML - IIRC ML required a AppleACPIPlatform rollback, Mavericks doesn't.

Link to comment
Share on other sites

Hey, I thought I was the only one lol :). Thanks for your reply, and yeah, I went ahead and signed on everything and no problems at all, asked in the chat and people told me it´s been like this for all previous GM releases so far.


On a semi related topic,  I got into the chat on saturday and got some insight from Donw35 on NVRAM, pure vanilla installation etc, and decided to give it a try on sunday so, starting from scratch, with great help from both team faq´s vanilla installation guides (ML and 10.9) I prepped my usb Mavericks GM stick, started to mess a bit with terminal and got it finally running with everything working late in the night. Not sure the improvements I ¨¨ see ¨¨are real or just in my head (others than Messages finally working, thanks to nvram fix, and me having a unique SN, chameleon wizard courtesy) but now I kinda know what kexts I have and I start to get some of what I did to get this working, instead of just clicking buttons and being greeted with a OSx desktop just cause scripts made it possible.


I even went ahead and placed a patched appleintelcpupowertmanagement kext and removed nullpowermanagement just a few minutes ago and it just booted (I thought I was due a reboot in terminal to go back to null haha =)  )


Think the next step for me is trying to learn how to use the latest fakeSMC binary and hardware sensors plugins to get hardware monitoring working and then check that my GF760 is running at whatever clocks it´s meant to run, since I´m ocd about some very minor and super randomly occurring micro stuttering while vertically scrolling some websites on safari, even when all benchmarks and general 3d performance is great, so I want to be sure that when idling my Geforce is not being throttled down more than it should, but need to have real time monitoring for that.


Again, thanks for your input and once again thanks everyone that contributes to this great community.


GL all! 

Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...