Jump to content
InsanelyMac Forum
Sign in to follow this  
zonoskar

Mountain Lion 10.8.5 doesn't recognise Marvell 88E8056 on P5E

Recommended Posts

I had Lion 10.7.2 up and running without a problem (well, actually, sleep and shutdown didn't work properly, but I didn't mind). But somehow, after a manual shutdown too many, my install didn't work anymore (would just hang somewhere), i decided to upgrade to the next release. I have 2 other Macs, so I tried the myHack method + a finalising/kext installer software from an unsupported site as that worked on the 10.7.2 install too. But I'm unable to get  the Marvell network card to work. On 10.7.2, I would change some strings in the AppleYukon2.kext in the IONetworkingFamily kext and the card would work. But this time that only stalled the boot process. When booting with -v it didn't become apparent where the problem was as I didn't see an obvious error. I tried installing the 10.7.2 kext from a backup, no go, then I tried this kext from http://www.insanelymac.com/forum/files/file/35-marvell-yukon-88e8056-108-1085/ in /Extra, but that didn't seem to do anything. I then replaced the kext in S/L/E, but the system would hang again. I even reinstalled 10.8.5 and made a DSDT file for my system (normally, I didn't have to), and applied patches for my motherboard (from http://olarila.com/forum/packs.php). But that way, I don't see a network card and if I try any of the above methods to get it to work, the same thing happens.

 

So I'm a bit lost now. My Hackintosh is running fine, although without any network. It's driving me mad :) Even so mad that I booted into my existing Windows 7 install to see if the network card didn't die. It worked fine there. Bummer.

 

My hardware:

Asus P5E motherboard (with unsupported audio chip and Marvell 88E8056 network), Intel X38 chipset.

Intel Q6600 2.4GHz@3.6GHz (I also tried without overclock).

nVidia GT8800.

Crucial M4 boot disk.

Share this post


Link to post
Share on other sites
Advertisement

I have an Asus motherboard with dual 88E8056 Marvell Yukon ethernet ports.  I am having no trouble with 10.8.5.

 

Instead of messing with the networking kext each time, I use a Yukon injector kext.  Whenever I update, the vanilla networking kext gets updated, but the injector kext is unaffected and it injects my vendor/device id during boot.

 

Remove any other networking kexts you may have added.  Install the vanilla 10.8.5 IONetworkingFamily.kext into SLE along with the Yukon injector kext.  Both are attached.

 

 

.10.8.5 Yukon Kexts.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×