Jump to content

en0=connected & ISP=green – but still no internet


4 posts in this topic

Recommended Posts

Network diagnostics give the following info:


Ethernet = red

Network Settings = yellow

ISP = green

Internet = red

Server = red


This is on a brand new installation of ML 10.8.2 (my first!!) on a Dell Optiplex GX620 which has an onboard Broadcom BCM5751 network chip (as opposed to a separate PCI card).


I know the cabling, NIC and routing etc is OK because I can swap the ML hard drive for another which has a stable and working Leopard 10.5.2 immediately before and after working on ML and everything internet-wise works tickety-boo.


The Hackintosh and my Windows PC are both plugged into a Netgear WGR614 v6 router (4 ports), which in turn is connected to my Internet Service Provider's modem, a Thomson Speedtouch. (This has the MAC address and the router is configured with this address.)


Obviously there's a problem somewhere between the kext and the kernel. I'm aware that the kernel in ML is 64-bit and therefore it requires a 64-bit ethernet kext. A 32-bit kext just won't work. (Correct me if I'm wrong please.)


Most of the BCM5751 kexts I've been using previously have been 32-bit and I've been able to determine that by using the Kext Info tab on an excellent app called Kext Wizard.


Immediately after installation, I had 5 red lights whichever kext I installed, with or without the NIC turned off in BIOS. (That trick has worked for me before in various 10.5 and 10.6 installs.)


However, I found a thread on another forum and the guy said he had successfully used a kext called “3523-BCM5722” to solve the same problem which is available for download on another site we don't mention here but has the words tony & mac & x86 in its title.


That also didn't work initially until I took some advice from a post by Cerastez who had previously advised me to edit the Info.plist to include the line <string>pci14e4, 1677</string> in the array section of the list (where 1677 is the ID number of the BCM5751.


Then on boot up in verbose mode I noticed the 5722 was recognised and given a MAC address (or is it a Router Hardware Address?) but this only solved the solution partway, to what I mentioned at the start of this post: an entry (at last) of en0 adapter in the left pane of SysPrefs>>Network which is green and says connected. After clicking apply and waiting a few seconds, DHCP (set to Automatic) assigns an IP address (which should be a local number to the router but isn't). And as I said, Network diagnostics gives red/yellow/green/red/red traffic lights.


On my Windows PC (and the Leopard 10.5.2 in the Dell), if I type in into an empty browser page with my user name and password, it takes me to the “home page” of the router where I can access and modify its settings if I want to. However, in ML it does not even allow me to do this. That tells me the card cannot 'see' the router, even though the router light for this port is green.


So now I'm stumped cos I really don't know how or what else to change the network settings in OS X 10.8.2.


Any help or advice if you are or have been in the same boat would be gratefully received.

Link to comment
Share on other sites

I guess that clearly explains it.  I still have not found or known anyone that created enough kexts to support a wide range of most Broadcom/Netgear wi-fi adapters.  I tried many for a Netgear WNDA3100v2 and still can't figure out what kext would be best for that.  Until I get pointed in the right direction, I use my old Belkin F7D1101v1 for the time being.

Link to comment
Share on other sites

, I use my old Belkin F7D1101v1 for the time being.


Well, that's just the point I was trying to make.


I've got a stack of old PCI network cards lying around that might do the trick.................but the Dell has its 5751 hard-wired to the Mobo.


So unless I change my computer (which is a bit pointless since I've only just got it and bought it SPECIFICALLY for Hackintoshing), I'm gonna have to find a workaround. If someone on another forum says he's solved his internet access problem with the the same make/model of PC as me, with the same NIC, and with the same OS X, that gives me hope.


But how.....................????





This is really doing my head in. I was experimenting with swapping the cable between the router and going directly into the modem. (That hasn't worked before for any Hackintosh install because of - I think - the way I've got the router set up for Windows. Rather than using the default MAC address, or the computer MAC address, I've got it allocated to a particular MAC address which I've specified. Can't remember why I did that, maybe my ISP told me to do it that way - it was 8 or 9 years ago when I bought it and then I only had Windows PCs on the network and no Hackintoshes. So I always go into the router - which has only got 2 internet ports anyway, the other two are for TV top boxes.)


I got distracted for a few minutes while I was moving the cable from modem to router and inadvertently left it UNPLUGGED. I booted up the Mac and wasn't surprised to see the 5722 kext loading successfully and an Ethernet address (6 hex numbers separated by colons) being allocated in verbose boot up mode, or that I saw the red/yellow/green/red/red traffic lights in Diagnostics - same as before......................until I turned round and saw the disconnected cable!!!


Even stranger is that in SysPrefs>>Network it was showing an en0 green connected symbol as well as an IP address and a subnet mask. How can an NIC card allocate itself an IP address without being connected to anything???

Link to comment
Share on other sites

  • 2 weeks later...

Well, this is not really a 'Solved', more of 'I give up and find a workaround'.


I deleted all kexts for 5751 and all other BCM adapters, turned off the onboard NIC in BIOS...............


............and simply bought a USB WLAN adapter for 10 Euros including postage via Amazon. Switched on the wireless function of my router, plugged in the dongle (more of a shirt button than a stick really), ran the installation software from the mini-CD supplied with it (Mac OS X 10.4 to 10.8), and the Realtek RTL8188CU driver kicked in with instant Internet access at 54Mbps (the adapter works at up to 150Mbps but my old Netgear WGR614v6 is the limiting factor here). This particular adapter also works brilliantly and with no fuss in all flavours of Windows, 32-bit & 64-bit, as well as Linux (all drivers and manuals included with product or available for free download).

Link to comment
Share on other sites


  • Create New...