Jump to content

Several problems on Acer Aspire 7750G (Dual-Screen, Sleep, SpeedStep, Sound...)


2 posts in this topic

Recommended Posts

Hey guys,


I have been working on my hackintosh for about 10 days now, and it was a lot of work. Sadly I still have some problems that bother me:


- Dual Screen not working

- Sleep not working / No waking up once the screen has gone black

- SpeedStep seems not to be working

- Sound seems a little bit distorted


System specs:

  • Acer Aspire 7750G Notebook
  • Intel i5 2430M CPU
  • ATI HD Radeon 6850M 1GB
  • 8Gb RAM
  • Broadcom 43227 internal Wifi (not working, currently on Edimax USB Wifi, internal will be replaced within the next few days)
  • ALC269 Sound Chip


Some info about the installation:


I did not use a DSDT, because apparently there is no patch file for my mainboard. I would / will try to do this by myself, or would greatly appreciate it if someone would patch my DSDT file. I used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to get the most things working, also experimented a bit with the packages to install, to see if I could advance in any way with the problems listed above. So there may be some kexts installed, that prevent certain components from working, but my hackintosh knowledge is just not that deep to figure out if and which that would be.



I will go into detail:




Dual Screen not working:


Getting the graphics working was most of the work.


- When I try booting without any ATI Framebuffer set, my graphic card gets recognized correctly in the system information app (QE / CI enabled), but my Notebook Screen stays black - External Screen (VGA) works fine. Even when I plug out the external screen, the internal screen stays black. Both screens are recognized in the settings. Setting ATI Ports did not change a thing


- When I boot with a framebuffer enabled / GE = yes (I had to manually add my device id and vendor id to AMDRadeonAccelerator.kext and ATI5000Controller.kext to get my card recognized with a framebuffer, ATI6000Controller.kext does NOT work) and the external screen plugged out, my internal screen works just fine. When I boot with my external screen plugged in, the external screen works just fine, but the internal screen stays black. Both screens are recognized in the settings, I can arrange them and everything, but I can not see a thing on my internal screen.


On an additional note, I just discovered that the QE / CI on my external screen is way sloppier than on my internal screen (lagging on the screensaver and stuff), any clues why that is?




Sleep / Wakeup not working:


The notebook just won't go into sleep. When I try to, the screen goes black, but the disks, the fans, the leds, everything else stays on. And from there on I can only reboot, since there is no way to wake the PC up again. Same problem seems to be the case when I unplug my power cord while Mac OSX is running, after a few seconds the screen goes black (I guess a power saving measurment), and cannot be awaken again.


I heard of a controversial SleepEnabler.kext, don't know if that would be helpful in my case.




SpeedStep not working:


I tested SpeedStep with MSRDumper.kext and only got multipliers of 8 and 24. I tried several different configurations in SMBios.plist but with no effect whatsoever. I can't figure out what is needed to make this run, I recently read that that is where the DSDT comes in to play?! (I must admit that I am not really sure in which situtations a DSDT is mandatory, and what effects can be achieved with a DSDT).




Sound seems to be distorted:


I installed a custom VoodooHDA.kext from a forum if I recall correctly, sadly it is the only link I did not bookmark in this progress. After installing sound is working, but the sound is definitely not as good as it sounds in my Windows 8 boot. It often sounds like the speakers couldn't handle the 'loud' output, even though it's not cranked up at all, but rather on semi volume level. Maybe a good comparison is: it sounds like when you max out the internal volume on VLC while playing a video / a song.

I tried the few tipps to fiddle around with the VoodooHDAConfig App, but nothing changed the quality of the sound.




I would really appreciate if you guys could help me through this, as I would love to get this thing working on every end.

This forum was a great deal of help within in the last few days, just by reading through it, and I hope that I'll solve all these issues with your help.


I will provide any information necessary to get further in the progress, just tell me what to do and I'll hurry up ;-)


Thanks in advance for your help, greatly appreciated




Link to comment
Share on other sites

  • 3 months later...

  • Create New...