Jump to content

Chameleon won't start on Asus Q87M-E based system


3 posts in this topic

Recommended Posts

I tried making a USB Installer for Mavericks DP1, I prepared a GUID'd 16GB USB key with the Mavericks Installation base and installed Chameleon 2.2 svn r2262 on it. I tried booting it on the following machine:

Core i7 4770  (not 4770K)

Asus Q87M-E motherboard (Intel Q87 chipset)


GeForce GTX 560 Ti 1024 MB

BIOS/UEFI settings: disable iGPU, CPU State C, disable Vd-m, disable Vt-x, SATA AHCI mode, USB storate auto mode (also tried force HDD and force CD-ROM), Boot device USB in legacy BIOS mode (also tried UEFI mode).


When it tried to boot off my USB key, I get a text cursor '_' in the upper left conner of the screen, the cursor drops to one line bellow, then it goes closer to the middle of the screen, then it disappears and nothing happens. I never even reach the bootloader's text menu.


I also create an Mavericks installer on a SATA hard drive, put Chameleon on it and tried boot it from an internal SATA controller. Same result.


I know the USB key is properly made since I tested it on my Core 2 Duo system and it boots fine. Could it be a compatibility problem between Chameleon and my motherboard or chipset? All the other posts I see for Haswell systems seem to be based on the Z87 chipset.


I am planning on trying with RevoBoot. I also heard you can use GRUB2 to load the OS X kernel directly?


If any one else with a Q87 system out there can try Chameleon, your results would be appreciated. As would any solution to my problem.

Link to comment
Share on other sites

UPDATE: I managed to get Chameleon and Clover launching on my system.


From another Hackintosh, I did the whole InstallESD.dmg procedure to a internal SATA drive, installed Chamelon then plugged in the SATA drive into my Asus Q87M-E based system. I booted into GRUB2 from my main drive and had GRUB2 boot Chameleon by doing this (grub is in hd0, chameleon hd1):

c (to enter GRUB command line)
set root=(hd1)
chainloader +1



It's weird that my BIOS can't boot Chameleon but GRUB has no problem.


Now the computer keeps rebooting when it reaches the 'Starting Darwin x86_64' line (even with -x -v GraphicsEnabler=no ACPI=no) but I still haven't tried everything yet.  I haven't tried extracting and editing my DSDT, doing that BIOS patch thing, etc.

Link to comment
Share on other sites


  • Create New...