Jump to content

Enabling GTX 770 + Audio on Gigabyte Z87x-OC

6 posts in this topic

Recommended Posts

Complete system Specs:


Intel i7-4770

Gigabyte z87x-OC Motherboard

EVGA Superclocked GTX 770 w/ ACX cooling

Corsair Vengeance LP RAM, 16GB (CML16GX3M2A1600C10)

Samsung 840 Pro SSD

Corsair HX750 PSU


Okay, so I've successfully booted up my first Hackintosh via the Chameleon boot loader, svn r-2255, following the mavericks install guides floating around on the forums. I ran into a few problems during the first few boots where it would hang at "[PCI Configuration Begin]", which I got around by switching to the Intel HD4600 integrated graphics via my board's EFI and then booting into safe mode with the -x and -f, and GraphicsEnabler=NO boot flags, which circumvented needing to add the HD4600 to OS X's device list. However this means my build has basic and unaccelerated graphics when using the Intel integrated chip.


After a bit of tinkering around with the boot flags mentioned above, OS X installed and booted up, and after a bunch of monkeying around, I got my GTX 770 working. Kinda. No matter what I did to add the device id to the NVDA kexts, the GTX shows up as a generic "NVIDIA GK104". I can't seem to get OS X to register it as a GTX 770 for the life of me. According to other threads, it just works out of the box. Mine didn't. After trying to do it "right" by manually editing the kexts over the course of about 48 hours, I eventually I got basic graphics acceleration working with the Pandora.app's ATI/NVIDIA Enabler (not to be confused with the graphics enabler boot flag) which added a ATY_Int.kext to my system. I'm almost certain this wasn't what I was supposed to do, however.


On the sound front, My board comes with the Realtek ACL892 on-board audio, but I can't get that to work at all, and it's frustrating as heck. I've googled it endlessly and read many, many posts on these forums, but I cannot get it to work with either the AppleHDA.kext + HDAEnabler1.kext, OR with VoodooHDA. I have repaired permissions and rebuilt the kext caches after every change I've made. Nothing works.


Other than the fact I have no sound, and that minor graphics hardware id issue, which I think affects the accelerated performance somewhat, my Hackintosh is running well. I've since added "GraphicsEnabler=NO" to my org.chameleon.Boot.plist, and my Hackintosh can now boot without any intervention from me.


Aside from those two semi-major issues, the only minor quibble I have is that my mouse's scrolling direction reverts to the "natural" setting and my Keyboard's modifier keys reset back to default after every reboot. I've trashed my user system and finder prefs multiple times, to no avail, but that's not a big problem. Ethernet my board's Intel i217v chipset, Messages, and the App Store worked out of the box.


Otherwise, things are looking good. Any help on any of these issues would be greatly appreciated.



Link to comment
Share on other sites

Hi SyntheticFrost

I have the same MB but different video and cpu. The sound works more or less well with voodoohda 2.8.4, make sure to use the installer (I used this one - http://www.osx86.net/view/2746-voodoohda_2.8.4_pkg_installer.html). Sometimes the system does not return from sleep or may crash suddenly but this is rare. I still can't find a working FakeSMC with plugins to read CPU/GPU temp :(

Link to comment
Share on other sites

I tried that. I installed the pkg, set the chmod, rebuilt the cache, repaired permissions, then used the terminal to load the kext to make sure they loaded. But my computer refused to boot afterwards, giving me the "**** [iOBluetoothHCIController][SearchForTransportEventTimeOutHandler] -- Missing Bluetooth Controller Transport!" error I got the first few times I tried to boot. So I rebooted in safe mode, deleted everything related to VoodooHDA, and it boots fine again.


Truth be told I'm not even 100% sure how I got past that error the first time. After I installed the nvda enabler thing mentioned above in safe mode, it just stopped happening until I try to change something.


The thing is, I don't even have a bluetooth card on this PC.

Link to comment
Share on other sites

Okay, so after much pulling of hair, I got the sound working. Believe it or not, it was that ATY_int.kext from the Pandora's Box installer I mentioned that was bothering me. I moved it to the desktop and rebooted just to see if I could find a more native way to get my GTX 770 working, since it was supposed to work out of the box, and low and behold, not only was the desktop fully accelerated, but the sound magically started working.


The ONLY thing I can think of is that the ATY was forcing some HDMI sound conflict. But if that were the case, I would think Mac OS X would at least register some kind of sound device. But the ALC892 device wasn't even found in any system infer or profile schematic at all while that ATY_int.kext was installed.


The ALC892 now works with the standard AppleHDA and HDAEnabler1 kexts.

Link to comment
Share on other sites


  • Create New...