Jump to content
Sign in to follow this  
rajkosto

Clover booting native installer via UEFI, Kernel Panic on postinstall on bless invocation

5 posts in this topic

Recommended Posts

Acer Aspire 5742G laptop

i5 nehalem (laptop produced oct 2009)

ddr3 1066MHz 4GB (2x2GB)

arrandale MCH

geforce 420m with 1024MB vram (discrete graphics only, intel graphics on cpu disabled by mobo)

 

using clover r1942

http://files.rajko.info/config.plist clover config

http://files.rajko.info/original_dsdt.zip original dsdt

 

UEFI version clover is booted on: 2.00 InsydeH2O so im using OsxLowMemFixDrv, not AptioFix

Slight graphical corruption on the bottom 5 lines, and on a rectangle bottom right (permuted boxes getting blit?)

nspci=0x3000 doesnt seem to do anything if it's even enabled

I have BusSpeed set to 133000 in config.plist of clover because that's the value both CloverEFI and UEFI-run clover detect (should it be 133333 ?)

 

Used injected kexts: FakeSMC.kext (from HWSensors_rev720_Release_10.6.tar.lzma), NullCPUPowerManagement.kext, VoodooPS2Controller.kext (without which i have no kb/mouse support on laptop)

 

Problem: http://i.imgur.com/iwqyqWs.jpg

bless shouldn't really do anything, should it ?

 

Maybe suggest me some DSDT fix bits to set ? I could have them as 0, or just HPET, but enabling Warning fix makes it fail on initial darwin boot with : 'unable to find driver for this platform ACPI'. Also, even though clover wiki says it's harmless if enabled, PatchAPIC set to true makes it hang after AppleAPIC... CPU listing thing

Share this post


Link to post
Share on other sites
Advertisement

Thanks, that made it reboot instead of panic there, and i got the boot entry to resume installation now (it panics immediately after, but i can try fixing that tomorrow)

The reason i thought i didn't need EmuVariable driver is because my firmware already has that DXE module, should i try and replace it in my firmware so that i don't need the driver in clover ? Here's the version i got in my firmware: http://files.rajko.info/CBD2E4D5-7068-4FF5-B866-9822B4AD8D60.efi

Share this post


Link to post
Share on other sites

I had to copy kexts to inject to 'Other' folder, not just 10.8

I guess 1st stage installer (from the dmg file) is considered 10.8, but 2nd stage is Other (didnt really find info about that)

Now installation is proceeding, will see what happens next

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By partha.slg123
      Hackintosh High Sierra 10.13.3 USB Installer Boot Into USB DIrectly Enter Exit Option Menu. Clover Boot Menu Not Showing. Plz Help .................
       

       
      My System Specification :

      CPU : Core i5 6400
      MB : Asus H110M-CS
      RAM : 8GB DDR 4
      HDD : WD 1TB For Windows And WD 500 GB For Hackintosh
      Bootloader : Clover
    • By MikixIT
      Salve a tutti, sono nuovo
      Ho un problema per installare il mio primo hackintosh 
      le mie spec sono: i7 720qm , gt730 2 gb ddr3, 8 gb di ram e una motherboard che non si capisce modello sia(perchè? perchè è un preassemblato a cui ho modificato i componenti mi lascio anche uno screen di cpuid se può essere utile comunque è legacy,comunque la motherboard è intel. )
       
      Comunque ho creato un boot usb con clever per installare Sierra e tutto va okay fin quiando vado in kernel panic, ho provato diverse boot flags ma non riesco ad arrivare all'installer di Cupertino
      CHIEDO AIUTO,grazie ancora aspetto risposte
    • By MikixIT
      Hi guys
      i need help for this kernel panic its the first hackintosh for me
      I posted photo error
      my spec: i7 720qm,gt 730 2 gb ddr3 msi,8 gb ram
      its a desktop
       
      Pls help me

    • By Tom Snow
      Hello everyone, ever since installing the security update at the end of January, I've been having two issues.
       
      The first is the kernel panic that happens every time I try to boot. After much research, here and elsewhere, I learned that the issue is Lilu.kext which I did not update prior to installing the security update. So now I have the latest version downloaded to a USB drive, but I cannot copy it to the hackintosh...
       
      Every time I try to boot into Recovery, the system just locks up. So I tried replacing the file via the UEFI shell and again from Kali, and in both cases I couldn't because both OS's see the Mac's file system as "read-only." I did some research on how to fix Recovery and found that I need to put FakeSMC.kext in the /EFI/CLOVER/Kexts/Other directory on the Recovery HD, which I cannot do for the same reason I can't replace the Lilu file (the HD is read-only to all other OS's).
       
      I tried booting off my old Snow Leopard CD, and that doesn't work either; every time I try it just quits mid-boot, resets the computer and reboots into Clover.
       
      Can anyone give me any suggestions? I'm out of ideas at this point.
    • By Dallastyle
      Hello Insanelymac,
      I've successfully installed Mac OS X Sierra on 2 32gb flash drives with them as a JBOD Raid. I can only get into the hackintosh if I use another USB flash drive with Clover installed on it. I've tried using a clover installer however that just installs on my Raid Disk. I've also noticed that when I open clover configurator, there are 2 EFI partitions but both of them were empty. I've tried moving the contents of the EFI on my Raid disk that clover installed but my BIOS does not detect it. Also when I use the other flash drive to boot into clover, there is another volume called "BOOT OS X" right next to my Raid Disk Volume that I use to boot from. I just want to install and boot off of my Raid usb flash drives. Really running out of options, Thanks guys.
×